cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marcel Kinard <cmarc...@gmail.com>
Subject Re: [Vote] 3.6.3 Cadence Release
Date Tue, 16 Sep 2014 13:02:55 GMT
Since the platforms don't have a shrinkwrap, those don't need to be updated, so we can leave
them as-is. So just the tools need to be updated.

I'm getting the same error on esprima-fb when updating the shrinkwrap. I'll update the browserify
dependency, update the shrinkwrap, build a new tools snapshot, publish it to npm as an rc
for final testing, and post it for a 24-hour vote. 

I don't think we need 72 hours given the number of reviews that 3.6.x has already had so far.

Archana / Bryan / Sergey, my apologies on the reviews/votes you've done on artifacts which
didn't completely publish. I'll test this last one in npm before putting it up for a vote.

On Sep 15, 2014, at 11:30 PM, Carlos Santana <csantana23@gmail.com> wrote:

> I was trying myself to generate a npm-shrinkwrap.json and got an error
> associated with the version of browserfy included in cordova-js which is
> included in cordova-lib:-)
> 0 info it worked if it ends with ok
> 1 verbose cli [ 'node',
> 1 verbose cli   '/Users/csantana23/.nvm/v0.10.31/bin/npm',
> 1 verbose cli   'shrinkwrap' ]
> 2 info using npm@1.4.27
> 3 info using node@v0.10.31
> 4 error Error: Problems were encountered
> 4 error Please correct and try again.
> 4 error invalid: esprima-fb@6001.1.0-dev-harmony-fb
> /Users/csantana23/Documents/SWG/git/cordova/cordova-cli/node_modules/cordova-lib/node_modules/cordova-js/node_modules/browserify/node_modules/derequire/node_modules/esprima-fb
> 4 erro
> 
> It looks we are using a 3 months old version 3.46
> Latest is 5.11.2 https://www.npmjs.org/package/browserify
> 
> If we update cordova-js dependency for browserfy from 3.46 to 5.11.2 the
> npm shrinkwrap command doesn't fail

Mime
View raw message