cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Gonzalez <martin.c.glez.g...@gmail.com>
Subject Re: CLI breaking changes on master
Date Thu, 31 Jul 2014 18:33:53 GMT
Yes, you are right, linking it with the latest cordova-lib in master works
pretty fine. I think that the master branch should be working stable and
working just typing "npm install", it just seems like an extra burden, get
to clone cordova-lib, then install it, then link it to the CLI node modules.

Well even so, the package.json on the CLI points to a cordova-lib that it
may not be fully compatible with CLI on master.
In that case, it would be better remove cordova-lib dependency from the
package.json, to force to get the right cordova-lib, install it and link
it, in order to make it work.
Have you consider that work in a different branch and publish into master,
only when the proper and fully compatible "cordova-lib" is released to npm,
and available to use?



2014-07-31 12:25 GMT-05:00 Josh Soref <jsoref@blackberry.com>:

> That's just because ‎you didn't link cordova-lib into the cordova-cli
> node-modules directory.
>
> A bug was filed today to fix the mobile spec create script to tell you
> what to do.
>
> Sent from my BlackBerry 10 smartphone.
>
>


-- 
Regards,
Martin Gonzalez

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message