cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matt Lantz <mattla...@gmail.com>
Subject Re: Accelerometer Build Issue
Date Sun, 11 May 2014 02:46:47 GMT
Thanks Sharon, I'm confused cause it lists the coremotion in the directories and Xcode and
I'm not sure what anis  is. Is it possible for me to update plugman via npm?

Cheers,

M. Lantz

Via my mobile device

> On May 10, 2014, at 9:06 PM, Shazron <shazron@gmail.com> wrote:
> 
> Looks like CoreMotion.framework was not added. There is a bug in plugman
> where this might happen - not sure if the patch landed in the new plugman
> being released (Anis?)
> 
>> On Saturday, May 10, 2014, Matt Lantz <mattlantz@gmail.com> wrote:
>> 
>> Hey all, I’m trying to add the device-motion plugin via command line in
>> OSX 10.9 and I’m using Xcode 5.1. It loads fine, but when I go to do the
>> build I get the following error. I followed Shazron’s blog to set the
>> details correctly. But I still get this error, any thoughts?
>> 
>> Ld build/emulator/Clairebot.app/Clairebot normal i386
>>    cd /Users/mlantz/Programming/PhoneGap/clairebot/platforms/ios
>>    export IPHONEOS_DEPLOYMENT_TARGET=7.0
>>    export
>> PATH="/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/usr/bin:/Applications/Xcode.app/Contents/Developer/usr/bin:/opt/local/bin:/opt/local/sbin:/opt/local/bin:/opt/local/sbin:/Users/mlantz/.nvm/v0.10.18/bin:/Applications/MAMP/bin/php/php5.5.3/bin/:/Users/mlantz/pebble-dev/arm-cs-tools/bin:/opt/local/bin:/opt/local/sbin:/Users/mlantz/.rvm/gems/ruby-1.9.3-p194/bin:/Users/mlantz/.rvm/gems/ruby-1.9.3-p194@global/bin:/Users/mlantz/.rvm/rubies/ruby-1.9.3-p194/bin:/Users/mlantz/.rvm/bin:/usr/local/bin:/usr/bin:/usr/local/lib:/Applications/MAMP/bin/php/php5.5.3/bin:/usr/local/php5/bin:/Users/mlantz/.composer/vendor/bin/:/Library/Frameworks/Python.framework/Versions/2.7/bin:/Developer/SDKs/Research
>> In Motion/BlackBerry 10 WebWorks SDK
>> 1.0.4.11/dependencies/tools/bin:/usr/local/mysql/bin:/Applications/MAMP/Library/bin:/Users/mlantz/Programming/devkit/bin:/Applications/MAMP/bin/ImageMagick/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/opt/X11/bin:/usr/local/git/bin:/opt/ImageMagick/bin:/usr/local/MacGPG2/bin
>> "
>> 
>> /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang
>> -arch i386 -isysroot
>> /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator7.1.sdk
>> -L/Users/mlantz/Programming/PhoneGap/clairebot/platforms/ios/build/emulator
>> -F/Users/mlantz/Programming/PhoneGap/clairebot/platforms/ios/build/emulator
>> -filelist
>> /Users/mlantz/Programming/PhoneGap/clairebot/platforms/ios/build/Clairebot.build/Debug-iphonesimulator/Clairebot.build/Objects-normal/i386/Clairebot.LinkFileList
>> -Xlinker -objc_abi_version -Xlinker 2 -weak_framework CoreFoundation
>> -weak_framework UIKit -weak_framework AVFoundation -weak_framework
>> CoreMedia -weak-lSystem -force_load
>> /Users/mlantz/Programming/PhoneGap/clairebot/platforms/ios/build/emulator/libCordova.a
>> -ObjC -fobjc-arc -fobjc-link-runtime -Xlinker -no_implicit_dylibs
>> -mios-simulator-version-min=7.0 -framework AssetsLibrary
>> /Users/mlantz/Programming/PhoneGap/clairebot/platforms/ios/build/emulator/libCordova.a
>> -framework CoreGraphics -framework MobileCoreServices -framework
>> CoreLocation -weak_framework AudioToolbox -Xlinker -dependency_info
>> -Xlinker
>> /Users/mlantz/Programming/PhoneGap/clairebot/platforms/ios/build/Clairebot.build/Debug-iphonesimulator/Clairebot.build/Objects-normal/i386/Clairebot_dependency_info.dat
>> -o
>> /Users/mlantz/Programming/PhoneGap/clairebot/platforms/ios/build/emulator/Clairebot.app/Clairebot
>> Undefined symbols for architecture i386:
>>  "_OBJC_CLASS_$_CMMotionManager", referenced from:
>>      objc-class-ref in CDVAccelerometer.o
>> ld: symbol(s) not found for architecture i386
>> clang: error: linker command failed with exit code 1 (use -v to see
>> invocation)
>> 
>> ** BUILD FAILED **
>> 
>> 
>> The following build commands failed:
>>        Ld build/emulator/Clairebot.app/Clairebot normal i386
>> (1 failure)
>> 
>> 
>> Not too sure what is up with the i386 build failing, is this something I
>> need to configure on my MacBook?
>> 
>> Cheers,
>> 
>> Matt Lantz

Mime
View raw message