cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Gonzalez <martin.c.glez.g...@gmail.com>
Subject Re: [Blackberry10] cordova emulate blackberry10 command fails
Date Wed, 28 May 2014 21:05:56 GMT
I have rebooted the simulator several times, installed the latest VMWare
and the one before of it.
It's curious that when I run blackberry-deploy -test <ip> it doesn't return
anything. Not a single response, if I use 'blackberry-deploy
-listDeviceInfo <ip>' it returns the proper output.



2014-05-28 15:57 GMT-05:00 Bryan Higgins <bryan@bryanhiggins.net>:

> If it is registered in DHCP leases, it should get automatically detected.
> There is a known issue when you upgrade VMWare, the file gets blown away
> and doesn't re-populate until you reboot the simulator.
>
> What output do you get from 'blackberry-deploy -test <ip>' ?
>
> You could also try manually registering the target (either by editing
> blackberry10.json or running 'target add') and then use 'cordova emulate
> --target'.
>
>
> On Wed, May 28, 2014 at 4:18 PM, Martin Gonzalez <
> martin.c.glez.glez@gmail.com> wrote:
>
> > I've been working with the Blackberry 10 simulator, recently I tried to
> > deploy an app into the simulator but it always fails, even if the
> simulator
> > is registered at .cordova\blackberry10.json.
> >
> > steps:
> > cordova create BB10Test
> > cordova platform add blackberry10
> > cordova build blackberry10
> >
> > then
> > cordova emulate blackberry10
> >
> > Error output:
> > C:\Users\Administrator\BB10Test>cordova emulate blackberry10
> > Running command:
> > c:\Users\Administrator\BB10Test\platforms\blackberry10\cordova\
> > run.bat --emulator
> > Searching for connected BlackBerry 10 Simulator (1/1)...
> > No connected BlackBerry 10 emulator found
> > Error:
> > c:\Users\Administrator\BB10Test\platforms\blackberry10\cordova\run.bat: C
> > ommand failed with exit code 2
> >     at ChildProcess.whenDone
> > (C:\Users\Administrator\nodist\bin\node_modules\cor
> > dova\node_modules\cordova-lib\src\cordova\superspawn.js:131:23)
> >     at ChildProcess.EventEmitter.emit (events.js:110:17)
> >     at maybeClose (child_process.js:992:16)
> >     at Process.ChildProcess._handle.onexit (child_process.js:1059:5)
> >
> > C:\Users\Administrator\BB10Test>
> >
> > The simulator it doesn't have any password, it has activated the
> > development mode, it has an ip address registered under the
> > vmnetdhcp.leases, and well it's throwing this error, I have checked my
> > environment and using the tools of Webworks 1.0, 2.0 and from the
> > Blackberry Native SDK it throws the same error.
> >
> > Cordova: 3.5.0-0-2.4.0
> > NodeJS(tested with): 10.26, 10.28, 11.12
> > BBTools(tested with):  Webworks 1.0, 2.0 and Native SDK
> > Simulator(tested with): 10.2.1.1925 & 10.3.0.440
> > OS: Win 7 64 Bit
> >
> > Is there somebody else facing this problem?
> >
> > --
> > Regards,
> > Martin Gonzalez
> >
>



-- 
Regards,
Martin Gonzalez

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message