cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Josh Soref <jso...@blackberry.com>
Subject Re: Some pain points from our users :'(
Date Mon, 28 Apr 2014 18:49:38 GMT
Shazron wrote:

>See: https://groups.google.com/d/msg/phonegap/II0qo-dSFWs/Fj8jkemGSbUJ

While I haven't written it, I've contemplated the metadata required for an
update check that could tell you when a given api breaks.

> because the API for device.platform changed and returned "ios" instead
>of "iPhone"/"iPad",

In principle, this would have been flagged to discourage updating the
plugin, and in theory a solver could have identified the last version from
before this break.

> Cordova/Phonegap docs where no help, because the version 3.4.0 version
>of the docs has broken links for all the plugins api docs.

This is a release process issue. We shouldn't have allowed the release to
happen w/ this broken. At least one of Edge or release-version should
always work.

> I then installed the "status bar" plugin for the ios 7 status bar. This
>plugin didn't work either. I always get an error in the XCode console
>that one or the other plugin does not exist or isn't cdv plugin...

I think this was the Xcode 5.1 bug, which I think we should have (process)
released the fix for sooner.


Mime
View raw message