cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shazron <shaz...@gmail.com>
Subject [ios] plugin os version support
Date Wed, 30 Apr 2014 20:13:55 GMT
With 3.4.0, the default template only supports iOS 6.0 and up. I know that
plugins can specify iOS support (apple-ios key in engines tag) but we
haven't done it yet. I'm not even sure if the cli plugin installer checks
for this yet.

Should we start using this in core plugins?

A specific case is this PR:
https://github.com/apache/cordova-plugin-camera/pull/24
It is using [ALAssetsLibrary authorizationStatus] and that API only occurs
in iOS 6.0 and up.

Wrapping this in a runtime os version check is not hard, however
(IsAtLeastVersion macro).

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message