cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gorkem Ercan <gorkem.er...@gmail.com>
Subject Suggestions for a problem
Date Mon, 07 Apr 2014 21:00:52 GMT
Hi,
With the independent platforms releases I have started to run into a
problem with my Eclipse tools that I am looking for some suggestions.

In the past, Cordova X.Y.Z meant all platforms would be tagged and released
with X.Y.Z. so if Eclipse tools needed to download Cordova version X.Y.Z,
it could just do so by using the X.Y.Z git tag. Now that platforms can do
independent releases the X.Y.Z tag for may not exist for a release for a
platform. So I actually need a way to determine what platform versions go
together. CLI actually captures that information on platforms.js for the
release but this is not enough for Eclipse tools as it does not capture the
data for older releases and Eclipse tools can be download and use older
versions.

Is there a place where I can extract this sort of platform version
information?
Also in the past, plugins could define engine compatibility as below
<engine name="cordova" version="1.7.0" />
How does plugman act with the independent releases now?
--
Gorkem

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message