cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexander Rasin <mitr...@gmail.com>
Subject Re: Developments on CB-4952 issue?
Date Wed, 05 Mar 2014 14:48:37 GMT
Ian, thank you so much for the suggestion.
I have not had any luck getting it to work.

Running the Cordova CLI you provided comes back with a message Plugin
"org.apache.cordova.file" already installed, 'sall good.
I tried removing the plugin first but that didn't help either.

Moreover, I have tried to put in the diffs myself, but I have so
little knowledge of Cordova structure that I haven't been able to do
that either.
I was able to find "CDVFile.m" to apply your changes, but I do not
know where the file
"diff --git a/file/index.html b/file/index.html" is even located to
add testPrivateURL function.

Any other suggestions?
Maybe there is something obvious I am missing with respects to getting
your fixed plugin?

Thank you,
Alex.


On 3/3/14, Ian Clelland <iclelland@chromium.org> wrote:
> Hi Alex,
>
> I believe that the issue is resolved, as of this morning. I've commented on
> the bug in JIRA -- File is now resolving all symlinks in file:/// URLs, so
> if your incoming URL starts with /private/, then that will be stripped.
>
> This didn't quite make it into v1.0.1, so for now, the unofficial solution
> is to install the dev branch of the File plugin.
>
> You can do that from github directly, or you can use the Codova CLI like
> this:
>
> $ cordova plugin add git://github.com/apache/cordova-plugin-file.git#dev
>
> Try that out and let me know if it solves your problem.
>
> Thanks,
> Ian
>
>
> On Sun, Mar 2, 2014 at 4:33 PM, Alexander Rasin <mitreya@gmail.com> wrote:
>
>> Hello,
>>
>> Apologies for bothering everyone -- but I am trying to figure out the
>> situation with CB-4952 bug (which prevents resolveLocalFileSystemURI
>> from getting access to the captured media files on iOS). This is
>> really, really putting a cramp into our development by killing an
>> important feature in the iOS app.
>>
>> Since the fix did not make it into the recent Cordova release, I am
>> trying to determine what the timeline on this is going to be. The
>> latest activity on the Jira page is two months old - is there a
>> preliminary fix/unofficial version available somewhere that addresses
>> this issue in the meantime?
>>
>> Thank you,
>> Alex.
>>
>

Mime
View raw message