cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anis KADRI <anis.ka...@gmail.com>
Subject Re: Versioned plugin dependencies
Date Tue, 10 Dec 2013 23:04:45 GMT
It should work (including with semver semantics).


On Tue, Dec 10, 2013 at 1:59 PM, Ian Clelland <iclelland@chromium.org>wrote:

> Anis -- does that work, or is it just the syntax that we'd like?
>
> And does it follow semver -- can I specify "1" to mean "at least major
> version 1"
>
>
> On Tue, Dec 10, 2013 at 4:57 PM, Anis KADRI <anis.kadri@gmail.com> wrote:
>
> > <dependency id="org.apache.cordova.file@version" />
> >
> >
> > On Tue, Dec 10, 2013 at 1:45 PM, Steven Gill <stevengill97@gmail.com>
> > wrote:
> >
> > > Same boat as Braden. Not sure if it has been implemented yet.
> > >
> > >
> > > On Tue, Dec 10, 2013 at 12:48 PM, Braden Shepherdson <
> > braden@chromium.org
> > > >wrote:
> > >
> > > > I think this has been much discussed, but I'm not aware of it
> actually
> > > > being implemented.
> > > >
> > > > Braden
> > > >
> > > >
> > > > On Tue, Dec 10, 2013 at 11:14 AM, Ian Clelland <
> iclelland@chromium.org
> > > > >wrote:
> > > >
> > > > > Do we have a way to specify, in plugin.xml, that a plugin depends
> on
> > a
> > > > > given (minimum) version of another plugin?
> > > > >
> > > > > I was sure that we did, but I can't find any documentation, code,
> or
> > > > tests
> > > > > for it, so I may have been hallucinating when I heard about it.
> > > > >
> > > > > It's relevant for file-transfer now; I think the next version of
> > > > > file-transfer is going to require v1.0.0+ of file to operate
> > properly,
> > > > and
> > > > > I'd like to be able to specify that requirement in plugin.xml
> > > > >
> > > > > Ian
> > > > >
> > > >
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message