cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Kim <timki...@gmail.com>
Subject Re: engines tag breaks cordova cli / plugman for BB10
Date Wed, 06 Nov 2013 21:39:10 GMT
After a little more digging, the fix for that issue should be in for 3.2.0.
You can update the platforms/blackberry10/cordova/lib/version.js file with
this one:
https://git-wip-us.apache.org/repos/asf?p=cordova-blackberry.git;a=blob;f=blackberry10/bin/templates/project/cordova/lib/version.js;h=694451fc702a9d700b9d9f7c6fc6e3e78da20b7d;hb=19cfe94a5a64379a4a3cd6cfaf2acaecb6d24671




On 6 November 2013 13:31, Tim Kim <timkim85@gmail.com> wrote:

> Hrm, looks like the version script is having trouble finding where the
> www/cordova.js file is located. The issue is if you try calling the version
> script from different levels of the cli created project, it won't be able
> to resolve where the cordova.js file should be.
>
>
> On 6 November 2013 13:10, Don Coleman <don.coleman@gmail.com> wrote:
>
>>  When plugin.xml contains an engines tag, the plugin fails to install with
>> cordova or plugman
>>
>> If the engines tag is removed from plugin.xml, the plugin installs OK
>>
>> $ cordova create foo
>> $ cd foo
>> $ cordova platform add blackberry10
>> $ cordova plugin add https://github.com/chariotsolutions/phonegap-nfc
>> Fetching plugin from "https://github.com/chariotsolutions/phonegap-nfc
>> "...
>> Starting installation of "com.chariotsolutions.nfc.plugin" for
>> blackberry10
>> [TypeError: Invalid Version: The file "www/cordova.js" does not exist.]
>>
>> $ cordova -v
>> 3.1.0-0.2.0
>> $ plugman -v
>> plugman version 0.14.0
>> $ uname -a
>> Darwin xvi 13.0.0 Darwin Kernel Version 13.0.0: Thu Sep 19 22:22:27 PDT
>> 2013; root:xnu-2422.1.72~6/RELEASE_X86_64 x86_64
>>
>
>
>
> --
> Timothy Kim
>
>


-- 
Timothy Kim

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message