cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Kemp <drk...@google.com>
Subject Re: buildbot failure in Cordova Testing on IOS_Master
Date Wed, 09 Oct 2013 20:53:41 GMT
Hi James,

That problem went away with the new commit, but now I am getting two
failures on one iPad (6.0__iPad3,1)
the other iPad passes all tests (6.1.3 - iPad2,5):

I tried it twice with the same results.

failures0specAccelerometer (navigator.accelerometer) getCurrentAcceleration
accelerometer.spec.5 success callback Acceleration object should return a
rec...<http://172.23.188.139:5900/_utils/document.html?mobilespec_results/ios__master__1381351230__6.0__iPad3%2C1#expand>
assertions0exceptiontimeout: timed out after 7500 msec waiting for win
never calledtrace1specAccelerometer (navigator.accelerometer)
watchAcceleration accelerometer.spec.5 success callback Acceleration object
should return a recent
t...<http://172.23.188.139:5900/_utils/document.html?mobilespec_results/ios__master__1381351230__6.0__iPad3%2C1#expand>
assertions0exceptionExpected 1381351391115.972 to be greater than
1381351399373.trace





On Wed, Oct 9, 2013 at 4:36 PM, Andrew Grieve <agrieve@chromium.org> wrote:

> Awesome!
>
>
> On Wed, Oct 9, 2013 at 4:34 PM, James Jong <wjamesjong@gmail.com> wrote:
>
> > Added.
> > -James Jong
> >
> > On Oct 9, 2013, at 4:23 PM, James Jong <wjamesjong@gmail.com> wrote:
> >
> > > Ah yes.  Sorry.  I need to add the new framework.
> > >
> > > -James Jong
> > >
> > > On Oct 9, 2013, at 4:08 PM, Andrew Grieve <agrieve@chromium.org>
> wrote:
> > >
> > >> James - our build bot thinks you broke things! Sadly still haven't got
> > it exposed, but the error is:
> > >>
> > >>
> > >>
> > >>
> >
> /Users/drkemp/buildbot/slave_ios2/IOS_Master/build/mobilespec/platforms/ios/build/emulator/mobilespec.app/mobilespec
> > >> Undefined symbols for architecture armv7:
> > >>  "_OBJC_CLASS_$_CMMotionManager", referenced from:
> > >>      objc-class-ref in CDVAccelerometer.o
> > >> ld: symbol(s) not found for architecture armv7
> > >> clang: error: linker command failed with exit code 1 (use -v to see
> > invocation)
> > >>
> > >>
> > >> ** BUILD FAILED **
> > >>
> > >>
> > >> The following build commands failed:
> > >>      Ld build/emulator/mobilespec.app/mobilespec normal armv7
> > >> (1 failure)
> > >>
> > >>
> > >>
> > >> Likely you need to add CoreMotion to the <frameworks> of the plugin.
> > >>
> > >>
> > >
> >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message