cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Kemp <drk...@google.com>
Subject Re: buildbot failure in Cordova Testing on IOS_Master
Date Wed, 09 Oct 2013 23:08:26 GMT
Hi James,
I had to head out of the office and I am not there tomorrow.
I re-ran the tests just now (remotely) on both master and release just to
check again.
If something went screwy with the device, then the release one should have
a failure too (it was clean)

On release branch, both iPads pass all tests.

On Master Branch, one iPad passes all tests, one failed one test...

6.0 - iPad3,1 failed one test.

I can't give much more detail without pulling the device and running the
tests on a development station.
I can't do that until Friday, but if you don't get anywhere I can do that.

failures0specAccelerometer (navigator.accelerometer) getCurrentAcceleration
accelerometer.spec.5 success callback Acceleration object should return a
rec...<http://172.23.188.139:5900/_utils/document.html?mobilespec_results/ios__master__1381359373__6.0__iPad3%2C1#expand>
assertions0exceptionExpected 1381359462105.384 to be greater than
1381359462107.trace





On Wed, Oct 9, 2013 at 6:43 PM, James Jong <wjamesjong@gmail.com> wrote:

> Thanks Shaz.  Does anyone else have an iOS 6.0 device they can run the
> tests on?
>
> -James Jong
>
> On Oct 9, 2013, at 6:23 PM, Shazron <shazron@gmail.com> wrote:
>
> > Just tested on an iPad 3, iOS 7.0.2  with the dev branch of
> > cordova-plugin-device-motion, it passes all tests.
> >
> >
> > On Wed, Oct 9, 2013 at 2:45 PM, Shazron <shazron@gmail.com> wrote:
> >
> >> I have an iPad 3 here with 7.0.2 - I'll test and verify soon.
> >>
> >>
> >> On Wed, Oct 9, 2013 at 2:29 PM, James Jong <wjamesjong@gmail.com>
> wrote:
> >>
> >>> I'm ok if you want to skip it.  Right now the issue looks like it's
> >>> limited to iPad 3 and/or 6.0.
> >>> -James Jong
> >>>
> >>> On Oct 9, 2013, at 5:23 PM, Steven Gill <stevengill97@gmail.com>
> wrote:
> >>>
> >>>> Should I skip this plugin for today's release until these issues get
> >>> sorted?
> >>>>
> >>>>
> >>>> On Wed, Oct 9, 2013 at 2:01 PM, James Jong <wjamesjong@gmail.com>
> >>> wrote:
> >>>>
> >>>>> Hmm...   Let me check if I have an iPad at 6.0.  I definitely don't
> >>> have
> >>>>> an iPad3 but may have an iPad2.
> >>>>>
> >>>>> -James Jong
> >>>>>
> >>>>> On Oct 9, 2013, at 4:53 PM, David Kemp <drkemp@google.com>
wrote:
> >>>>>
> >>>>>>
> >>>>>> Hi James,
> >>>>>>
> >>>>>> That problem went away with the new commit, but now I am getting
two
> >>>>> failures on one iPad (6.0__iPad3,1)
> >>>>>> the other iPad passes all tests (6.1.3 - iPad2,5):
> >>>>>>
> >>>>>> I tried it twice with the same results.
> >>>>>>
> >>>>>> failures
> >>>>>> 0
> >>>>>> spec
> >>>>>> Accelerometer (navigator.accelerometer) getCurrentAcceleration
> >>>>> accelerometer.spec.5 success callback Acceleration object should
> >>> return a
> >>>>> rec...
> >>>>>> assertions
> >>>>>> 0
> >>>>>> exception
> >>>>>> timeout: timed out after 7500 msec waiting for win never called
> >>>>>> trace
> >>>>>> 1
> >>>>>> spec
> >>>>>> Accelerometer (navigator.accelerometer) watchAcceleration
> >>>>> accelerometer.spec.5 success callback Acceleration object should
> >>> return a
> >>>>> recent t...
> >>>>>> assertions
> >>>>>> 0
> >>>>>> exception
> >>>>>> Expected 1381351391115.972 to be greater than 1381351399373.
> >>>>>> trace
> >>>>>>
> >>>>>>
> >>>>>>
> >>>>>>
> >>>>>>
> >>>>>> On Wed, Oct 9, 2013 at 4:36 PM, Andrew Grieve <agrieve@chromium.org
> >
> >>>>> wrote:
> >>>>>> Awesome!
> >>>>>>
> >>>>>>
> >>>>>> On Wed, Oct 9, 2013 at 4:34 PM, James Jong <wjamesjong@gmail.com>
> >>> wrote:
> >>>>>>
> >>>>>>> Added.
> >>>>>>> -James Jong
> >>>>>>>
> >>>>>>> On Oct 9, 2013, at 4:23 PM, James Jong <wjamesjong@gmail.com>
> wrote:
> >>>>>>>
> >>>>>>>> Ah yes.  Sorry.  I need to add the new framework.
> >>>>>>>>
> >>>>>>>> -James Jong
> >>>>>>>>
> >>>>>>>> On Oct 9, 2013, at 4:08 PM, Andrew Grieve <agrieve@chromium.org>
> >>>>> wrote:
> >>>>>>>>
> >>>>>>>>> James - our build bot thinks you broke things! Sadly
still
> haven't
> >>>>> got
> >>>>>>> it exposed, but the error is:
> >>>>>>>>>
> >>>>>>>>>
> >>>>>>>>>
> >>>>>>>>>
> >>>>>>>
> >>>>>
> >>>
> /Users/drkemp/buildbot/slave_ios2/IOS_Master/build/mobilespec/platforms/ios/build/emulator/mobilespec.app/mobilespec
> >>>>>>>>> Undefined symbols for architecture armv7:
> >>>>>>>>> "_OBJC_CLASS_$_CMMotionManager", referenced from:
> >>>>>>>>>    objc-class-ref in CDVAccelerometer.o
> >>>>>>>>> ld: symbol(s) not found for architecture armv7
> >>>>>>>>> clang: error: linker command failed with exit code
1 (use -v to
> see
> >>>>>>> invocation)
> >>>>>>>>>
> >>>>>>>>>
> >>>>>>>>> ** BUILD FAILED **
> >>>>>>>>>
> >>>>>>>>>
> >>>>>>>>> The following build commands failed:
> >>>>>>>>>    Ld build/emulator/mobilespec.app/mobilespec normal
armv7
> >>>>>>>>> (1 failure)
> >>>>>>>>>
> >>>>>>>>>
> >>>>>>>>>
> >>>>>>>>> Likely you need to add CoreMotion to the <frameworks>
of the
> >>> plugin.
> >>>>>>>>>
> >>>>>>>>>
> >>>>>>>>
> >>>>>>>
> >>>>>>>
> >>>>>>
> >>>>>
> >>>>>
> >>>
> >>>
> >>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message