cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew Grieve <agri...@chromium.org>
Subject Re: open link in system browser
Date Fri, 13 Sep 2013 03:29:51 GMT
Hey Kirill,

Your setup sounds correct to me. Shouldn't need to touch your access tag.
Only thought that you didn't cover is that you're waiting for the
deviceready event to fire?


On Thu, Sep 12, 2013 at 4:52 PM, Kirill Kireyev <kirill@instagrok.com>wrote:

>  Hi, sorry to ask this question again, but I simply can't get this to work.
>
> The problem I have is when I do
>     window.open(url, "_system")  (e.g. window.open("http://www.cnn.com"<http://www.cnn.com>,
> "_system") )
> I want to open the link on the system (e.g. safari) browser, but instead
> it opens the content inside the app (blocking the previous screen).
>
> I'm using Cordova 3.0.0. This behavior happens both on Android and iOS.
>
> I've installed InAppBrowser ( cordova plugin add
> https://git-wip-us.apache.org/repos/asf/cordova-plugin-inappbrowser.git), like the instructions
said. I have also added the clause to the
> platform-specific config.xml, e.g. in /platforms/android/res/xml/config.xml:
> <feature name="InAppBrowser">
>         <param name="android-package"
> value="org.apache.cordova.InAppBrowser" />
> </feature>
>
> Could this be because I have:
> <access origin="*" />
> in the config.xml? Do I need to change that setting?
>
> Please help!
>
> Thanks,
> Kirill
>
> --
> *Kirill Kireyev, PhD*
> Founder/CTO instaGrok.com <http://www.instagrok.com>
> kirill@instagrok.com
> Twitter: @instaGrok <http://twitter.com/InstaGrok>
> FB: facebook.com/instagrok <http://www.facebook.com/instagrok>
>  <http://www.instagrok.com>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message