cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bryan Higgins <br...@bryanhiggins.net>
Subject Re: blackberry os 10 issues
Date Mon, 19 Aug 2013 13:09:21 GMT
Once the plugin is installed, you should have access to the blackberry
namespace:

https://github.com/blackberry/cordova-blackberry-plugins/blob/master/plugin/com.blackberry.invoke.card/plugin.xml#L22-L24

I'll respond to the other issue you had directly on github. You likely need
to add some encoding to the data property.


On Mon, Aug 19, 2013 at 9:00 AM, Ivan Baktsheev <owner@apla.me> wrote:

> hi,
>
> thank you for answers. i have some more questions. please see below.
>
> On 18 Aug 2013, at 18:50, Bryan Higgins <bryan@bryanhiggins.net> wrote:
>
> > Hi Ivan,
> >
> > Thanks for the feedback. Very much appreciated. I will try to address
> your
> > comments inline.
> >
> > Thanks,
> > Bryan
> >
> >
> > On Sat, Aug 17, 2013 at 6:51 PM, Ivan Baktsheev <dot.and.thing@gmail.com
> >wrote:
> >
> >> hi everyone.
> >>
> >> deployment for blackberry10 is broken in many places.
> >>
> >> 1) main issue with blackberry is "blackberry" object in javascript not
> >> populated. i need to use "blackberry.invoke" in my plugin, but adding
> those
> >> features doesn't work:
> >> <feature id="blackberry.invoke" required="true" version="1.0.0.0" />
> >> <feature id="blackberry.invoke.card" />
> >>
> >> please tell me how to use it.
> >>
> >
> >
> > These are BlackBerry features which are not part of Apache Cordova. You
> > will need to install the plugins from this repo until they become
> available
> > on the plugin registry.
> >
> > https://github.com/blackberry/cordova-blackberry-plugins/
>
> got idea. client part make request to the "local web server". "local web
> server" then launch www/plugins/[plugin]/index.js
>
> plugin installed, but i cannot use blackberry.invoke.card. filled issue:
>
> https://github.com/blackberry/BB10-WebWorks-Framework/issues/678
>
> >
> >>
> >> 2) second issue is with persistent storage. when i trying to reach file,
> >> located in persistent storage, i've got wrong url.
> >> this is a gist for problem demonstration:
> >> https://gist.github.com/apla/6258386
> >> on ios and android this gist gives me alert, but not on a blackberry.
> >>
> >> this can be an api restriction or a bug.
> >>
> >>
> > You cannot write to a filesystem of size 0. Please log an issue if you're
> > still having problems. There is a developer actively working on getting
> the
> > file api to behave more like the other platforms - although there are
> > quirks with all of them.
> >
> >
> >> another issues:
> >>
> >> 3) www/config.xml:
> >> 3.1) platform/blackberry10/www/config.xml must be cleared from <icon
> >> platform="!blackberry"/> because packager goes mad with so many icons
> with
> >> unknown sizes (minor, because it doesn't affect package build)
> >> 3.2) config.xml template must contains actual configurations for
> >> blackberry (icon size 114x114)
> >> 3.3) <gap:splash> is not renamed to <rim:splash> in
> >> "platform/blackberry10/www/config.xml" after running `cordova prepare
> >> blackberry`
> >> 3.4) <preference name="orientation" value="portrait" /> not converted
to
> >> <feature id="blackberry.app">
> >>        <param name="orientation" value="portrait" />
> >> </feature>
> >> in resulting config.xml file (probably
> >> https://issues.apache.org/jira/browse/CB-4563)
> >> 3.5) rim xmlns must be added
> >> 3.6) error if <content src="index.html"/> omitted (probably
> >> https://issues.apache.org/jira/browse/CB-4570)
> >>
> >> so, i was patched cordova-cli to make 3.1, 3.3, 3.4, 3.5, 3.6 works.
> >> please review my pull request.
> >>
> >
> > Thanks for this! I'll review these changes on Monday.
> >
> > Btw, there is another pull request outstanding to convert all of the
> > blackberry.app features to preference
> >
> > https://github.com/apache/cordova-blackberry/pull/70
>
> saw your comments, thank you
>
> >> 4) cordova-cli:
> >>
> >> version 3.0.4 copies config.xml from template over actual one and make
> >> unusable build.
> >> probably someone need to release newer cordova-cli version for
> blackberry
> >> builds (at least after commit 83a042a75ab83370b74a5413a2721cceb08e6399)
> >
> >
> > I believe the NPM release is already up to 3.0.6.
>
> missed release, my fault

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message