cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew Grieve <agri...@chromium.org>
Subject Re: plugin.xml specification
Date Wed, 14 Aug 2013 20:37:54 GMT
#1 <lib-file> == dynamically linked libs that exist in your plugin == .so,
.dll, .dylib, .jar
#2 <framework> == dynamically linked libs provided by the OS == .so, .dll,
.dylib, .framework
#3 <src> == precompiled object file / lib that exists in you plugins == .a,
.o
#4 <src framework="true"> == ???... Might refer to the fake .framework
files that some iOS projects distribute (that have .a in them instead of
.dylib). Example might just be wrong (should say .framework not .a)

so... I think all four do different things, but maybe we can coalesce them
better?

e.g. we could have have framework=true be unnecessary by just looking at
the file extension.
Not sure about a sane way to combine the others... Maybe add a section to
the docs that highlights the differences?


On Wed, Aug 14, 2013 at 3:53 PM, Michal Mocny <mmocny@chromium.org> wrote:

> I would think it will be more confusing to use the same tag name that does
> something different depending on which platform its used on, so I'de vote
> to leave them specific and not try to unify.
>
> I do think thats its hard to tell which tag applies to which platform, so
> perhaps a platform prefix or platform attribute that is verified by a
> schema (ie, <framework platform=ios ...>, <lib-file platform=bb10 ...>)
>
> Not sure about the sourrce-file framework=true issue, but that sounds
> confusing :)
>
>
> On Wed, Aug 14, 2013 at 3:41 PM, Filip Maj <fil@adobe.com> wrote:
>
> > Hey all,
> >
> > There's an issue filed for plugman [1], wherein a user had an issue
> > authoring a plugin.xml file for a plugin and got tripped up with
> > <framework> [2] and <lib-file> [3] support on different platforms.
> >
> > Currently: <framework> only applies to iOS. <lib-file> only for BB10.
To
> > confuse matters further, we also support <source-file> elements with a
> > framework=true attribute (that is iOS-only).
> >
> > :)
> >
> > Any ideas on how to consolidate all this stuff? How to make this
> > specification clearer/more readable/more intuitive?
> >
> > [1] https://issues.apache.org/jira/browse/CB-4430
> > [2]
> >
> http://cordova.apache.org/docs/en/3.0.0/plugin_ref_spec.md.html#Plugin%20Sp
> > ecification_framework
> > [3]
> >
> http://cordova.apache.org/docs/en/3.0.0/plugin_ref_spec.md.html#Plugin%20Sp
> > ecification_lib_file
> > [4]
> >
> http://cordova.apache.org/docs/en/3.0.0/plugin_ref_spec.md.html#Plugin%20Sp
> > ecification_source_file
> >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message