cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Filip Maj <...@adobe.com>
Subject Re: 3.0.0 Testing thread
Date Tue, 16 Jul 2013 19:53:28 GMT
I guess it will. Fkn semver man

I see a few workarounds:

- massage any versions returned with 'rc' strings in it so they are semver
compatible
- remove <engine> constraint checking in plugman
- remove <engine> tags from plugin.xmls

On 7/16/13 12:47 PM, "Shazron" <shazron@gmail.com> wrote:

>So is this semver version thing going to be a problem for people using
>plugman on its own then? (at least on the rc1 anyways)
>
>
>On Tue, Jul 16, 2013 at 6:31 AM, Joe Bowser <bowserj@gmail.com> wrote:
>
>> I'm running the latest.  The issue was with the use of semver.  The
>> version template must return a valid semver version, which 3.0.0rc1 is
>> not.
>>
>> On Tue, Jul 16, 2013 at 6:22 AM, Shazron <shazron@gmail.com> wrote:
>> > Hmm I'm running plugman 0.9.1 - what version did you run Joe
>> >
>> >
>> > On Tue, Jul 16, 2013 at 6:20 AM, Joe Bowser <bowserj@gmail.com> wrote:
>> >
>> >> I keep getting invalid version 3.0.0rc1 on plugman. :(
>> >>
>> >> On Mon, Jul 15, 2013 at 6:54 PM, Shazron <shazron@gmail.com> wrote:
>> >> > So far I went and tested with the plugins (specified in the
>> >> > dependencies-plugin on cordova-mobile-spec) on master for iOS,
>>with 1
>> >> test
>> >> > failing:
>> >> >
>> >> > File API DirectoryReader interface readEntries file.spec.109 should
>> >> return
>> >> > an empty entry list on the second call.
>> >> > Expected 0 not to be 0.
>> >>
>>


Mime
View raw message