cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Filip Maj <...@adobe.com>
Subject Re: error when doing 'sudo npm install -g cordova'
Date Wed, 03 Jul 2013 15:58:41 GMT
Yeah there is an outstanding issue with newer versions of npm (above 1.3)
where this creeps up.

I believe isaacs and the npm folk are aware of the issue. Downgrading to
npm 1.2.x seems to fix this.

On 7/2/13 6:54 PM, "Tyler Wilson" <twilson@pulse-robotics.com> wrote:

>Sorry, ignore this. I should have 'google'd first. My apologies.
>
>- Tyler
>
>On Jul 2, 2013, at 9:48 PM, Tyler Wilson <twilson@pulse-robotics.com>
>wrote:
>
>> I get this when trying to install cordova cli:
>> 
>> ...
>> npm http 304 https://registry.npmjs.org/express
>> npm ERR! TypeError: Invalid Version: 3.0.0alpha1
>> npm ERR!     at new SemVer
>>(/opt/local/lib/node_modules/npm/node_modules/semver/semver.js:257:11)
>> npm ERR!     at SemVer.compare
>>(/opt/local/lib/node_modules/npm/node_modules/semver/semver.js:296:13)
>> npm ERR!     at compare
>>(/opt/local/lib/node_modules/npm/node_modules/semver/semver.js:410:31)
>> npm ERR!     at rcompare
>>(/opt/local/lib/node_modules/npm/node_modules/semver/semver.js:420:10)
>> npm ERR!     at Array.sort (native)
>> npm ERR!     at Function.maxSatisfying
>>(/opt/local/lib/node_modules/npm/node_modules/semver/semver.js:838:6)
>> npm ERR!     at next
>>(/opt/local/lib/node_modules/npm/lib/cache.js:699:21)
>> npm ERR!     at /opt/local/lib/node_modules/npm/lib/cache.js:678:5
>> npm ERR!     at saved
>>(/opt/local/lib/node_modules/npm/node_modules/npm-registry-client/lib/get
>>.js:138:7)
>> npm ERR!     at Object.oncomplete (fs.js:107:15)
>> npm ERR! If you need help, you may report this log at:
>> npm ERR!     <http://github.com/isaacs/npm/issues>
>> npm ERR! or email it to:
>> npm ERR!     <npm-@googlegroups.com>
>> 
>> npm ERR! System Darwin 12.4.0
>> npm ERR! command "/opt/local/bin/node" "/opt/local/bin/npm" "install"
>>"-g" "cordova"
>> npm ERR! cwd /Users/tylerwilson
>> npm ERR! node -v v0.10.12
>> npm ERR! npm -v 1.3.1
>> npm http 304 https://registry.npmjs.org/glob
>> Š
>> 
>> Perhaps it is an nom error. I am running on OS X 10.8.4 using node and
>>nom installed via mac ports.
>> 
>> Thanks,
>> tyler
>


Mime
View raw message