cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carlos Santana <csantan...@gmail.com>
Subject Re: error generating cordova-docs ( ./bin/generate --edge )
Date Tue, 09 Jul 2013 16:47:54 GMT
ding ding ding ! we have a winner

gem install --version '= 1.5.2' nokogiri

cordova-docs:(master)$ ./bin/generate --edge
 => Generating the Cordova Documentation for edge-en...
 => /Users/csantana23/Documents/SWG/git/apache/cordova-docs/public



On Tue, Jul 9, 2013 at 12:25 PM, Shazron <shazron@gmail.com> wrote:

> Might be because I'm using:
> nokogiri (1.5.2, 1.4.4)
>
>
>
>
> On Tue, Jul 9, 2013 at 9:13 AM, Carlos Santana <csantana23@gmail.com>
> wrote:
>
> > I tried ruby 1.8.7 (by the way not longer supported) and I have other
> > problems.
> >
> >  nokogiri requires ruby >= 1.9.2
> >
> > How you guys got it working with 1.8.7?
> >
> > Any advice?
> >
> > cordova-docs:(master)$ rvm install 1.8.7
> >
> > Install of ruby-1.8.7-p374 - #complete
> > WARNING: Please be aware that you just installed ruby that is no more
> > supported, more details here:
> >
> >     http://www.ruby-lang.org/en/news/2013/06/30/we-retire-1-8-7/
> >
> > Please consider upgrading to ruby-2.0.0-p247 which will have all of the
> > latest security patches.
> > cordova-docs:(master)$ rvm use 1.8.7
> >
> > cordova-docs:(master)$ gem install nokogiri
> >
> > ERROR:  Error installing nokogiri:
> >     nokogiri requires Ruby version >= 1.9.2.
> >
> >
> > cordova-docs:(master)$ ./bin/generate --edge
> >
> >
> >
> /Users/csantana23/.rvm/rubies/ruby-1.8.7-p374/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in
> > `gem_original_require': no such file to load -- nokogiri (LoadError)
> >     from
> >
> >
> /Users/csantana23/.rvm/rubies/ruby-1.8.7-p374/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in
> > `require'
> >     from ./bin/../lib/cordova/add_title.rb:19
> >     from
> >
> >
> /Users/csantana23/.rvm/rubies/ruby-1.8.7-p374/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in
> > `gem_original_require'
> >     from
> >
> >
> /Users/csantana23/.rvm/rubies/ruby-1.8.7-p374/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in
> > `require'
> >     from ./bin/../lib/docs_generator.rb:23
> >     from ./bin/generate:22:in `require'
> >     from ./bin/generate:22
> >
> >
> >
> >
> > On Tue, Jul 9, 2013 at 9:27 AM, Carlos Santana <csantana23@gmail.com>
> > wrote:
> >
> > > thanks I will use rvm to get 1.8.7 and try again.
> > >
> > > If this is the problem, I will update the README with the info
> > >
> > > Thanks for the quick response
> > >
> > >
> > > On Mon, Jul 8, 2013 at 9:53 PM, Andrew Grieve <agrieve@chromium.org
> > >wrote:
> > >
> > >> 1.8.7 here as well. I remember having a hard time getting jodoc
> working
> > >> the
> > >> first time I built docs :(
> > >>
> > >>
> > >> On Mon, Jul 8, 2013 at 7:22 PM, Shazron <shazron@gmail.com> wrote:
> > >>
> > >> > I'm still using ruby 1.8.7 (which came with the system) and that
> > >> worked, so
> > >> > I reckon it could be ruby 1.9.x?
> > >> >
> > >> >
> > >> > On Mon, Jul 8, 2013 at 4:05 PM, Carlos Santana <
> csantana23@gmail.com>
> > >> > wrote:
> > >> >
> > >> > > Anyone has a clue on what I'm doing wrong?
> > >> > >
> > >> > > https://issues.apache.org/jira/browse/CB-4126
> > >> > >
> > >> > >
> > >> > > cordova-docs:(master)$ ./bin/generate --edge
> > >> > >
> > >> > >
> > >> >
> > >>
> >
> /Users/csantana23/.rvm/rubies/ruby-1.9.2-p320/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
> > >> > > `require':
> > >> > >
> > >> > >
> > >> >
> > >>
> >
> /Users/csantana23/Documents/SWG/git/apache/cordova-docs/lib/cordova/jodoc.rb:28:
> > >> > > syntax error, unexpected tCONSTANT, expecting ']' (SyntaxError)
> > >> > >     @template_directories = [ File.join TEMPLATE_PATH, 'default'
]
> > >> > >                                                      ^
> > >> > >
> > >> > >
> > >> >
> > >>
> >
> /Users/csantana23/Documents/SWG/git/apache/cordova-docs/lib/cordova/jodoc.rb:28:
> > >> > > dynamic constant assignment
> > >> > >     @template_directories = [ File.join TEMPLATE_PATH, 'default'
]
> > >> > >                                                       ^
> > >> > >
> > >> > >
> > >> >
> > >>
> >
> /Users/csantana23/Documents/SWG/git/apache/cordova-docs/lib/cordova/jodoc.rb:28:
> > >> > > syntax error, unexpected ']', expecting tCOLON2 or '[' or '.'
> > >> > > from
> > >> > >
> > >> > >
> > >> >
> > >>
> >
> /Users/csantana23/.rvm/rubies/ruby-1.9.2-p320/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
> > >> > > `require'
> > >> > > from
> > >> > >
> > >> > >
> > >> >
> > >>
> >
> /Users/csantana23/Documents/SWG/git/apache/cordova-docs/lib/docs_generator.rb:26:in
> > >> > > `<top (required)>'
> > >> > > from <internal:lib/rubygems/custom_require>:29:in `require'
> > >> > > from <internal:lib/rubygems/custom_require>:29:in `require'
> > >> > > from ./bin/generate:22:in `<main>'
> > >> > >
> > >> > >
> > >> > > --
> > >> > > Carlos Santana
> > >> > > <csantana23@gmail.com>
> > >> > >
> > >> >
> > >>
> > >
> > >
> > >
> > > --
> > > Carlos Santana
> > > <csantana23@gmail.com>
> > >
> >
> >
> >
> > --
> > Carlos Santana
> > <csantana23@gmail.com>
> >
>



-- 
Carlos Santana
<csantana23@gmail.com>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message