cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Braden Shepherdson <bra...@chromium.org>
Subject Re: Cordova.js now at 2.9.0rc1 for real
Date Wed, 19 Jun 2013 18:34:11 GMT
One further piece of information for this Node version nonsense: 0.6 is too
old. 0.8 is too old, but only very thinly: we call os.tmpdir(), which
exists only in 0.10, renamed from os.tmpDir() in 0.8. os.tmpDir() still
exists as a synonym in 0.10 (though I don't think it appears in the
documentation, it's clearly there in the source), so we can change the
spelling of these few calls and return our support for Node 0.8 in the CLI
tools. I think this is probably a good idea.

Braden



On Wed, Jun 19, 2013 at 2:17 PM, Steven Gill <stevengill97@gmail.com> wrote:

> I use nvm to switch back to node v0.8.14 when running jake on cordova-js.
> Not a good solution.
>
>
> On Wed, Jun 19, 2013 at 11:08 AM, Andrew Grieve <agrieve@chromium.org
> >wrote:
>
> > hmm, I did indeed just upgrade my node version. blowing away node_modules
> > didn't seem to fix it though.
> >
> >
> > On Wed, Jun 19, 2013 at 12:04 PM, Braden Shepherdson <
> braden@chromium.org
> > >wrote:
> >
> > > This happened to me back when I upgraded node. I ended up doing rm -rf
> > > node_modules and then npm install. I eventually managed to claw my way
> > back
> > > to a working Jake. Why it fails utterly silently, and with code 0,
> > puzzles
> > > me.
> > >
> > > Braden
> > >
> > >
> > > On Wed, Jun 19, 2013 at 12:00 PM, Jeffrey Heifetz
> > > <jheifetz@blackberry.com>wrote:
> > >
> > > > I've been seeing similar issues with Jake since I've upgraded my node
> > and
> > > > it is definitely related to Jake failing with dependencies. I have
> yet
> > to
> > > > find the real root cause.
> > > >
> > > > On 13-06-18 8:27 PM, "Andrew Grieve" <agrieve@chromium.org> wrote:
> > > >
> > > > >As both Jesse and Shaz pointed out, I ran coho to update cordova.js
> > > > >snapshots, but it resulted in them being set to 2.7.0 instead of
> > 2.9.0.
> > > > >
> > > > >This is now fixed (new commits for 2.9.0rc1), and I've updated the
> > coho
> > > > >script to not push by default (so that commits can be inspected).
> > > > >
> > > > >The root problem is that jake is existing without failure and
> without
> > > > >printing anything to the console. Can anyone else verify if this is
> > > > >happening for them?
> > > > >
> > > > >I debugged it as far as to see that removing the
> "complainwhitespace"
> > > > >dependency from the "hint" task fixed things, but I don't know why
> > that
> > > > >is.
> > > >
> > > >
> > > > ---------------------------------------------------------------------
> > > > This transmission (including any attachments) may contain
> confidential
> > > > information, privileged material (including material protected by the
> > > > solicitor-client or other applicable privileges), or constitute
> > > non-public
> > > > information. Any use of this information by anyone other than the
> > > intended
> > > > recipient is prohibited. If you have received this transmission in
> > error,
> > > > please immediately reply to the sender and delete this information
> from
> > > > your system. Use, dissemination, distribution, or reproduction of
> this
> > > > transmission by unintended recipients is not authorized and may be
> > > unlawful.
> > > >
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message