cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ian Clelland <iclell...@google.com>
Subject Re: jake errors
Date Thu, 13 Jun 2013 17:30:33 GMT
I haven't had a problem with node 0.10.x on Linux, but I can confirm that
0.6.x is too old. Unfortunately, it's what's shipping with a lot of distros.

My workflow on Linux has been to download and compile node.js from current
sources, and use that. Is that what you were doing, or did you try a
packaged version?

If there's a compatibility issue with 0.10, we should probably address
that. I'll try it again today to see if anything's changed.

Ian


On Thu, Jun 13, 2013 at 11:37 AM, Plaquette, Paul
<paul.plaquette@intel.com>wrote:

> Hi folks,
>
> It appears that the jake errors iI was having were coming by using an "old
> " version of node
>
> I am using an Ubuntu 12.04, on witch the package version for node is
> limited to 0.6.12.
>
> I am also using my personal mac, on witch I  have a 0.8.1 version of node.
> On my Mac I do not have there errors.
>
> By doing more investigation on that I came to question node version.
>
> On my Ubuntu machine, i tried the last version 0.10.10 , but it seems it is
> too much advance  ;-)
> the build end telling that fs.exitSync is replacing path.existSync without
> actually building the cordova.js files...
>
> Eventually I get node sources (git repository) and i built a 0.8.1 release
> version and it is now working fine.
>
> @Paul
>
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
>
> Paul Plaquette,
> Senior Software Engineer
> Intel Corporation SAS *
> *
> *SSG/OTC: Open Source Technology Center*
> France, Montpellier
>
>
>
> On Mon, Jun 10, 2013 at 4:21 PM, Plaquette, Paul
> <paul.plaquette@intel.com>wrote:
>
> >
> > Hi folks,
> >
> > I am having following errors with jake (see hereafter)
> > I tried after a jake clean , and with a fresh repository
> >
> > the last :
> > TypeError: Object #<Object> has no method 'existsSync'
> >     at Object.generate
> >
> (/home/pplaquette/Work/git/CORDOVA/Apache/cordova-js/build/packager.js:39:13)
> >
> > is about a "fs" object.
> > I see a require ('fs') for fs but i cannot find the file that is actually
> > loaded
> >
> > Does someone see what may going wrong?
> >
> > Regards,
> > Paul
> >
> >
> > jake traces:
> > --------------------------------
> > pplaquette@pplaquette-linux:~/Work/git/CORDOVA/Apache/cordova-js$ jake
> > lib/blackberry10/plugin/blackberry10/fileTransfer.js: line 28, col 9,
> > 'resolveLocalFileSystemURI' is not defined.
> > lib/blackberry10/plugin/blackberry10/fileTransfer.js: line 63, col 22,
> > 'FileTransferError' is not defined.
> > lib/blackberry10/plugin/blackberry10/fileTransfer.js: line 63, col 40,
> > 'FileTransferError' is not defined.
> > lib/blackberry10/plugin/blackberry10/fileTransfer.js: line 82, col 46,
> > 'FileUploadResult' is not defined.
> > lib/blackberry10/plugin/blackberry10/fileTransfer.js: line 88, col 38,
> > 'FileTransferError' is not defined.
> > lib/blackberry10/plugin/blackberry10/fileTransfer.js: line 88, col 56,
> > 'FileTransferError' is not defined.
> > lib/blackberry10/plugin/blackberry10/fileTransfer.js: line 90, col 38,
> > 'FileTransferError' is not defined.
> > lib/blackberry10/plugin/blackberry10/fileTransfer.js: line 90, col 56,
> > 'FileTransferError' is not defined.
> > lib/blackberry10/plugin/blackberry10/fileTransfer.js: line 94, col 34,
> > 'FileTransferError' is not defined.
> > lib/blackberry10/plugin/blackberry10/fileTransfer.js: line 94, col 52,
> > 'FileTransferError' is not defined.
> > lib/blackberry10/plugin/blackberry10/fileTransfer.js: line 97, col 34,
> > 'FileTransferError' is not defined.
> > lib/blackberry10/plugin/blackberry10/fileTransfer.js: line 97, col 52,
> > 'FileTransferError' is not defined.
> > lib/blackberry10/plugin/blackberry10/fileTransfer.js: line 127, col 26,
> > 'FileTransferError' is not defined.
> > lib/blackberry10/plugin/blackberry10/fileTransfer.js: line 127, col 44,
> > 'FileTransferError' is not defined.
> > lib/blackberry10/plugin/blackberry10/fileTransfer.js: line 130, col 22,
> > 'FileTransferError' is not defined.
> > lib/blackberry10/plugin/blackberry10/fileTransfer.js: line 130, col 40,
> > 'FileTransferError' is not defined.
> > lib/blackberry10/plugin/blackberry10/fileTransfer.js: line 143, col 22,
> > 'FileTransferError' is not defined.
> > lib/blackberry10/plugin/blackberry10/fileTransfer.js: line 143, col 40,
> > 'FileTransferError' is not defined.
> > lib/blackberry10/plugin/blackberry10/fileTransfer.js: line 168, col 22,
> > 'FileTransferError' is not defined.
> > lib/blackberry10/plugin/blackberry10/fileTransfer.js: line 168, col 40,
> > 'FileTransferError' is not defined.
> > lib/blackberry10/plugin/blackberry10/fileTransfer.js: line 176, col 38,
> > 'FileTransferError' is not defined.
> > lib/blackberry10/plugin/blackberry10/fileTransfer.js: line 176, col 56,
> > 'FileTransferError' is not defined.
> > lib/blackberry10/plugin/blackberry10/fileTransfer.js: line 179, col 34,
> > 'FileTransferError' is not defined.
> > lib/blackberry10/plugin/blackberry10/fileTransfer.js: line 179, col 52,
> > 'FileTransferError' is not defined.
> > lib/blackberry10/plugin/blackberry10/fileTransfer.js: line 182, col 30,
> > 'FileTransferError' is not defined.
> > lib/blackberry10/plugin/blackberry10/fileTransfer.js: line 182, col 48,
> > 'FileTransferError' is not defined.
> > lib/blackberry10/plugin/blackberry10/fileTransfer.js: line 184, col 30,
> > 'FileTransferError' is not defined.
> > lib/blackberry10/plugin/blackberry10/fileTransfer.js: line 184, col 48,
> > 'FileTransferError' is not defined.
> > lib/blackberry10/plugin/blackberry10/utils.js: line 181, col 33,
> > 'NamedNodeMap' is not defined.
> > lib/blackberry10/plugin/blackberry10/utils.js: line 206, col 33,
> > 'NamedNodeMap' is not defined.
> > lib/blackberry10/plugin/blackberry10/event.js: line 82, col 60,
> 'unescape'
> > is not defined.
> > lib/blackberry10/plugin/FileWriter.js: line 98, col 41, 'Blob' is not
> > defined.
> > lib/blackberry10/platform.js: line 45, col 10, Missing semicolon.
> > lib/scripts/plugin_loader.js: line 113, col 32, Use '===' to compare with
> > '0'.
> > lib/scripts/bootstrap-blackberry10.js: line 85, col 36, 'cordova' is not
> > defined.
> > lib/scripts/bootstrap-blackberry10.js: line 96, col 13, 'cordova' is not
> > defined.
> > lib/scripts/bootstrap-blackberry10.js: line 106, col 24, 'cordova' is not
> > defined.
> > lib/scripts/bootstrap-blackberry10.js: line 111, col 24, 'cordova' is not
> > defined.
> > lib/scripts/bootstrap-blackberry10.js: line 113, col 48, 'cordova' is not
> > defined.
> > lib/scripts/bootstrap-blackberry10.js: line 113, col 95, 'cordova' is not
> > defined.
> > lib/scripts/bootstrap-blackberry10.js: line 114, col 17, 'cordova' is not
> > defined.
> >
> >
> > building 2.7.0rc1-84-g62c5786
> > jake aborted.
> > TypeError: Object #<Object> has no method 'existsSync'
> >     at Object.generate
> >
> (/home/pplaquette/Work/git/CORDOVA/Apache/cordova-js/build/packager.js:39:13)
> > (See full trace by running task with --trace)
> > pplaquette@pplaquette-linux:~/Work/git/CORDOVA/Apache/cordova-js$ $$
> >
> >
> >
> >
> >
> > ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> >
> > Paul Plaquette,
> > Senior Software Engineer
> > Intel Corporation SAS *
> > *
> > *SSG/OTC: Open Source Technology Center*
> > France, Montpellier
> >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message