cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew Grieve <agri...@chromium.org>
Subject Re: config.xml - phonegap properties
Date Thu, 09 May 2013 15:57:10 GMT
I'm away until Monday as well. I think this will also need an issue to
update plugman because the change to the top-level tag name broke some
xpaths.


On Mon, May 6, 2013 at 5:17 PM, Filip Maj <fil@adobe.com> wrote:

> Go for it, I am busy all week with conference stuff so am MIA until next
> week!
>
> On 5/6/13 2:05 PM, "Gorkem Ercan" <gorkem.ercan@gmail.com> wrote:
>
> >Hi Fil,
> >As a note the cordova-cli bits are not yet integrated. I think it would be
> >great if at least the config.xml on the default www template is updated
> >from the PR.
> >
> >Also we need the JIRAs for the remaining platforms to catch up. If you
> >prefer I can fire them as well.
> >
> >I will have doc updates coming your way.
> >
> >--
> >Gorkem
> >
> >--
> >Gorkem
> >http://www.gorkem-ercan.com
> >
> >
> >On Mon, May 6, 2013 at 3:42 PM, Filip Maj <fil@adobe.com> wrote:
> >
> >> Thanks Andrew!
> >>
> >> On 5/6/13 12:12 PM, "Andrew Grieve" <agrieve@chromium.org> wrote:
> >>
> >> >I merged these on Friday :)
> >> >
> >> >
> >> >On Tue, Apr 30, 2013 at 5:38 PM, Filip Maj <fil@adobe.com> wrote:
> >> >
> >> >> Sorry Gorkem I am completely swamped with other work, have
> >>presentation
> >> >>to
> >> >> do next week as well, so won't have time to merge your stuff for a
> >>while
> >> >> yet.
> >> >>
> >> >> Perhaps another committer on this list can take a look at your work.
> >>If
> >> >> anyone is, please see the original thread of discussion:
> >> >> http://markmail.org/message/tbf4epryuh2vvfiw
> >> >>
> >> >> On 4/30/13 2:31 PM, "Gorkem Ercan" <gorkem.ercan@gmail.com> wrote:
> >> >>
> >> >> >I do not think phonegap-version is the only problematic one, all
4
> >> >> >preferences that are present on the cli's template are ignored
by
> >>the
> >> >> >platforms at runtime.
> >> >> >
> >> >> >The unified config.xml work I did earlier (which is not yet merged
)
> >> >> >handles this by having the preferences from all platforms on the
> >>cli's
> >> >> >template.
> >> >> >--
> >> >> >Gorkem
> >> >> >
> >> >> >
> >> >> >--
> >> >> >Gorkem
> >> >> >http://www.gorkem-ercan.com
> >> >> >
> >> >> >
> >> >> >On Tue, Apr 30, 2013 at 1:58 PM, Michael Brooks
> >> >> ><michael@michaelbrooks.ca>wrote:
> >> >> >
> >> >> >> Hi Andreas,
> >> >> >>
> >> >> >> Good catch and we've already logged this issue as CB-3279
[1].
> >> >> >>
> >> >> >> I haven't had a chance to investigate it, but I imagine it
was
> >> >>either a
> >> >> >> copy & paste mistake when the config.xml support was first
added
> >>the
> >> >> >>CLI.
> >> >> >> Since the version is 1.9.0, I imagine it was copied from a
> >> >> >>PhoneGap/Build
> >> >> >> project that was set to PhoneGap 1.9.0. In short, you can
ignore
> >>it
> >> >>and
> >> >> >>it
> >> >> >> should be removed.
> >> >> >>
> >> >> >> Thanks for the heads up!
> >> >> >> Michael
> >> >> >>
> >> >> >> [1] https://issues.apache.org/jira/browse/CB-3279
> >> >> >>
> >> >> >>
> >> >> >> On Tue, Apr 30, 2013 at 8:49 AM, Andreas Sander
> >> >> >> <andreas.sander@hotmail.de>wrote:
> >> >> >>
> >> >> >> > Hi,
> >> >> >> >
> >> >> >> > I've a short question concerning the www/config.xml property
> >>file.
> >> >> >> >
> >> >> >> > I compiled my cordova project with Cordova v1.6.0 via
npm and
> >> >>command
> >> >> >> > line. After creating a project with cordova create command,
> >>there
> >> >>are
> >> >> >>two
> >> >> >> > config.xml properties concerning phonegap.
> >> >> >> >
> >> >> >> >  <preference name="phonegap-version" value="1.9.0"
/>
> >> >> >> > <feature name="http://api.phonegap.com/1.0/device"
/>
> >> >> >> >
> >> >> >> > Is this a left-over of phonegap code before cordova existed?
> >> >> >> >
> >> >> >> > Nevertheless:
> >> >> >> >
> >> >> >> > Why does the phonegap-version is set to 1.9.0 when I'm
building
> >>it
> >> >> >>with
> >> >> >> > cordova 2.6.0? Is there a meaning for this value, which
I don't
> >> >>get?
> >> >> >>Or
> >> >> >> can
> >> >> >> > I change it to the same version number, hence 2.6.0?
> >> >> >> >
> >> >> >> > Any help is appreciated!
> >> >> >> >
> >> >> >> > With best regards,
> >> >> >> >
> >> >> >> > Andreas Sander
> >> >> >> >
> >> >> >>
> >> >>
> >> >>
> >>
> >>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message