cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michal Mocny <mmo...@chromium.org>
Subject Re: plugin.xml config-file setting not copying all tags
Date Mon, 22 Apr 2013 22:10:58 GMT
Actually, the chrome mobile apps project has a bootstrap plugin which
basically does that right now.  We got lucky and the plugin content tag is
appended after the app content tag, so we win :)  Would love to see
something less volatile.

-Michal


On Mon, Apr 22, 2013 at 5:11 PM, Filip Maj <fil@adobe.com> wrote:

> Interesting. I think I tend to agree with that. Some app-level config.xml
> elements (such as access tags) could be duplicated across multiple
> plugins. `prepare` is aware of _all_ plugins installed in an app, so it
> may make sense to move it in there.
>
> The content tag is an interesting one. What if two plugins want to change
> the content entry point into an app? Heh.
>
> On 4/22/13 11:42 AM, "Michal Mocny" <mmocny@chromium.org> wrote:
>
> >found it.  CB-3188 updated.
> >
> >I think its another argument for moving more stuff out to prepare step.
> > Essentially the plugman install time work is being overwritten on
> >prepare.
> >
> >
> >On Fri, Apr 19, 2013 at 2:51 PM, Michal Mocny <mmocny@chromium.org>
> wrote:
> >
> >> I am, sorry, I should have said so.
> >>
> >>
> >> On Fri, Apr 19, 2013 at 2:36 PM, Anis KADRI <anis.kadri@gmail.com>
> >>wrote:
> >>
> >>> I don't believe Shaz is using the future branch. The future branch is
> >>> mostly untested, partly broken and under heavy development right now.
> >>>Are
> >>> you using the future branch Michal ?
> >>>
> >>>
> >>> On Fri, Apr 19, 2013 at 11:29 AM, Michal Mocny <mmocny@chromium.org>
> >>> wrote:
> >>>
> >>> > Very odd, I just tried using the exact same syntax and even moved the
> >>> tag
> >>> > to the same relative file location.  Not working.
> >>> >
> >>> > Shaz, are you using the future branch?
> >>> >
> >>> >
> >>> > On Fri, Apr 19, 2013 at 1:00 PM, Shazron <shazron@gmail.com>
wrote:
> >>> >
> >>> > > I was just playing with plugman yesterday with the Facebook Connect
> >>> > > plugin, it did however install my access tags that were in the
> >>> top-level:
> >>> > >
> >>> > >
> >>> >
> >>>
> >>>
> https://github.com/phonegap/phonegap-facebook-plugin/blob/plugman-FB-SDK
> >>>-3.2.1/plugin.xml#L12-L16
> >>> > >
> >>> > >
> >>> > > On Fri, Apr 19, 2013 at 7:23 AM, Michal Mocny <mmocny@chromium.org
> >
> >>> > wrote:
> >>> > >
> >>> > >> Seems access tag does not work in top-level either.
> >>> > >>
> >>> > >>
> >>> > >> On Fri, Apr 19, 2013 at 10:00 AM, Michal Mocny
> >>><mmocny@chromium.org>
> >>> > >> wrote:
> >>> > >>
> >>> > >> > CB-3188
> >>> > >> >
> >>> > >> >
> >>> > >> > On Thu, Apr 18, 2013 at 6:52 PM, Anis KADRI
> >>><anis.kadri@gmail.com>
> >>> > >> wrote:
> >>> > >> >
> >>> > >> >> the access tag should be top-level (as a common practice)
but
> >>>it
> >>> > should
> >>> > >> >> work anyway....weird...
> >>> > >> >>
> >>> > >> >>
> >>> > >> >> On Thu, Apr 18, 2013 at 12:22 PM, Filip Maj <fil@adobe.com>
> >>> wrote:
> >>> > >> >>
> >>> > >> >> > Bug, file that shizzle yo
> >>> > >> >> >
> >>> > >> >> > On 4/18/13 12:19 PM, "Michal Mocny" <mmocny@google.com>
> >>>wrote:
> >>> > >> >> >
> >>> > >> >> > >Anis/Fil:
> >>> > >> >> > >
> >>> > >> >> > >I've got a plugin that contains the following
in the ios
> >>> platform
> >>> > >> >> section:
> >>> > >> >> > >
> >>> > >> >> > >    <config-file target="config.xml"
parent="/widget">
> >>> > >> >> > >      <access origin="chrome-extension://*"
/>
> >>> > >> >> > >      <content
> >>> > >> >> >
> >>> > >> >>
> >>> > >>
> >>> >
> >>>
> >>>>src="chrome-extension://ohgfbmefaoadakchflddcopcmphnlcba/chromeapp.html
> >>>>"
> >>> > >> >> > >/>
> >>> > >> >> > >    </config-file>
> >>> > >> >> > >
> >>> > >> >> > >The content tag is being copied fine, but
the access tag is
> >>>not
> >>> > >> (!).  I
> >>> > >> >> > >was
> >>> > >> >> > >under the impression that config-file would
do a raw copy
> >>>over
> >>> to
> >>> > >> >> platform
> >>> > >> >> > >config?  Are we whitelisting/blacklisting
tags somehow?
> >>>Bug?
> >>> >  User
> >>> > >> >> error?
> >>> > >> >> > >
> >>> > >> >> > >-Michal
> >>> > >> >> >
> >>> > >> >> >
> >>> > >> >>
> >>> > >> >
> >>> > >> >
> >>> > >>
> >>> > >
> >>> > >
> >>> >
> >>>
> >>
> >>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message