cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michal Mocny <mmo...@chromium.org>
Subject Re: plugin.xml config-file setting not copying all tags
Date Fri, 19 Apr 2013 18:51:08 GMT
I am, sorry, I should have said so.


On Fri, Apr 19, 2013 at 2:36 PM, Anis KADRI <anis.kadri@gmail.com> wrote:

> I don't believe Shaz is using the future branch. The future branch is
> mostly untested, partly broken and under heavy development right now. Are
> you using the future branch Michal ?
>
>
> On Fri, Apr 19, 2013 at 11:29 AM, Michal Mocny <mmocny@chromium.org>
> wrote:
>
> > Very odd, I just tried using the exact same syntax and even moved the tag
> > to the same relative file location.  Not working.
> >
> > Shaz, are you using the future branch?
> >
> >
> > On Fri, Apr 19, 2013 at 1:00 PM, Shazron <shazron@gmail.com> wrote:
> >
> > > I was just playing with plugman yesterday with the Facebook Connect
> > > plugin, it did however install my access tags that were in the
> top-level:
> > >
> > >
> >
> https://github.com/phonegap/phonegap-facebook-plugin/blob/plugman-FB-SDK-3.2.1/plugin.xml#L12-L16
> > >
> > >
> > > On Fri, Apr 19, 2013 at 7:23 AM, Michal Mocny <mmocny@chromium.org>
> > wrote:
> > >
> > >> Seems access tag does not work in top-level either.
> > >>
> > >>
> > >> On Fri, Apr 19, 2013 at 10:00 AM, Michal Mocny <mmocny@chromium.org>
> > >> wrote:
> > >>
> > >> > CB-3188
> > >> >
> > >> >
> > >> > On Thu, Apr 18, 2013 at 6:52 PM, Anis KADRI <anis.kadri@gmail.com>
> > >> wrote:
> > >> >
> > >> >> the access tag should be top-level (as a common practice) but
it
> > should
> > >> >> work anyway....weird...
> > >> >>
> > >> >>
> > >> >> On Thu, Apr 18, 2013 at 12:22 PM, Filip Maj <fil@adobe.com>
wrote:
> > >> >>
> > >> >> > Bug, file that shizzle yo
> > >> >> >
> > >> >> > On 4/18/13 12:19 PM, "Michal Mocny" <mmocny@google.com>
wrote:
> > >> >> >
> > >> >> > >Anis/Fil:
> > >> >> > >
> > >> >> > >I've got a plugin that contains the following in the
ios
> platform
> > >> >> section:
> > >> >> > >
> > >> >> > >    <config-file target="config.xml" parent="/widget">
> > >> >> > >      <access origin="chrome-extension://*" />
> > >> >> > >      <content
> > >> >> >
> > >> >>
> > >>
> > >src="chrome-extension://ohgfbmefaoadakchflddcopcmphnlcba/chromeapp.html"
> > >> >> > >/>
> > >> >> > >    </config-file>
> > >> >> > >
> > >> >> > >The content tag is being copied fine, but the access
tag is not
> > >> (!).  I
> > >> >> > >was
> > >> >> > >under the impression that config-file would do a raw
copy over
> to
> > >> >> platform
> > >> >> > >config?  Are we whitelisting/blacklisting tags somehow?
 Bug?
> >  User
> > >> >> error?
> > >> >> > >
> > >> >> > >-Michal
> > >> >> >
> > >> >> >
> > >> >>
> > >> >
> > >> >
> > >>
> > >
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message