cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brian>
Subject [cordova-cli] versioning
Date Fri, 22 Mar 2013 17:53:15 GMT
Right now the global executable is version locked to a Cordova
release. If you have a project running 2.5 you are required to have
Cordova/CLI 2.5. If you need to then work in Cordova 2.4 you need to
downgrade (not really but you would to be safe).

In Grunt .4 the global executable is dumb. It just shells to locally
installed ./node_module version of Grunt. This enables project level
versioning of Grunt. Nice feature. We can do the same thing: with the
caveat that you would then require a package.json and ./node_modules
folder in our Cordova projects.


View raw message