cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Filip Maj <...@adobe.com>
Subject Re: [iOS] Call for testing
Date Fri, 08 Feb 2013 21:45:33 GMT
Cool, thanks for checking it out Becky.

That is exactly where some users are reporting their issues.

Funny thing is, cordova-cli only runs "xcodebuild -version" to determine
if Xcode is installed or not. As long as the xcodebuild executable is in
your PATH it *should* work. I don't see how Xcode-select factors in here
though. Any ideas? Is my approach of checking iOS min reqs by shelling out
to xcodebuild too naïve?

On 2/8/13 1:38 PM, "Becky Gibson" <gibson.becky@gmail.com> wrote:

>Interesting.  I ran this once and it worked (I had to use sudo).  Then, I
>realized that I might have my xcode-selects variable set wrong since I
>recently downloaded Xcode 4.6 via the iOS downloads page rather than via
>the AppStore.   I put Xcode 4.6 into a subdirectory:
> /Applications/Xcode46/Xcode.app rather than right in the Applications
>folder.  I realized that I should have also updated my xcode-select
>variable.   I did that:
>      sudo /usr/bin/xcode-select -switch
>/Applications/Xcode46/Xcode.app/Contents/Developer
>Then when I run sudo npm install -g cordova again,  iOS fails:
>   WARNING: Your system does not meet requirements to create iosprojects.
>See error output below.
>Xcode is not installed. Cannot add iOS platform.
>SKIPPING ios bootstrap.
>
>So, I would guess it has to do with the xcode-selects value.
>
>Also, FWIW running the suggested sudo chown -R <yourusername>
>/usr/local/lib/node_modules/cordova  command and it didn't work for me.  I
>haven't investigate that yet.
>
>-becky
>
>
>On Fri, Feb 8, 2013 at 3:59 PM, Filip Maj <fil@adobe.com> wrote:
>
>> Hey everyone,
>>
>> I've had a couple of reports of people using the cordova-cli tools and
>> having issues installing. Apparently the post-install script
>>("bootstrap")
>> complains that Xcode is not installed on the system. Both users were
>> running Xcode 4.6.
>>
>> I've since upgraded my Xcode and done both a fresh install as well as an
>> upgrade from old cli tools to new, and cannot reproduce (the bootstrap
>> works; I get "SUCCESS: min reqs for iOS met").
>>
>> Could other contributors on the ML here, who have Xcode at least 4.5.2
>> installed, give it a shot and see if the installation goes through?
>>
>> To install, have node installed and run: npm install -g cordova
>> (you may need to put sudo in front of that if your node is installed
>> globally)
>>
>> Near the end of the installation process you should see something like:
>>
>> > cordova@2.4.4 install /usr/local/lib/node_modules/cordova
>> > node bootstrap.js && ./bin/notice
>>
>> SUCCESS: Minimum requirements for blackberry met.
>> BOOTSTRAPPING blackberry...
>> SUCCESS: Minimum requirements for ios met.
>> BOOTSTRAPPING ios...
>> SUCCESS: ios ready to rock!
>> SUCCESS: blackberry ready to rock!
>> SUCCESS: Minimum requirements for android met.
>> BOOTSTRAPPING android...
>> SUCCESS: android ready to rock!
>>
>>
>> If you do notice issues, please file any details on the following JIRA
>> issue I have set up to track details:
>> https://issues.apache.org/jira/browse/CB-2404
>>
>> Thanks in advance!
>> Fil
>>
>>


Mime
View raw message