cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shazron Abdullah (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CB-2301) EXC_BAD_ACCESS on resume/wake on iOS device
Date Wed, 30 Jan 2013 01:06:12 GMT

    [ https://issues.apache.org/jira/browse/CB-2301?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13566032#comment-13566032
] 

Shazron Abdullah commented on CB-2301:
--------------------------------------

Are you using WebSQL/localStorage at all? Try disabling BackupWebStorage: http://docs.phonegap.com/en/2.3.0/guide_project-settings_ios_index.md.html#Project%20Settings%20for%20iOS
                
> EXC_BAD_ACCESS on resume/wake on iOS device
> -------------------------------------------
>
>                 Key: CB-2301
>                 URL: https://issues.apache.org/jira/browse/CB-2301
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: iOS
>    Affects Versions: 2.2.0
>         Environment: iPhone 5 running iOS 6.0.2 and Phonegap 2.2.0. (Xcode 4.5.2 on Mountain
Lion)
>            Reporter: Ross Holdway
>            Assignee: Shazron Abdullah
>            Priority: Critical
>              Labels: cordova, ios, phonegap
>
> I have implemented a websocket connection (using socket.io) within my app which it uses
to communicate with the server. On locking and waking the device, it disconnects and reconnects
correctly, but on leaving the device locked for 1 minute or longer when unlocking, the application
will crash sometimes instantly, or sometimes after reconnecting with the server.
> If I do the same, but run my app within mobile Safari, it does not crash, leading me
to believe this is an issue with Phonegap/Cordova. 
> On app crash, within Xcode I get within WebThread - WebCore::ThreadTImers::sharedTimerFiredInternal()
an EXC_BAD_ACCESS (code=1) error
> Screenshot of crash state in Xcode -http://pictat.com/i/2013/1/28/24904screenshot.jpg
> Hopefully someone will have an idea as to what could be causing this, or recommend some
tests for me to run etc because I'm really clueless on how to proceed with fixing this!
> Many Thanks,
> Ross

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message