cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Filip Maj <...@adobe.com>
Subject Re: [ANDROID] What are the specific requirements re: Android SDK?
Date Fri, 18 Jan 2013 00:32:54 GMT
This may be wrong, but didn't the target ID have to match up to a specific
number or something?

On 1/17/13 4:22 PM, "Joe Bowser" <bowserj@gmail.com> wrote:

>Here it is on one line:
>android list target | grep "Android 4.2"
>
>Basically, if you have a non-zero result, you're good to go as far as
>the scripts are concerned.  Android's binary backwards compatible, so
>as long as you support the minimum SDK and compile against the target
>SDK, the user should be fine..  You only need earlier targets if you
>want to test on earlier versions of Android.
>
>
>On Thu, Jan 17, 2013 at 4:14 PM, Filip Maj <fil@adobe.com> wrote:
>> I am trying to solve this: https://issues.apache.org/jira/browse/CB-2219
>>
>> Tl;dr: check that user has correct minimums installed w.r.t Android SDK.
>>
>> There is already something like this in place in the CLI tools for iOS.
>> The tools runs `xcodebuild -version` and then using semver I parse
>>through
>> it to see if the minimum is installed (4.5.1).
>>
>> Looking through the android implementation's read me this isn't
>>explicitly
>> listed out. From experience I (think) the requirements are "download all
>> the targets".
>>
>> Is this correct?
>>
>> Can we brainstorm the specific requirements and list them out here? I
>>want
>> the CLI tools to do something like (and this is rough but hopefully you
>> get the idea):
>>
>> 1. run `android list target`
>> 2. grep through the output and determine if the user has the necessary
>> stuff
>>
>> If we can list everything out in this thread I will do my best to codify
>> it.
>>
>> Thanks all,
>> Fil
>>


Mime
View raw message