cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Filip Maj <...@adobe.com>
Subject Cordova-CLI: Version handling
Date Thu, 17 Jan 2013 19:15:53 GMT
Questions: how to handle moving between cordova versions? Do we want to
support both upgrading and downgrading? How to land support for this in
cordova-cli?

My answers:

- how to handle moving between cordova versions?
  Suggestion: add an "upgrade" (and "downgrade") script to each platform
implementation, which handles moving from the previous version to the
current and vice-versa.
- Do we want to support both upgrading and downgrading?
  IMO: Yes.
- How to land support for this in cordova-cli?

  CLI tools shell out to above-mentioned scripts.

In my mind we would draw a line in the sand (let's say, 2.4, or 2.5) on
which Cordova version(s) support upgrade and downgrade scripts. From that
point on we can tell our users "OK, if you run 2.4 (or 2.5) or newer, you
can use these scripts. Or you can use cordova-cli if you want a unified
tool for this. If you are below this version, take a look at the
"Upgrading" guides written for the platforms in the docs."

Thoughts? Any other suggestions?


Mime
View raw message