cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shazron <shaz...@gmail.com>
Subject Re: Issues with Mobile-spec on iOS
Date Wed, 02 Jan 2013 23:03:28 GMT
The deviceready thing might be this issue:
https://issues.apache.org/jira/browse/CB-2094


On Wed, Jan 2, 2013 at 2:59 PM, Becky Gibson <gibson.becky@gmail.com> wrote:

> I have been testing 2.3rc2 on my iPhone 4s and running into strange
> problems in mobile-spec.
>
> All of the automatic tests pass (although I do see an error about contacts
> not cleaning up in the log that I have to investigate).
>
> I seem to be able to run the manual tests, but then some of the tests stop
> working.   I can hit back to get out of the test page and back to the menu
> but loading a new test page and pressing one of the buttons on  to actually
> run a test will do nothing.   And, sometimes if I go back to run the
> automatic tests again the page is blank except for the back link.   In some
> ways it seems that deviceReady is not firing some of the time but I think
> most manual test pages have a timeout for that and display an alert.  I'm
> not seeing an alert.
>
> At first I thought it might be some specific test that was jamming up the
> system but I haven't found a repeatable case.   I thought it might be
> location because that wasn't working for me - but now it seems to be
> working.   To try and duplicate run the automatic tests and then start
> running the manual tests.  After a few tests, the manual ones seem to stop
> working.  Notifications vibrate is a quick test to see if it has failed.
>
> I hope it is just gremlins on my device but I'm hoping someone else can
> take a look.  I'll create a new project and test some more tomorrow.
>
> Note that I fixed a bug (CB-2109) in the manual audio test so be sure to
> pull master before running.
>
> -becky
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message