cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Becky Gibson <gibson.be...@gmail.com>
Subject SOLVED the iOS FileTransfer Errors I was seeing
Date Wed, 30 Jan 2013 21:27:24 GMT
I took the time to reacquaint myself with the Jasmine tests and also did
some debugging to see why I was consistently getting a failure in the
FileTransfer tests.

I was specifically having problems with the download to an unknown host.
 After looking at (and taking the time to understand) the tests I realize
that foobar.apache.org SHOULD be in the whitlelist.  I was getting a fail
in the download from unknown host test due to my internet provider trying
to return a "helpful" search assist page for foobar.apache.org!  Since the
internet provider url was not in the whitelist, I was getting a whitelist
error back in the payload rather than a failure.  When I put the internet
provider (*verizon*) in the whitelist I get a timeout.   However, when I
run in 3G mode the download  unknown host test passed (although others fail
due to timeouts).

Whew - mystery solved.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message