cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joe Bowser (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (CB-1947) Secure whitelisted URLs not loading in Android
Date Tue, 11 Dec 2012 15:11:21 GMT

    [ https://issues.apache.org/jira/browse/CB-1947?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13529039#comment-13529039
] 

Joe Bowser edited comment on CB-1947 at 12/11/12 3:09 PM:
----------------------------------------------------------

So, it specifically doesn't load in the iFrame.  I've just been vanilla testing it so far,
but I can see it totally crapping out on the iFrame based on what I've seen so far with performance.
 I'll try re-creating it again today if I get time, but the iFrame shouldn't load any slower
than the rest of the app.  (Yes, I missed this detail when I saw it being crap on a full page.
 Sorry about that!)
                
      was (Author: bowserj):
    So, it specifically doesn't load in the iFrame.  I've just been vanilla testing it so
far, but I can see it totally crapping out on the iFrame based on what I've seen so far with
performance.  I'll try re-creating it again today if I get time, but the iFrame shouldn't
load any slower than the rest of the app.
                  
> Secure whitelisted URLs not loading in Android
> ----------------------------------------------
>
>                 Key: CB-1947
>                 URL: https://issues.apache.org/jira/browse/CB-1947
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: Android
>    Affects Versions: 2.2.0
>         Environment: Android 2.3 and 4.2
>            Reporter: Antony Lees
>            Assignee: Joe Bowser
>         Attachments: log.txt
>
>
> Given the config
>     <access origin="http://127.0.0.1*"/> <!-- allow local pages -->
>     <access origin="https://mysite.com" subdomains="true"/>
>     <access origin="http://mysite.com" subdomains="true"/>
> I would expect both the http and https sites to load.  However only the unsecured http
URL will load, the secure https URL shows an HTML error page (it's an iframe)
> Even if I add
>     <access origin="*"/>
> the same thing happens
> I should add that if I deploy the app straight from eclipse (ie not signing it) the secure
URL works fine, so it is only when the whitelist is enforced that it doesn't seem to work

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message