cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Filip Maj <...@adobe.com>
Subject Re: Getting Started with Android on Windows
Date Mon, 19 Nov 2012 19:18:14 GMT
You can cd into the framework/ directory and run "ant jar" to get a better
idea of what is failing. That's the task that compiles the jar.

On 11/19/12 11:15 AM, "Amos Hayes" <ahayes@gcrc.carleton.ca> wrote:

>
>FYI. I have been just been through the same steps on OS X. (replaced my
>4.1 SDK with the 4.2 one, downloaded Cordova 2.2.0 package)
>
>Looks like the cordova jar isn't building with the Android 4.2 SDK (and I
>guess on Windows it's not reporting the error when it can't copy it)
>
>Moog2:incubator-cordova-android ahayes$ cd bin
>Moog2:bin ahayes$ ./create ../../../Test com.example.test Test
>cp: 
>/Users/ahayes/Documents/cordova-2.2.0/incubator-cordova-android/framework/
>cordova-2.2.0.jar: No such file or directory
>An error occurred. Deleting project...
>
>--
>Amos
>
>
>
>On 2012-11-19, at 1:20 PM, Amos Hayes <ahayes@gcrc.carleton.ca> wrote:
>
>> 
>> Thanks for your response.
>> 
>> No. There is no cordova-2.2.0.jar in the libs directory. I just tried
>>again with a freshly created project and it isn't there, even before
>>adding to eclipse.
>> 
>> --
>> Amos
>> 
>> 
>> 
>> On 2012-11-19, at 12:59 PM, Anis KADRI <anis.kadri@gmail.com> wrote:
>> 
>>> AppInfo.jar is not necessary. It is only used by the cordova commands.
>>> Do you have cordova-2.2.0.jar in your libs directory ?
>>> 
>>> 
>>> On Mon, Nov 19, 2012 at 9:54 AM, Amos Hayes <ahayes@gcrc.carleton.ca>
>>>wrote:
>>> 
>>>> Hello. I've just downloaded the latest windows ADK 4.2 package for
>>>>windows
>>>> (which includes an eclipse environment) from developer.android.com
>>>>and the
>>>> Cordova 2.2.0 packages.
>>>> 
>>>> I have followed the windows getting started guide. Well, more or
>>>>less. I
>>>> found
>>>> 
>>>> 
>>>>http://simonmacdonald.blogspot.ca/2012/11/getting-create-command-to-wor
>>>>k-on.htmlafter
>>>> the fact and suggest that it does a bit better job for any windows
>>>> users who aren't also familiar with unix-ish systems.
>>>> 
>>>> Anyway, after creating the project at the command line (and telling
>>>>it to
>>>> locate the project in my ADK/Eclipse "workspace" folder, I was not
>>>>able to
>>>> File -> New -> Project... -> Android Project from Existing Code.
It
>>>> complained of an "Invalid project description." I was able to get
>>>>around
>>>> this problem by creating the project outside my workspace folder and
>>>>then
>>>> choosing to copy it in when adding it to Eclipse. Weird.
>>>> 
>>>> Anyway, where I'm stuck now is with a persistent "The import
>>>> org.apache.cordova cannot be resolved" error (along with other later
>>>>ones
>>>> which I have to assume are a result of that first one. I have tried
>>>> cleaning the project and adding cordova/AppInfo.jar to the build path
>>>>but
>>>> I'm not having any luck.
>>>> 
>>>> Any suggestions? Wish I knew more about java... but if I did I might
>>>>not be
>>>> trying to use Cordova in the first place. :)
>>>> 
>>>> --
>>>> Amos
>>>> 
>> 
>


Mime
View raw message