cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Filip Maj <...@adobe.com>
Subject Re: RIM/BlackBerry folk: please help
Date Wed, 14 Nov 2012 20:39:28 GMT
I'm doing this with playbook.

For signing, this works:
Edit playbook.xml and set code.sign to true at the top.
Then I run ant playbook build

Note that it should say "signing successful"

Then <tablet-sdk>bbwp/blackberry-tablet-sdk/bin/blackberry-deploy
-installApp -launchApp -device <ip> -password <device_password> <path to
cordova-bb app/build/appname.bar> :: this works and launches on the tablet

But if I do the 'ant playbook build' in node via child_process I keep
getting:

Error: code signing request failed because this file has been previously
signed.

Note that I am creating a fresh cordova project every time with
./bin/create, and editing the right settings in project.properties. For
both the node process and me working with the command line I am using the
same generated project.

Related: where the fuck did "Sample Inc." come from in my app's author???
(when I do ./blackberry-nativepackager -listManifest <path to my app.bar>)
My signing keys and my debug tokens have "Adobe" as the company name.

I will reiterate that this whole debug token process is super annoying and
not convenient for devs AT ALL. Way easier to just sign your shit and be
on your way. Plus debug tokens expire and you can only be limited to x
number of devices with it?

Woo security win...

On 11/14/12 12:26 PM, "Gord Tanner" <gtanner@gmail.com> wrote:

>So to reproduce I just shell execute ant qnx load-device via a node
>script?
>
>
>On Wed, Nov 14, 2012 at 3:20 PM, Filip Maj <fil@adobe.com> wrote:
>
>> I am working on a continuous integration setup. Got android and iOS
>> working. Now trying to get it working with playbook + BB10.
>>
>> I've tried many avenues to automate the compilation / signing /
>>deployment
>> / launching aspect.
>>
>> Using blackberry-deploy I can launch an app. Hooray!
>>
>> However, I can't sign the app when I shell out to the ant file (ant
>> <target> build with code.sign=true). I get "code signing failed as this
>> package is already signed". If I run this command interactively from my
>> command line it works fine. Perhaps some kind of permission issue with a
>> node process shelling out to ant which in turn fires off to bbwp?
>>
>> Then I tried using the debug tokens instead of signing the app. This is
>>a
>> shitshow in itself. I keep getting "author does not match" or something
>> along those lines. Tried the various solutions mentioned on the BB
>>support
>> forums [1] and none of them work, including:
>> - Author tag in config.xml matches the debug token author
>> - tablet-sdk/bbwp/bin/bbwp.properties points to the debug token I
>>created
>> and installed on the device
>>
>> I would also recommend reviewing this whole debug token process as it
>> sucks and doesn't work. Echoing the questions in the thread, basically
>> "Why do I have to enter my company name in 20 different locations?"
>>
>> Any insight into how to fix the author mismatch or automated signing
>>would
>> be helpful.
>>
>> [1]
>> 
>>http://supportforums.blackberry.com/t5/Web-and-WebWorks-Development/Appli
>>ca
>> tion-author-does-not-match-debug-token-author/td-p/1471779
>>
>>


Mime
View raw message