cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anis KADRI <anis.ka...@gmail.com>
Subject Re: [Android] ./bin/emulate + debug script behavior
Date Wed, 07 Nov 2012 18:19:05 GMT
On Tue, Nov 6, 2012 at 4:58 PM, Jesse <purplecabbage@gmail.com> wrote:

> User interaction should NOT be required, if it annoys you then type
> the right thing.
>

What would the right thing be ?


>
> adb devices
> - returns a list of usable devices, why not mimic that?
> adb -s <serialNumber> <command>
> - makes perfect sense to me
>
> When I did the WP7 tool : ( which is used by the script )
> CordovaDeploy  [ -devices  BuildOutputPath -d:DeviceIndex ]
>   -devices : lists the devices and exits
>   BuildOutputPath : path to the built application, typically
> Bin/Debug/ or Bin/Release/
> -d : index of the device to deploy, default is 0
>
>
>
> On Tue, Nov 6, 2012 at 4:46 PM, Anis KADRI <anis.kadri@gmail.com> wrote:
> > Right now when you cordova/emulate and nothing is running, it displays a
> > list of AVDs to choose from. I believe that we should display a list of
> > running devices/emulators when there is more than one device/emulator
> > running. As a user, I'd get mad if you automatically picked up the wrong
> > device/emulator.
> > However, according to this discussion [1] I thought we would separate
> > running on a device (cordova/deploy) and running in the emulator
> > (cordova/emulate) http://markmail.org/thread/znkkjmwgoc23lhhq
> >
> >
> > On Tue, Nov 6, 2012 at 4:38 PM, Jesse <purplecabbage@gmail.com> wrote:
> >
> >> first device, or add an optional index param
> >> this is what WP7 did, haven't tested it a few versions though ..
> >>
> >> On Tue, Nov 6, 2012 at 4:17 PM, Filip Maj <fil@adobe.com> wrote:
> >> > If you have more than one device/emulator hooked up these scripts fail
> >> > along the lines of:
> >> >
> >> > [exec] error: more than one device and emulator
> >> > [exec] - waiting for device -
> >> > [exec] error: more than one device and emulator
> >> > [exec] - waiting for device -
> >> > [exec] error: more than one device and emulator
> >> > [exec] - waiting for device -
> >> >
> >> >
> >> > And indefinitely hangs.
> >> >
> >> > Is this a use case we should cover, and if so, how to solve this one?
> >> grep
> >> > for the first dev/emu and choose that one? Iterate over all connected
> >> > devices?
> >> >
> >>
> >>
> >>
> >> --
> >> @purplecabbage
> >> risingj.com
> >>
>
>
>
> --
> @purplecabbage
> risingj.com
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message