cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shazron Abdullah (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CB-1806) Upgrading cordova 1.9.0 (iOS) to cordova 2.1.0 and updating existing projects to use 2.1.0
Date Fri, 02 Nov 2012 18:11:12 GMT

    [ https://issues.apache.org/jira/browse/CB-1806?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13489611#comment-13489611
] 

Shazron Abdullah commented on CB-1806:
--------------------------------------

If you only have www changes, I would suggest creating a new project and copying your old
www into the new project - and also re-add your plugins. 2.2.0 was just released.
                
> Upgrading cordova 1.9.0 (iOS) to cordova 2.1.0 and updating existing projects to use
2.1.0
> ------------------------------------------------------------------------------------------
>
>                 Key: CB-1806
>                 URL: https://issues.apache.org/jira/browse/CB-1806
>             Project: Apache Cordova
>          Issue Type: New Feature
>          Components: iOS
>         Environment: on a mac os x lion version 10.7.5
> in xcode Version 4.5.1 (4G1004)
>            Reporter: Jquery Ninja
>            Assignee: Shazron Abdullah
>              Labels: cordova, iOS, upgrade, xcode
>   Original Estimate: 120h
>  Remaining Estimate: 120h
>
> I have uninstalled cordova 1.9.0 by doing:
> To uninstall:
> Remove the PHONEGAPLIB value in Xcode Preferences -> Source Trees
> Delete the ~/Documents/PhoneGapLib folder
> Delete the ~/Library/Application Support/Developer/Shared/Xcode/Project Templates/PhoneGap
folder
> Delete the "~/Library/Application Support/Developer/Shared/Xcode/Templates/Project Templates/Application/PhoneGap-based
Application.xctemplate" or the "~/Library/Developer/Xcode/Templates/Project\ Templates/Application/PhoneGap-based\
Application.xctemplate" folder
> Delete the /Users/Shared/PhoneGap/Frameworks/PhoneGap.framework folder Delete the ~/Library/Frameworks/PhoneGap.framework
symlink
> I then followed the upgrade guides: http://github.com/apache/incubator-cordova ios/blob/master/guides/Cordova%20Plugin%20Upgrade%20Guide.md
and http://docs.phonegap.com/en/2.1.0/guide_upgrading_ios_index.md.html The project builds
with no errors, but when I try to run: On an iPhone with iOS 5.1.1 I get this error:
> ERROR: Start Page at 'www/index.html' was not found.
> and on an iPhone with iOS 6.0 I get this error:
> Failed to load webpage with error: The requested URL was not found on this server.
> Whether I remove the only external link or all javascript sources, whether I manually
add the www folder, or anything at all that can be found on the internet, these errors are
persistent.
> Was I supposed to install cordova 2.0.0 first before installing 2.1.0
> Another issue I am not too sure of is: Change in the method signature of the CordovaLib's
JSONKit method categories, they are prefixed with "cdvjk_" now:e.g.
> [myDict cdvjk_JSONString];
> instead of:
> [myDict JSONString];
> I checked JSONKit.h and JSONKit.m in
> /Path/to_my_installation/Cordova-2.1.0/lib/ios/CordovaLib/Classes/JSON
> and there was no problem.
> I have spent days searching the internet and trying out all different suggestions but
none work. If I navigate to
> /var/log
> cat system.log
> I get this result after running on the iPhone 6.0 simulator:
> Interface Builder Cocoa Touch Tool[#####]: BUG in libdispatch client: kevent[EVFILT_VNODE]
add: "Bad file descriptor" - 0x9
> Install of "/~/Library/Developer/Xcode/DerivedData/appnamename-a_bunch_of_numbers/Build/Products/Debug-iphonesimulator/appname.app"
requested by  SimulatorBridge
> MobileInstallationInstall_Server: Installing app com.company_name.package_name
> MobileInstallationInstall_Server: Staging: 0.05s; Waiting: 0.00s; Installation: 0.04s;
LS Sync: 0.03s; Overall: 0.14s
> (UIKitApplication:com.company_name.package_name[0xba4d][17042]): Spawned and waiting
for the debugger to attach before continuing...
> debugserver-### for x86_64.
> Listening to port 31208...
> Got a connection, waiting for process information for launching or attaching.
> 1 +0.000000 sec error: ::task_get_exception_ports ( task = 0x1b03, mask = 0xbfe, maskCnt
=> 12, ports, behaviors, flavors ) err = (os/kern) invalid argument (0x00000004)
> Multi-tasking -> Device: YES, App: YES

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message