cordova-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shazron Abdullah (JIRA)" <>
Subject [jira] [Updated] (CB-1664) Device Object
Date Tue, 16 Oct 2012 17:09:03 GMT


Shazron Abdullah updated CB-1664:

    Fix Version/s:     (was: 2.1.0)

Thanks for the bug report. This may be the case that there is an updated cordova-X.X.X.js
in the development version that you need to use. Also make sure you call if after the deviceready

In any case, I cannot reproduce this bug in the latest source version (which will be 2.2.0rc1
released soon). I tried multiple simulators and devices.
> Device Object
> -------------
>                 Key: CB-1664
>                 URL:
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: iOS
>    Affects Versions: 2.1.0
>         Environment: iphone Simulator, or iphone 3GS
>            Reporter: David Ward
>            Assignee: Shazron Abdullah
>            Priority: Minor
>              Labels: device,
>             Fix For: 2.2.0
> Try to call the device object (such as works in official release 2.1.0 but
in 2.1.0 which I just downloaded off github (new to all this) so not sure how best to identify
it but the zip file name was I used was .../zipball/master
yesterday) maybe that'll give u an idea let me know if I can tell you more. I tried the same
code in both and one worked and the other didn' could use a hand. Documentation says
no permissions need to be set. (test code I used was from

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see:

View raw message