cordova-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ste...@apache.org
Subject svn commit: r1815260 - in /cordova/site/public: announcements/2017/11/09/android-release.html blog/index.html feed.xml
Date Tue, 14 Nov 2017 20:24:43 GMT
Author: steven
Date: Tue Nov 14 20:24:43 2017
New Revision: 1815260

URL: http://svn.apache.org/viewvc?rev=1815260&view=rev
Log:
Updated docs

Modified:
    cordova/site/public/announcements/2017/11/09/android-release.html
    cordova/site/public/blog/index.html
    cordova/site/public/feed.xml

Modified: cordova/site/public/announcements/2017/11/09/android-release.html
URL: http://svn.apache.org/viewvc/cordova/site/public/announcements/2017/11/09/android-release.html?rev=1815260&r1=1815259&r2=1815260&view=diff
==============================================================================
--- cordova/site/public/announcements/2017/11/09/android-release.html (original)
+++ cordova/site/public/announcements/2017/11/09/android-release.html Tue Nov 14 20:24:43
2017
@@ -6,7 +6,7 @@
     <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
     <meta name="format-detection" content="telephone=no">
     <meta name="viewport" content="user-scalable=no, initial-scale=1, maximum-scale=1,
minimum-scale=1, width=device-width" />
-    <meta name="description" content="We would like to announce that Cordova Android 6.4.0
has been released! Due to the recent changes Google made to Android Studio, Cordova Android
now requires...">
+    <meta name="description" content="We would like to announce that Cordova Android 6.4.0
has been released! This release now uses the latest Android Gradle plugin that was released
with Android...">
 
     <title>
         
@@ -133,9 +133,13 @@
         <div>
             <p>We would like to announce that <code>Cordova Android 6.4.0</code>
has been released! </p>
 
-<p>Due to the recent changes <strong>Google</strong> made to Android Studio,
Cordova Android now requires that Gradle be installed as a dependency for Android development
on all platforms. We will be removing the code that uses Android Studio as a dependency in
the near future. This release now uses the latest Android Gradle plugin that was released
with Android Studio 3.0.</p>
+<p>This release now uses the latest Android Gradle plugin that was released with Android
Studio 3.0.</p>
 
-<p><strong>Google</strong> has changed the Gradle DSL used and currently
support for the Crosswalk WebView is broken in this version of Cordova as a result.  Unfortunately,
since Crosswalk is no longer supported by the Crosswalk Project, we do not know whether this
issue will be fixed.  If you require support for Crosswalk, we recommend that you continue
using cordova-android 6.3.0 at this time and avoid using your project with Android Studio.</p>
+<p>Due to the recent changes Google made to Android Studio, Cordova Android now requires
that Gradle is installed as a standalone dependency for Android development on all platforms.
You can do so by <a href="https://gradle.org/install/">following these instructions
at gradle.org</a>.<br>
+We will be removing the code that uses Android Studio to provide Gradle as a dependency in
the near future.</p>
+
+<p>Google also has changed the Gradle DSL used and currently support for the Crosswalk
WebView is broken in this version of Cordova as a result. Unfortunately, since Crosswalk is
no longer supported by the <a href="https://crosswalk-project.org/">Crosswalk Project</a>,
we do not know whether <a href="https://github.com/crosswalk-project/cordova-plugin-crosswalk-webview/issues/183">this
issue</a> will be fixed.<br>
+If you require support for Crosswalk, we recommend that you continue using cordova-android
6.3.0 at this time and avoid using or upgrading your project with Android Studio.</p>
 
 <p>To upgrade:</p>
 <div class="highlight"><pre><code class="language-" data-lang="">npm install
-g cordova

Modified: cordova/site/public/blog/index.html
URL: http://svn.apache.org/viewvc/cordova/site/public/blog/index.html?rev=1815260&r1=1815259&r2=1815260&view=diff
==============================================================================
--- cordova/site/public/blog/index.html (original)
+++ cordova/site/public/blog/index.html Tue Nov 14 20:24:43 2017
@@ -207,9 +207,13 @@ cordova plugin add cordova-plugin-camera
                 <section class="post-excerpt">
                     <p><p>We would like to announce that <code>Cordova
Android 6.4.0</code> has been released! </p>
 
-<p>Due to the recent changes <strong>Google</strong> made to Android Studio,
Cordova Android now requires that Gradle be installed as a dependency for Android development
on all platforms. We will be removing the code that uses Android Studio as a dependency in
the near future. This release now uses the latest Android Gradle plugin that was released
with Android Studio 3.0.</p>
+<p>This release now uses the latest Android Gradle plugin that was released with Android
Studio 3.0.</p>
 
-<p><strong>Google</strong> has changed the Gradle DSL used and currently
support for the Crosswalk WebView is broken in this version of Cordova as a result.  Unfortunately,
since Crosswalk is no longer supported by the Crosswalk Project, we do not know whether this
issue will be fixed.  If you require support for Crosswalk, we recommend that you continue
using cordova-android 6.3.0 at this time and avoid using your project with Android Studio.</p>
+<p>Due to the recent changes Google made to Android Studio, Cordova Android now requires
that Gradle is installed as a standalone dependency for Android development on all platforms.
You can do so by <a href="https://gradle.org/install/">following these instructions
at gradle.org</a>.<br>
+We will be removing the code that uses Android Studio to provide Gradle as a dependency in
the near future.</p>
+
+<p>Google also has changed the Gradle DSL used and currently support for the Crosswalk
WebView is broken in this version of Cordova as a result. Unfortunately, since Crosswalk is
no longer supported by the <a href="https://crosswalk-project.org/">Crosswalk Project</a>,
we do not know whether <a href="https://github.com/crosswalk-project/cordova-plugin-crosswalk-webview/issues/183">this
issue</a> will be fixed.<br>
+If you require support for Crosswalk, we recommend that you continue using cordova-android
6.3.0 at this time and avoid using or upgrading your project with Android Studio.</p>
 
 <p>To upgrade:</p>
 <div class="highlight"><pre><code class="language-" data-lang="">npm install
-g cordova

Modified: cordova/site/public/feed.xml
URL: http://svn.apache.org/viewvc/cordova/site/public/feed.xml?rev=1815260&r1=1815259&r2=1815260&view=diff
==============================================================================
--- cordova/site/public/feed.xml (original)
+++ cordova/site/public/feed.xml Tue Nov 14 20:24:43 2017
@@ -6,8 +6,8 @@
 </description>
     <link>https://cordova.apache.org/</link>
     <atom:link href="https://cordova.apache.org/feed.xml" rel="self" type="application/rss+xml"/>
-    <pubDate>Tue, 14 Nov 2017 18:51:54 +0000</pubDate>
-    <lastBuildDate>Tue, 14 Nov 2017 18:51:54 +0000</lastBuildDate>
+    <pubDate>Tue, 14 Nov 2017 20:03:44 +0000</pubDate>
+    <lastBuildDate>Tue, 14 Nov 2017 20:03:44 +0000</lastBuildDate>
     <generator>Jekyll v2.5.3</generator>
     
       <item>
@@ -307,9 +307,13 @@ cordova plugin add cordova-plugin-camera
         <title>Cordova Android 6.4.0 Released!</title>
         <description>&lt;p&gt;We would like to announce that &lt;code&gt;Cordova
Android 6.4.0&lt;/code&gt; has been released! &lt;/p&gt;
 
-&lt;p&gt;Due to the recent changes &lt;strong&gt;Google&lt;/strong&gt;
made to Android Studio, Cordova Android now requires that Gradle be installed as a dependency
for Android development on all platforms. We will be removing the code that uses Android Studio
as a dependency in the near future. This release now uses the latest Android Gradle plugin
that was released with Android Studio 3.0.&lt;/p&gt;
+&lt;p&gt;This release now uses the latest Android Gradle plugin that was released
with Android Studio 3.0.&lt;/p&gt;
 
-&lt;p&gt;&lt;strong&gt;Google&lt;/strong&gt; has changed the Gradle
DSL used and currently support for the Crosswalk WebView is broken in this version of Cordova
as a result.  Unfortunately, since Crosswalk is no longer supported by the Crosswalk Project,
we do not know whether this issue will be fixed.  If you require support for Crosswalk, we
recommend that you continue using cordova-android 6.3.0 at this time and avoid using your
project with Android Studio.&lt;/p&gt;
+&lt;p&gt;Due to the recent changes Google made to Android Studio, Cordova Android
now requires that Gradle is installed as a standalone dependency for Android development on
all platforms. You can do so by &lt;a href=&quot;https://gradle.org/install/&quot;&gt;following
these instructions at gradle.org&lt;/a&gt;.&lt;br&gt;
+We will be removing the code that uses Android Studio to provide Gradle as a dependency in
the near future.&lt;/p&gt;
+
+&lt;p&gt;Google also has changed the Gradle DSL used and currently support for the
Crosswalk WebView is broken in this version of Cordova as a result. Unfortunately, since Crosswalk
is no longer supported by the &lt;a href=&quot;https://crosswalk-project.org/&quot;&gt;Crosswalk
Project&lt;/a&gt;, we do not know whether &lt;a href=&quot;https://github.com/crosswalk-project/cordova-plugin-crosswalk-webview/issues/183&quot;&gt;this
issue&lt;/a&gt; will be fixed.&lt;br&gt;
+If you require support for Crosswalk, we recommend that you continue using cordova-android
6.3.0 at this time and avoid using or upgrading your project with Android Studio.&lt;/p&gt;
 
 &lt;p&gt;To upgrade:&lt;/p&gt;
 &lt;div class=&quot;highlight&quot;&gt;&lt;pre&gt;&lt;code class=&quot;language-&quot;
data-lang=&quot;&quot;&gt;npm install -g cordova



---------------------------------------------------------------------
To unsubscribe, e-mail: commits-unsubscribe@cordova.apache.org
For additional commands, e-mail: commits-help@cordova.apache.org


Mime
View raw message