cordova-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From shaz...@apache.org
Subject [18/50] ios commit: Increment ios-deploy min version to 1.2.0 and ios-sim min version to 3.0
Date Fri, 31 Oct 2014 23:43:38 GMT
Increment ios-deploy min version to 1.2.0 and ios-sim min version to 3.0


Project: http://git-wip-us.apache.org/repos/asf/cordova-ios/repo
Commit: http://git-wip-us.apache.org/repos/asf/cordova-ios/commit/bdbb026f
Tree: http://git-wip-us.apache.org/repos/asf/cordova-ios/tree/bdbb026f
Diff: http://git-wip-us.apache.org/repos/asf/cordova-ios/diff/bdbb026f

Branch: refs/heads/wkwebview
Commit: bdbb026fce26d476485f708f8ec9398b3ec714db
Parents: 307a00b
Author: Shazron Abdullah <shazron@apache.org>
Authored: Fri Oct 17 15:35:46 2014 -0700
Committer: Shazron Abdullah <shazron@apache.org>
Committed: Fri Oct 17 15:35:46 2014 -0700

----------------------------------------------------------------------
 bin/templates/scripts/cordova/emulate              | 2 +-
 bin/templates/scripts/cordova/lib/install-device   | 2 +-
 bin/templates/scripts/cordova/lib/install-emulator | 2 +-
 bin/templates/scripts/cordova/run                  | 4 ++--
 4 files changed, 5 insertions(+), 5 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/cordova-ios/blob/bdbb026f/bin/templates/scripts/cordova/emulate
----------------------------------------------------------------------
diff --git a/bin/templates/scripts/cordova/emulate b/bin/templates/scripts/cordova/emulate
index 638e650..5c68a82 100755
--- a/bin/templates/scripts/cordova/emulate
+++ b/bin/templates/scripts/cordova/emulate
@@ -31,7 +31,7 @@ APP_PATH=${1:-$PROJECT_PATH/build/emulator/$(xcodebuild -project "$PROJECT_PATH/
 
 TARGET=${2:-${TARGET:-iPhone-6}}
 
-IOS_SIM_MIN_VERSION="1.7"
+IOS_SIM_MIN_VERSION="3.0"
 IOS_SIM_LOCATION=$(which ios-sim)
 if [ $? != 0 ]; then
     echo -e "\033[31mError: ios-sim was not found. Please download, build and install version
$IOS_SIM_MIN_VERSION or greater from https://github.com/phonegap/ios-sim into your path. Or
'npm install -g ios-sim' using node.js: http://nodejs.org/\033[m" 1>&2; 

http://git-wip-us.apache.org/repos/asf/cordova-ios/blob/bdbb026f/bin/templates/scripts/cordova/lib/install-device
----------------------------------------------------------------------
diff --git a/bin/templates/scripts/cordova/lib/install-device b/bin/templates/scripts/cordova/lib/install-device
index 617442f..4cea6c7 100755
--- a/bin/templates/scripts/cordova/lib/install-device
+++ b/bin/templates/scripts/cordova/lib/install-device
@@ -40,7 +40,7 @@ if [ ! -d "$DEVICE_APP_PATH" ]; then
 fi
 
 
-IOS_DEPLOY_MIN_VERSION="1.0.4"
+IOS_DEPLOY_MIN_VERSION="1.2.0"
 IOS_DEPLOY_LOCATION=$(which ios-deploy)
 if [ $? != 0 ]; then
     echo -e "\033[31mError: ios-deploy was not found. Please download, build and install
version $IOS_DEPLOY_MIN_VERSION or greater from https://github.com/phonegap/ios-deploy into
your path. Or 'npm install -g ios-deploy' using node.js: http://nodejs.org/\033[m"; exit 1;

http://git-wip-us.apache.org/repos/asf/cordova-ios/blob/bdbb026f/bin/templates/scripts/cordova/lib/install-emulator
----------------------------------------------------------------------
diff --git a/bin/templates/scripts/cordova/lib/install-emulator b/bin/templates/scripts/cordova/lib/install-emulator
index e916660..65d2036 100755
--- a/bin/templates/scripts/cordova/lib/install-emulator
+++ b/bin/templates/scripts/cordova/lib/install-emulator
@@ -84,7 +84,7 @@ if [ ! -d "$SIMULATOR_APP_PATH" ]; then
 	exit 1
 fi
 
-IOS_SIM_MIN_VERSION="1.7"
+IOS_SIM_MIN_VERSION="3.0"
 IOS_SIM_LOCATION=$(which ios-sim)
 if [ $? != 0 ]; then
     echo -e "\033[31mError: ios-sim was not found. Please download, build and install version
$IOS_SIM_MIN_VERSION or greater from https://github.com/phonegap/ios-sim into your path. Or
'npm install -g ios-sim' using node.js: http://nodejs.org/\033[m"; exit 1;

http://git-wip-us.apache.org/repos/asf/cordova-ios/blob/bdbb026f/bin/templates/scripts/cordova/run
----------------------------------------------------------------------
diff --git a/bin/templates/scripts/cordova/run b/bin/templates/scripts/cordova/run
index b4d45d0..ff60876 100755
--- a/bin/templates/scripts/cordova/run
+++ b/bin/templates/scripts/cordova/run
@@ -90,7 +90,7 @@ source "$CORDOVA_PATH/check_reqs"
 
 # if device build found, run it first
 if "$USE_DEVICE"; then
-    IOS_DEPLOY_MIN_VERSION="1.0.4"
+    IOS_DEPLOY_MIN_VERSION="1.2.0"
     IOS_DEPLOY_LOCATION=$(which ios-deploy)
     if [ $? != 0 ]; then
         echo -e "\033[31mError: ios-deploy was not found. Please download, build and install
version $IOS_DEPLOY_MIN_VERSION or greater from https://github.com/phonegap/ios-deploy into
your path. Or 'npm install -g ios-deploy' using node.js: http://nodejs.org/\033[m" 1>&2;
@@ -116,7 +116,7 @@ if "$USE_DEVICE"; then
 fi
 
 if "$USE_SIMULATOR"; then
-    IOS_SIM_MIN_VERSION="1.7"
+    IOS_SIM_MIN_VERSION="3.0"
     IOS_SIM_LOCATION=$(which ios-sim)
     if [ $? != 0 ]; then
         echo -e "\033[31mError: ios-sim was not found. Please download, build and install
version $IOS_SIM_MIN_VERSION or greater from https://github.com/phonegap/ios-sim into your
path. Or 'npm install -g ios-sim' using node.js: http://nodejs.org/\033[m" 1>&2;


---------------------------------------------------------------------
To unsubscribe, e-mail: commits-unsubscribe@cordova.apache.org
For additional commands, e-mail: commits-help@cordova.apache.org


Mime
View raw message