cordova-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From kam...@apache.org
Subject [70/70] git commit: Update plugman cli to use cordova-lib
Date Fri, 02 May 2014 18:31:16 GMT
Update plugman cli to use cordova-lib


Project: http://git-wip-us.apache.org/repos/asf/cordova-plugman/repo
Commit: http://git-wip-us.apache.org/repos/asf/cordova-plugman/commit/bea01b36
Tree: http://git-wip-us.apache.org/repos/asf/cordova-plugman/tree/bea01b36
Diff: http://git-wip-us.apache.org/repos/asf/cordova-plugman/diff/bea01b36

Branch: refs/heads/master
Commit: bea01b3661e90c5d670d5c0a2df9ce0a85dfbcc2
Parents: eefdf68
Author: Mark Koudritsky <kamrik@gmail.com>
Authored: Wed Apr 30 17:48:11 2014 -0400
Committer: Mark Koudritsky <kamrik@gmail.com>
Committed: Thu May 1 11:22:29 2014 -0400

----------------------------------------------------------------------
 main.js             |   9 +-
 npm-shrinkwrap.json | 625 -----------------------------------------------
 package.json        |  16 +-
 plugman.js          |   5 +
 4 files changed, 12 insertions(+), 643 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/cordova-plugman/blob/bea01b36/main.js
----------------------------------------------------------------------
diff --git a/main.js b/main.js
index cb08923..89b703d 100755
--- a/main.js
+++ b/main.js
@@ -23,9 +23,10 @@ var path = require('path')
     , url = require('url')
     , package = require(path.join(__dirname, 'package'))
     , nopt = require('nopt')
-    , plugins = require('./src/util/plugins')
     , Q = require('q')
-    , plugman = require('./plugman');
+    , help = require('./src/help')
+    , cordova_lib = require('cordova-lib')
+    , plugman = cordova_lib.plugman;
 
 var known_opts = { 'platform' : [ 'ios', 'android', 'amazon-fireos', 'blackberry10', 'wp7',
'wp8' , 'windows8', 'firefoxos' ]
         , 'project' : path
@@ -77,12 +78,12 @@ plugman.on('error', console.error);
 if (cli_opts.version) {
     console.log(package.version);
 } else if (cli_opts.help) {
-    console.log(plugman.help());
+    console.log(help());
 } else if (plugman.commands[cmd]) {
     var result = plugman.commands[cmd](cli_opts);
     if (result && Q.isPromise(result)) {
         result.done();
     }
 } else {
-    console.log(plugman.help());
+    console.log(help());
 }

http://git-wip-us.apache.org/repos/asf/cordova-plugman/blob/bea01b36/npm-shrinkwrap.json
----------------------------------------------------------------------
diff --git a/npm-shrinkwrap.json b/npm-shrinkwrap.json
deleted file mode 100644
index 5c38496..0000000
--- a/npm-shrinkwrap.json
+++ /dev/null
@@ -1,625 +0,0 @@
-{
-  "name": "plugman",
-  "version": "0.20.3-dev",
-  "dependencies": {
-    "bplist-parser": {
-      "version": "0.0.5",
-      "from": "bplist-parser@0.0.x"
-    },
-    "dep-graph": {
-      "version": "1.1.0",
-      "from": "dep-graph@1.1.0",
-      "dependencies": {
-        "underscore": {
-          "version": "1.2.1",
-          "from": "underscore@1.2.1"
-        }
-      }
-    },
-    "elementtree": {
-      "version": "0.1.5",
-      "from": "elementtree@0.1.5",
-      "dependencies": {
-        "sax": {
-          "version": "0.3.5",
-          "from": "sax@0.3.5"
-        }
-      }
-    },
-    "glob": {
-      "version": "3.2.9",
-      "from": "glob@3.2.x",
-      "dependencies": {
-        "minimatch": {
-          "version": "0.2.14",
-          "from": "minimatch@~0.2.11",
-          "dependencies": {
-            "lru-cache": {
-              "version": "2.5.0",
-              "from": "lru-cache@2"
-            },
-            "sigmund": {
-              "version": "1.0.0",
-              "from": "sigmund@~1.0.0"
-            }
-          }
-        },
-        "inherits": {
-          "version": "2.0.1",
-          "from": "inherits@2"
-        }
-      }
-    },
-    "nopt": {
-      "version": "1.0.10",
-      "from": "nopt@1.0.x",
-      "dependencies": {
-        "abbrev": {
-          "version": "1.0.4",
-          "from": "abbrev@1"
-        }
-      }
-    },
-    "npm": {
-      "version": "1.3.4",
-      "from": "npm@1.3.4",
-      "dependencies": {
-        "semver": {
-          "version": "2.0.8",
-          "from": "semver@latest"
-        },
-        "ini": {
-          "version": "1.1.0",
-          "from": "ini@latest"
-        },
-        "slide": {
-          "version": "1.1.4",
-          "from": "slide@latest"
-        },
-        "abbrev": {
-          "version": "1.0.4",
-          "from": "abbrev@latest"
-        },
-        "graceful-fs": {
-          "version": "2.0.0",
-          "from": "graceful-fs@2"
-        },
-        "minimatch": {
-          "version": "0.2.12",
-          "from": "minimatch@latest",
-          "dependencies": {
-            "sigmund": {
-              "version": "1.0.0",
-              "from": "sigmund@~1.0.0",
-              "resolved": "https://registry.npmjs.org/sigmund/-/sigmund-1.0.0.tgz"
-            }
-          }
-        },
-        "nopt": {
-          "version": "2.1.1",
-          "from": "nopt@latest"
-        },
-        "rimraf": {
-          "version": "2.2.0",
-          "from": "rimraf@2.2"
-        },
-        "request": {
-          "version": "2.21.0",
-          "from": "request@latest",
-          "dependencies": {
-            "qs": {
-              "version": "0.6.5",
-              "from": "qs@~0.6.0"
-            },
-            "json-stringify-safe": {
-              "version": "4.0.0",
-              "from": "json-stringify-safe@~4.0.0"
-            },
-            "forever-agent": {
-              "version": "0.5.0",
-              "from": "forever-agent@~0.5.0"
-            },
-            "tunnel-agent": {
-              "version": "0.3.0",
-              "from": "tunnel-agent@~0.3.0"
-            },
-            "http-signature": {
-              "version": "0.9.11",
-              "from": "http-signature@~0.9.11",
-              "dependencies": {
-                "assert-plus": {
-                  "version": "0.1.2",
-                  "from": "assert-plus@0.1.2"
-                },
-                "asn1": {
-                  "version": "0.1.11",
-                  "from": "asn1@0.1.11"
-                },
-                "ctype": {
-                  "version": "0.5.2",
-                  "from": "ctype@0.5.2"
-                }
-              }
-            },
-            "hawk": {
-              "version": "0.13.1",
-              "from": "hawk@~0.13.0",
-              "dependencies": {
-                "hoek": {
-                  "version": "0.8.5",
-                  "from": "hoek@0.8.x"
-                },
-                "boom": {
-                  "version": "0.4.2",
-                  "from": "boom@0.4.x",
-                  "dependencies": {
-                    "hoek": {
-                      "version": "0.9.1",
-                      "from": "hoek@0.9.x",
-                      "resolved": "https://registry.npmjs.org/hoek/-/hoek-0.9.1.tgz"
-                    }
-                  }
-                },
-                "cryptiles": {
-                  "version": "0.2.1",
-                  "from": "cryptiles@0.2.x"
-                },
-                "sntp": {
-                  "version": "0.2.4",
-                  "from": "sntp@0.2.x",
-                  "dependencies": {
-                    "hoek": {
-                      "version": "0.9.1",
-                      "from": "hoek@0.9.x",
-                      "resolved": "https://registry.npmjs.org/hoek/-/hoek-0.9.1.tgz"
-                    }
-                  }
-                }
-              }
-            },
-            "aws-sign": {
-              "version": "0.3.0",
-              "from": "aws-sign@~0.3.0"
-            },
-            "oauth-sign": {
-              "version": "0.3.0",
-              "from": "oauth-sign@~0.3.0"
-            },
-            "cookie-jar": {
-              "version": "0.3.0",
-              "from": "cookie-jar@~0.3.0"
-            },
-            "node-uuid": {
-              "version": "1.4.0",
-              "from": "node-uuid@~1.4.0"
-            },
-            "mime": {
-              "version": "1.2.9",
-              "from": "mime@~1.2.9"
-            },
-            "form-data": {
-              "version": "0.0.8",
-              "from": "form-data@0.0.8",
-              "dependencies": {
-                "combined-stream": {
-                  "version": "0.0.4",
-                  "from": "combined-stream@~0.0.4",
-                  "dependencies": {
-                    "delayed-stream": {
-                      "version": "0.0.5",
-                      "from": "delayed-stream@0.0.5"
-                    }
-                  }
-                },
-                "async": {
-                  "version": "0.2.9",
-                  "from": "async@~0.2.7"
-                }
-              }
-            }
-          }
-        },
-        "which": {
-          "version": "1.0.5",
-          "from": "which@1"
-        },
-        "tar": {
-          "version": "0.1.17",
-          "from": "tar@0.1.17",
-          "resolved": "https://registry.npmjs.org/tar/-/tar-0.1.17.tgz"
-        },
-        "fstream": {
-          "version": "0.1.23",
-          "from": "fstream@latest"
-        },
-        "block-stream": {
-          "version": "0.0.6",
-          "from": "block-stream@*"
-        },
-        "inherits": {
-          "version": "1.0.0",
-          "from": "git://github.com/isaacs/inherits"
-        },
-        "mkdirp": {
-          "version": "0.3.5",
-          "from": "mkdirp@0.3.5",
-          "resolved": "https://registry.npmjs.org/mkdirp/-/mkdirp-0.3.5.tgz"
-        },
-        "read": {
-          "version": "1.0.4",
-          "from": "read@~1.0.3",
-          "dependencies": {
-            "mute-stream": {
-              "version": "0.0.3",
-              "from": "mute-stream@~0.0.2"
-            }
-          }
-        },
-        "lru-cache": {
-          "version": "2.3.0",
-          "from": "lru-cache@latest"
-        },
-        "node-gyp": {
-          "version": "0.10.6",
-          "from": "node-gyp@latest"
-        },
-        "fstream-npm": {
-          "version": "0.1.4",
-          "from": "fstream-npm@latest",
-          "dependencies": {
-            "fstream-ignore": {
-              "version": "0.0.6",
-              "from": "fstream-ignore@~0.0.5"
-            }
-          }
-        },
-        "uid-number": {
-          "version": "0.0.3",
-          "from": "../uid-number"
-        },
-        "archy": {
-          "version": "0.0.2",
-          "from": "archy@0.0.2"
-        },
-        "chownr": {
-          "version": "0.0.1",
-          "from": "../chownr"
-        },
-        "npmlog": {
-          "version": "0.0.4",
-          "from": "npmlog@latest"
-        },
-        "ansi": {
-          "version": "0.1.2",
-          "from": "ansi@~0.1.2"
-        },
-        "npm-registry-client": {
-          "version": "0.2.27",
-          "from": "npm-registry-client@latest",
-          "dependencies": {
-            "couch-login": {
-              "version": "0.1.17",
-              "from": "couch-login@~0.1.15"
-            }
-          }
-        },
-        "read-package-json": {
-          "version": "1.1.0",
-          "from": "read-package-json@1",
-          "dependencies": {
-            "normalize-package-data": {
-              "version": "0.2.0",
-              "from": "normalize-package-data@~0.2",
-              "dependencies": {
-                "github-url-from-git": {
-                  "version": "1.1.1",
-                  "from": "github-url-from-git@~1.1.1"
-                }
-              }
-            }
-          }
-        },
-        "read-installed": {
-          "version": "0.2.2",
-          "from": "read-installed@latest"
-        },
-        "glob": {
-          "version": "3.2.3",
-          "from": "glob@latest",
-          "dependencies": {
-            "inherits": {
-              "version": "2.0.0",
-              "from": "inherits@2"
-            }
-          }
-        },
-        "init-package-json": {
-          "version": "0.0.10",
-          "from": "init-package-json@latest",
-          "dependencies": {
-            "promzard": {
-              "version": "0.2.0",
-              "from": "promzard@~0.2.0"
-            }
-          }
-        },
-        "osenv": {
-          "version": "0.0.3",
-          "from": "osenv@latest"
-        },
-        "lockfile": {
-          "version": "0.4.0",
-          "from": "lockfile@latest"
-        },
-        "retry": {
-          "version": "0.6.0",
-          "from": "retry"
-        },
-        "once": {
-          "version": "1.1.1",
-          "from": "once"
-        },
-        "npmconf": {
-          "version": "0.1.1",
-          "from": "npmconf@latest",
-          "dependencies": {
-            "config-chain": {
-              "version": "1.1.7",
-              "from": "config-chain@~1.1.1",
-              "dependencies": {
-                "proto-list": {
-                  "version": "1.2.2",
-                  "from": "proto-list@~1.2.1"
-                }
-              }
-            }
-          }
-        },
-        "opener": {
-          "version": "1.3.0",
-          "from": "opener@latest"
-        },
-        "chmodr": {
-          "version": "0.1.0",
-          "from": "chmodr@latest"
-        },
-        "cmd-shim": {
-          "version": "1.1.0",
-          "from": "cmd-shim@"
-        },
-        "sha": {
-          "version": "1.0.1",
-          "from": "sha@~1.0.1"
-        },
-        "editor": {
-          "version": "0.0.4",
-          "from": "editor@"
-        },
-        "child-process-close": {
-          "version": "0.1.1",
-          "from": "child-process-close@",
-          "resolved": "https://registry.npmjs.org/child-process-close/-/child-process-close-0.1.1.tgz"
-        },
-        "npm-user-validate": {
-          "version": "0.0.3",
-          "from": "npm-user-validate@0.0.3",
-          "resolved": "https://registry.npmjs.org/npm-user-validate/-/npm-user-validate-0.0.3.tgz"
-        }
-      }
-    },
-    "plist-with-patches": {
-      "version": "0.5.1",
-      "from": "plist-with-patches@0.5.x",
-      "dependencies": {
-        "xmlbuilder": {
-          "version": "0.4.3",
-          "from": "xmlbuilder@0.4.x"
-        },
-        "xmldom": {
-          "version": "0.1.19",
-          "from": "xmldom@0.1.x"
-        }
-      }
-    },
-    "q": {
-      "version": "0.9.7",
-      "from": "q@~0.9"
-    },
-    "rc": {
-      "version": "0.3.0",
-      "from": "rc@0.3.0",
-      "dependencies": {
-        "optimist": {
-          "version": "0.3.7",
-          "from": "optimist@~0.3.4",
-          "dependencies": {
-            "wordwrap": {
-              "version": "0.0.2",
-              "from": "wordwrap@~0.0.2"
-            }
-          }
-        },
-        "deep-extend": {
-          "version": "0.2.8",
-          "from": "deep-extend@~0.2.5"
-        },
-        "ini": {
-          "version": "1.1.0",
-          "from": "ini@~1.1.0"
-        }
-      }
-    },
-    "request": {
-      "version": "2.22.0",
-      "from": "request@2.22.0",
-      "dependencies": {
-        "qs": {
-          "version": "0.6.6",
-          "from": "qs@~0.6.0"
-        },
-        "json-stringify-safe": {
-          "version": "4.0.0",
-          "from": "json-stringify-safe@~4.0.0"
-        },
-        "forever-agent": {
-          "version": "0.5.2",
-          "from": "forever-agent@~0.5.0"
-        },
-        "tunnel-agent": {
-          "version": "0.3.0",
-          "from": "tunnel-agent@~0.3.0"
-        },
-        "http-signature": {
-          "version": "0.10.0",
-          "from": "http-signature@~0.10.0",
-          "dependencies": {
-            "assert-plus": {
-              "version": "0.1.2",
-              "from": "assert-plus@0.1.2"
-            },
-            "asn1": {
-              "version": "0.1.11",
-              "from": "asn1@0.1.11"
-            },
-            "ctype": {
-              "version": "0.5.2",
-              "from": "ctype@0.5.2"
-            }
-          }
-        },
-        "hawk": {
-          "version": "0.13.1",
-          "from": "hawk@~0.13.0",
-          "dependencies": {
-            "hoek": {
-              "version": "0.8.5",
-              "from": "hoek@0.8.x"
-            },
-            "boom": {
-              "version": "0.4.2",
-              "from": "boom@0.4.x",
-              "dependencies": {
-                "hoek": {
-                  "version": "0.9.1",
-                  "from": "hoek@0.9.x"
-                }
-              }
-            },
-            "cryptiles": {
-              "version": "0.2.2",
-              "from": "cryptiles@0.2.x"
-            },
-            "sntp": {
-              "version": "0.2.4",
-              "from": "sntp@0.2.x",
-              "dependencies": {
-                "hoek": {
-                  "version": "0.9.1",
-                  "from": "hoek@0.9.x"
-                }
-              }
-            }
-          }
-        },
-        "aws-sign": {
-          "version": "0.3.0",
-          "from": "aws-sign@~0.3.0"
-        },
-        "oauth-sign": {
-          "version": "0.3.0",
-          "from": "oauth-sign@~0.3.0"
-        },
-        "cookie-jar": {
-          "version": "0.3.0",
-          "from": "cookie-jar@~0.3.0"
-        },
-        "node-uuid": {
-          "version": "1.4.1",
-          "from": "node-uuid@~1.4.0"
-        },
-        "mime": {
-          "version": "1.2.11",
-          "from": "mime@~1.2.9"
-        },
-        "form-data": {
-          "version": "0.0.8",
-          "from": "form-data@0.0.8",
-          "dependencies": {
-            "combined-stream": {
-              "version": "0.0.4",
-              "from": "combined-stream@~0.0.4",
-              "dependencies": {
-                "delayed-stream": {
-                  "version": "0.0.5",
-                  "from": "delayed-stream@0.0.5"
-                }
-              }
-            },
-            "async": {
-              "version": "0.2.10",
-              "from": "async@~0.2.7"
-            }
-          }
-        }
-      }
-    },
-    "semver": {
-      "version": "2.0.11",
-      "from": "semver@2.0.x"
-    },
-    "shelljs": {
-      "version": "0.1.4",
-      "from": "shelljs@0.1.x"
-    },
-    "tar": {
-      "version": "0.1.19",
-      "from": "tar@0.1.x",
-      "dependencies": {
-        "inherits": {
-          "version": "2.0.1",
-          "from": "inherits@2"
-        },
-        "block-stream": {
-          "version": "0.0.7",
-          "from": "block-stream@*"
-        },
-        "fstream": {
-          "version": "0.1.25",
-          "from": "fstream@~0.1.8",
-          "dependencies": {
-            "rimraf": {
-              "version": "2.2.6",
-              "from": "rimraf@2"
-            },
-            "mkdirp": {
-              "version": "0.3.5",
-              "from": "mkdirp@0.3"
-            },
-            "graceful-fs": {
-              "version": "2.0.2",
-              "from": "graceful-fs@~2.0.0"
-            }
-          }
-        }
-      }
-    },
-    "underscore": {
-      "version": "1.4.4",
-      "from": "underscore@1.4.4"
-    },
-    "xcode": {
-      "version": "0.6.6",
-      "from": "xcode@0.6.6",
-      "dependencies": {
-        "pegjs": {
-          "version": "0.6.2",
-          "from": "pegjs@0.6.2"
-        },
-        "node-uuid": {
-          "version": "1.3.3",
-          "from": "node-uuid@1.3.3"
-        }
-      }
-    }
-  }
-}

http://git-wip-us.apache.org/repos/asf/cordova-plugman/blob/bea01b36/package.json
----------------------------------------------------------------------
diff --git a/package.json b/package.json
index a70e882..8c39c29 100644
--- a/package.json
+++ b/package.json
@@ -18,25 +18,13 @@
   "engineStrict":true,
   "dependencies": {
     "nopt": "1.0.x",
-    "glob": "3.2.x",
-    "elementtree": "0.1.5",
-    "xcode": "0.6.6",
-    "plist-with-patches": "0.5.x",
-    "bplist-parser": "0.0.x",
-    "shelljs": "0.1.x",
     "underscore":"1.4.4",
-    "dep-graph":"1.1.0",
-    "semver": "2.0.x",
     "q": "~0.9",
     "npm": "1.3.4",
-    "rc": "0.3.0",
-    "tar": "0.1.x",
-    "request": "2.22.0"
+    "rc": "0.3.0"
   },
   "devDependencies": {
-    "temp": "0.6.x",
-    "jasmine-node": "~1",
-    "osenv": "0.0.x"
+    "jasmine-node": "~1"
   },
   "bin" : { "plugman" : "./main.js" },
   "scripts": {

http://git-wip-us.apache.org/repos/asf/cordova-plugman/blob/bea01b36/plugman.js
----------------------------------------------------------------------
diff --git a/plugman.js b/plugman.js
new file mode 100644
index 0000000..30f4cba
--- /dev/null
+++ b/plugman.js
@@ -0,0 +1,5 @@
+// All plugman js API moved to cordova-lib . This is a temporary shim for
+// dowstream packages that use plugman via js API.
+
+var cordova_lib = require('cordova-lib');
+module.exports = cordova_lib.plugman;
\ No newline at end of file


Mime
View raw message