cordova-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mwbro...@apache.org
Subject svn commit: r1539110 [2/2] - in /cordova/site/public/docs/en: 3.0.0/ 3.1.0/ edge/
Date Tue, 05 Nov 2013 19:34:37 GMT
Modified: cordova/site/public/docs/en/edge/guide_platforms_android_upgrading.md.html
URL: http://svn.apache.org/viewvc/cordova/site/public/docs/en/edge/guide_platforms_android_upgrading.md.html?rev=1539110&r1=1539109&r2=1539110&view=diff
==============================================================================
--- cordova/site/public/docs/en/edge/guide_platforms_android_upgrading.md.html (original)
+++ cordova/site/public/docs/en/edge/guide_platforms_android_upgrading.md.html Tue Nov  5 19:34:36 2013
@@ -177,16 +177,14 @@ version of the CLI.</p>
 <p>For projects that were created with the cordova CLI: </p>
 
 <ol>
-<li>Update the <code>cordova</code> CLI version - see <a href="guide_cli_index.md.html#The%20Command-line%20Interface">The Command-line Interface</a> </li>
-<li>Run <code>cordova platform update android</code>
-</li>
+<li><p>Update the <code>cordova</code> CLI version. See <a href="guide_cli_index.md.html#The%20Command-line%20Interface">The Command-line Interface</a>.</p></li>
+<li><p>Run <code>cordova platform update android</code></p></li>
 </ol>
 
 <p>For projects not created with the cordova CLI, run:</p>
 
-<ol>
-<li><code>bin/update &lt;project_path&gt;</code></li>
-</ol>
+<pre class="prettyprint"><code>    bin/update &lt;project_path&gt;
+</code></pre>
 
 <h2><a name="Upgrading%20Android_upgrade_to_the_cli_3_0_0_from_2_9_0">Upgrade to the CLI (3.0.0) from 2.9.0</a></h2>
 
@@ -213,8 +211,11 @@ added. Only 3.0.0 plugins are compatible
 <li><p>Copy any native Android assets from your <code>res</code> directory to the new project.</p></li>
 <li><p>Copy over any plugins you installed from the <code>src</code> subdirectories into the new project.</p></li>
 <li><p>Make sure to upgrade any deprecated <code>&lt;plugin&gt;</code> references from your old <code>config.xml</code> file to the new <code>&lt;feature&gt;</code> specification.</p></li>
-<li><p>Update any references to the <code>org.apache.cordova.api</code> package to be <code>org.apache.cordova</code>.</p></li>
-<li><p><strong>NOTE:</strong> all core APIs have been removed and must be installed as plugins. Please see the <a href="plugin_ref_plugman.md.html#Using%20Plugman%20to%20Manage%20Plugins">Using Plugman to Manage Plugins</a> Guide for details.</p></li>
+<li>
+<p>Update any references to the <code>org.apache.cordova.api</code> package to be <code>org.apache.cordova</code>.</p>
+
+<p><strong>NOTE</strong>: all core APIs have been removed and must be installed as plugins. Please see the <a href="plugin_ref_plugman.md.html#Using%20Plugman%20to%20Manage%20Plugins">Using Plugman to Manage Plugins</a> Guide for details.</p>
+</li>
 </ol>
 
 <h2><a name="Upgrading%20Android_upgrade_to_2_9_0_from_2_8_0">Upgrade to 2.9.0 from 2.8.0</a></h2>
@@ -228,7 +229,12 @@ added. Only 3.0.0 plugins are compatible
 <ol>
 <li><p>Remove <code>cordova-2.7.0.jar</code> from the project's <code>libs</code> directory.</p></li>
 <li><p>Add <code>cordova-2.8.0.jar</code> to the project's <code>libs</code> directory.</p></li>
-<li><p>If you are using Eclipse, please refresh your eclipse project and do a clean.</p></li>
+<li><p>If you use Eclipse, please refresh your Eclipse project and do a clean.</p></li>
+</ol>
+
+<!-- SS Eclipse -->
+
+<ol>
 <li><p>Copy the new <code>cordova.js</code> into your project.</p></li>
 <li><p>Update your HTML to use the new <code>cordova.js</code> file.</p></li>
 <li><p>Copy the <code>res/xml/config.xml</code> file to match <code>framework/res/xml/config.xml</code>.</p></li>
@@ -241,7 +247,7 @@ added. Only 3.0.0 plugins are compatible
 <ol>
 <li><p>Remove <code>cordova-2.6.0.jar</code> from the project's <code>libs</code> directory.</p></li>
 <li><p>Add <code>cordova-2.7.0.jar</code> to the project's <code>libs</code> directory.</p></li>
-<li><p>If you are using Eclipse, please refresh your eclipse project and do a clean.</p></li>
+<li><p>If you use Eclipse, please refresh your Eclipse project and do a clean.</p></li>
 <li><p>Copy the new <code>cordova-2.7.0.js</code> into your project.</p></li>
 <li><p>Update your HTML to use the new <code>cordova-2.7.0.js</code> file.</p></li>
 <li><p>Copy the <code>res/xml/config.xml</code> to match <code>framework/res/xml/config.xml</code>.</p></li>
@@ -254,7 +260,7 @@ added. Only 3.0.0 plugins are compatible
 <ol>
 <li><p>Remove <code>cordova-2.5.0.jar</code> from the project's <code>libs</code> directory.</p></li>
 <li><p>Add <code>cordova-2.6.0.jar</code> to the project's <code>libs</code> directory.</p></li>
-<li><p>If you are using Eclipse, please refresh your eclipse project and do a clean.</p></li>
+<li><p>If you use Eclipse, please refresh your Eclipse project and do a clean.</p></li>
 <li><p>Copy the new <code>cordova-2.6.0.js</code> into your project.</p></li>
 <li><p>Update your HTML to use the new <code>cordova-2.6.0.js</code> file.</p></li>
 <li><p>Copy the <code>res/xml/config.xml</code> to match <code>framework/res/xml/config.xml</code>.</p></li>
@@ -269,7 +275,7 @@ added. Only 3.0.0 plugins are compatible
 <ol>
 <li><p>Remove <code>cordova-2.4.0.jar</code> from the project's <code>libs</code> directory.</p></li>
 <li><p>Add <code>cordova-2.5.0.jar</code> to the project's <code>libs</code> directory.</p></li>
-<li><p>If you are using Eclipse, please refresh your eclipse project and do a clean.</p></li>
+<li><p>If you use Eclipse, please refresh your Eclipse project and do a clean.</p></li>
 <li><p>Copy the new <code>cordova-2.5.0.js</code> into your project.</p></li>
 <li><p>Update your HTML to use the new <code>cordova-2.5.0.js</code> file.</p></li>
 <li><p>Copy the <code>res/xml/config.xml</code> to match <code>framework/res/xml/config.xml</code>.</p></li>
@@ -282,7 +288,7 @@ added. Only 3.0.0 plugins are compatible
 <ol>
 <li><p>Remove <code>cordova-2.3.0.jar</code> from the project's <code>libs</code> directory.</p></li>
 <li><p>Add <code>cordova-2.4.0.jar</code> to the project's <code>libs</code> directory.</p></li>
-<li><p>If you are using Eclipse, please refresh your eclipse project and do a clean.</p></li>
+<li><p>If you use Eclipse, please refresh your Eclipse project and do a clean.</p></li>
 <li><p>Copy the new <code>cordova-2.4.0.js</code> into your project.</p></li>
 <li><p>Update your HTML to use the new <code>cordova-2.4.0.js</code> file.</p></li>
 <li><p>Copy the <code>res/xml/config.xml</code> to match <code>framework/res/xml/config.xml</code>.</p></li>
@@ -294,7 +300,7 @@ added. Only 3.0.0 plugins are compatible
 <ol>
 <li><p>Remove <code>cordova-2.2.0.jar</code> from the project's <code>libs</code> directory.</p></li>
 <li><p>Add <code>cordova-2.3.0.jar</code> to the project's <code>libs</code> directory.</p></li>
-<li><p>If you are using Eclipse, please refresh your eclipse project and do a clean.</p></li>
+<li><p>If you use Eclipse, please refresh your Eclipse project and do a clean.</p></li>
 <li><p>Copy the new <code>cordova-2.3.0.js</code> into your project.</p></li>
 <li><p>Update your HTML to use the new <code>cordova-2.3.0.js</code> file.</p></li>
 <li><p>Copy the <code>res/xml/config.xml</code> to match <code>framework/res/xml/config.xml</code>.</p></li>
@@ -306,7 +312,7 @@ added. Only 3.0.0 plugins are compatible
 <ol>
 <li><p>Remove <code>cordova-2.1.0.jar</code> from the project's <code>libs</code> directory.</p></li>
 <li><p>Add <code>cordova-2.2.0.jar</code> to the project's <code>libs</code> directory.</p></li>
-<li><p>If you are using Eclipse, please refresh your eclipse project and do a clean.</p></li>
+<li><p>If you use Eclipse, please refresh your Eclipse project and do a clean.</p></li>
 <li><p>Copy the new <code>cordova-2.2.0.js</code> into your project.</p></li>
 <li><p>Update your HTML to use the new <code>cordova-2.2.0.js</code> file.</p></li>
 <li><p>Copy the <code>res/xml/config.xml</code> to match <code>framework/res/xml/config.xml</code>.</p></li>
@@ -318,7 +324,7 @@ added. Only 3.0.0 plugins are compatible
 <ol>
 <li><p>Remove <code>cordova-2.0.0.jar</code> from the project's <code>libs</code> directory.</p></li>
 <li><p>Add <code>cordova-2.1.0.jar</code> to the project's <code>libs</code> directory.</p></li>
-<li><p>If you are using Eclipse, please refresh your eclipse project and do a clean.</p></li>
+<li><p>If you use Eclipse, please refresh your Eclipse project and do a clean.</p></li>
 <li><p>Copy the new <code>cordova-2.1.0.js</code> into your project.</p></li>
 <li><p>Update your HTML to use the new <code>cordova-2.1.0.js</code> file.</p></li>
 <li><p>Copy the <code>res/xml/config.xml</code> to match <code>framework/res/xml/config.xml</code>.</p></li>
@@ -330,7 +336,7 @@ added. Only 3.0.0 plugins are compatible
 <ol>
 <li><p>Remove <code>cordova-1.9.0.jar</code> from the project's <code>libs</code> directory.</p></li>
 <li><p>Add <code>cordova-2.0.0.jar</code> to the project's <code>libs</code> directory.</p></li>
-<li><p>If you are using Eclipse, please refresh your eclipse project and do a clean.</p></li>
+<li><p>If you use Eclipse, please refresh your Eclipse project and do a clean.</p></li>
 <li><p>Copy the new <code>cordova-2.0.0.js</code> into your project.</p></li>
 <li><p>Update your HTML to use the new <code>cordova-2.0.0.js</code> file.</p></li>
 <li><p>Copy the <code>res/xml/config.xml</code> to match <code>framework/res/xml/config.xml</code>.</p></li>
@@ -338,17 +344,17 @@ added. Only 3.0.0 plugins are compatible
 
 <h3>Notes about 2.0.0 release</h3>
 
-<p><code>config.xml</code> will be replacing <code>cordova.xml</code> and <code>plugins.xml</code>.  This
-new file is a combination of the previous two.  However, the old files
-are deprecated, and while currently still work, will cease working in
-a future release.</p>
+<p>The <code>config.xml</code> file will replace <code>cordova.xml</code> and <code>plugins.xml</code>.
+This new file is a combination of the previous two.  However, the old
+files are deprecated, and while currently still work, will cease
+working in a future release.</p>
 
 <h2><a name="Upgrading%20Android_upgrade_to_1_9_0_from_1_8_1">Upgrade to 1.9.0 from 1.8.1</a></h2>
 
 <ol>
 <li><p>Remove <code>cordova-1.8.0.jar</code> from the project's <code>libs</code> directory.</p></li>
 <li><p>Add <code>cordova-1.9.0.jar</code> to the project's <code>libs</code> directory.</p></li>
-<li><p>If you are using Eclipse, please refresh your eclipse project and do a clean.</p></li>
+<li><p>If you use Eclipse, please refresh your Eclipse project and do a clean.</p></li>
 <li><p>Copy the new <code>cordova-1.9.0.js</code> into your project.</p></li>
 <li><p>Update your HTML to use the new <code>cordova-1.9.0.js</code> file.</p></li>
 <li><p>Update <code>res/xml/plugins.xml</code> to match <code>framework/res/xml/plugins.xml</code>.</p></li>
@@ -367,7 +373,7 @@ maintainer and add this task to their bu
 <ol>
 <li><p>Remove <code>cordova-1.8.0.jar</code> from the project's <code>libs</code> directory.</p></li>
 <li><p>Add <code>cordova-1.8.1.jar</code> to the project's <code>libs</code> directory.</p></li>
-<li><p>If you are using Eclipse, please refresh your eclipse project and do a clean.</p></li>
+<li><p>If you use Eclipse, please refresh your Eclipse project and do a clean.</p></li>
 <li><p>Copy the new <code>cordova-1.8.1.js</code> into your project.</p></li>
 <li><p>Update your HTML to use the new <code>cordova-1.8.1.js</code> file.</p></li>
 <li><p>Update <code>res/xml/plugins.xml</code> to match <code>framework/res/xml/plugins.xml</code>.</p></li>
@@ -378,7 +384,7 @@ maintainer and add this task to their bu
 <ol>
 <li><p>Remove <code>cordova-1.7.0.jar</code> from the project's <code>libs</code> directory.</p></li>
 <li><p>Add <code>cordova-1.8.0.jar</code> to the project's <code>libs</code> directory.</p></li>
-<li><p>If you are using Eclipse, please refresh your eclipse project and do a clean.</p></li>
+<li><p>If you use Eclipse, please refresh your Eclipse project and do a clean.</p></li>
 <li><p>Copy the new <code>cordova-1.8.0.js</code> into your project.</p></li>
 <li><p>Update your HTML to use the new <code>cordova-1.8.0.js</code> file.</p></li>
 <li><p>Update <code>res/xml/plugins.xml</code> to match <code>framework/res/xml/plugins.xml</code>.</p></li>
@@ -389,7 +395,7 @@ maintainer and add this task to their bu
 <ol>
 <li><p>Remove <code>cordova-1.7.0.jar</code> from the project's <code>libs</code> directory.</p></li>
 <li><p>Add <code>cordova-1.8.0.jar</code> to the project's <code>libs</code> directory.</p></li>
-<li><p>If you are using Eclipse, please refresh your eclipse project and do a clean.</p></li>
+<li><p>If you use Eclipse, please refresh your Eclipse project and do a clean.</p></li>
 <li><p>Copy the new <code>cordova-1.8.0.js</code> into your project.</p></li>
 <li><p>Update your HTML to use the new <code>cordova-1.8.0.js</code> file.</p></li>
 <li><p>Update <code>res/xml/plugins.xml</code> to match <code>framework/res/xml/plugins.xml</code>.</p></li>
@@ -400,7 +406,7 @@ maintainer and add this task to their bu
 <ol>
 <li><p>Remove <code>cordova-1.6.1.jar</code> from the project's <code>libs</code> directory.</p></li>
 <li><p>Add <code>cordova-1.7.0.jar</code> to the project's <code>libs</code> directory.</p></li>
-<li><p>If you are using Eclipse, please refresh your eclipse project and do a clean.</p></li>
+<li><p>If you use Eclipse, please refresh your Eclipse project and do a clean.</p></li>
 <li><p>Copy the new <code>cordova-1.7.0.js</code> into your project.</p></li>
 <li><p>Update <code>res/xml/plugins.xml</code> to match <code>framework/res/xml/plugins.xml</code>.</p></li>
 </ol>
@@ -410,7 +416,7 @@ maintainer and add this task to their bu
 <ol>
 <li><p>Remove <code>cordova-1.6.0.jar</code> from the project's <code>libs</code> directory.</p></li>
 <li><p>Add <code>cordova-1.6.1.jar</code> to the project's <code>libs</code> directory.</p></li>
-<li><p>If you are using Eclipse, please refresh your eclipse project and do a clean.</p></li>
+<li><p>If you use Eclipse, please refresh your Eclipse project and do a clean.</p></li>
 <li><p>Copy the new <code>cordova-1.6.1.js</code> into your project.</p></li>
 <li><p>Update <code>res/xml/plugins.xml</code> to match <code>framework/res/xml/plugins.xml</code>.</p></li>
 </ol>
@@ -420,7 +426,7 @@ maintainer and add this task to their bu
 <ol>
 <li><p>Remove <code>cordova-1.5.0.jar</code> from the project's <code>libs</code> directory.</p></li>
 <li><p>Add <code>cordova-1.6.0.jar</code> to the project's <code>libs</code> directory.</p></li>
-<li><p>If you are using Eclipse, please refresh your eclipse project and do a clean.</p></li>
+<li><p>If you use Eclipse, please refresh your Eclipse project and do a clean.</p></li>
 <li><p>Copy the new <code>cordova-1.6.0.js</code> into your project.</p></li>
 <li><p>Update your HTML to use the new <code>cordova-1.6.0.js</code> file.</p></li>
 <li><p>Update <code>res/xml/plugins.xml</code> to match <code>framework/res/xml/plugins.xml</code>.</p></li>
@@ -432,7 +438,7 @@ maintainer and add this task to their bu
 <ol>
 <li><p>Remove <code>phonegap-1.4.0.jar</code> from the project's <code>libs</code> directory.</p></li>
 <li><p>Add <code>cordova-1.5.0.jar</code> to the project's <code>libs</code> directory.</p></li>
-<li><p>If you are using Eclipse, please refresh your eclipse project and do a clean.</p></li>
+<li><p>If you use Eclipse, please refresh your Eclipse project and do a clean.</p></li>
 <li><p>Copy the new <code>cordova-1.5.0.js</code> into your project.</p></li>
 <li><p>Update your HTML to use the new <code>cordova-1.5.0.js</code> file.</p></li>
 <li><p>Update <code>res/xml/plugins.xml</code> to match <code>framework/res/xml/plugins.xml</code>.</p></li>
@@ -444,7 +450,7 @@ maintainer and add this task to their bu
 <ol>
 <li><p>Remove <code>phonegap-1.3.0.jar</code> from the project's <code>libs</code> directory.</p></li>
 <li><p>Add <code>phonegap-1.4.0.jar</code> to the project's <code>libs</code> directory.</p></li>
-<li><p>If you are using Eclipse, please refresh your eclipse project and do a clean.</p></li>
+<li><p>If you use Eclipse, please refresh your Eclipse project and do a clean.</p></li>
 <li><p>Copy the new <code>phonegap-1.4.0.js</code> into your project.</p></li>
 <li><p>Update your HTML to use the new <code>phonegap-1.4.0.js</code> file.</p></li>
 <li><p>Update <code>res/xml/plugins.xml</code> to match <code>framework/res/xml/plugins.xml</code>.</p></li>
@@ -456,7 +462,7 @@ maintainer and add this task to their bu
 <ol>
 <li><p>Remove <code>phonegap-1.2.0.jar</code> from the project's <code>libs</code> directory.</p></li>
 <li><p>Add <code>phonegap-1.3.0.jar</code> to the project's <code>libs</code> directory.</p></li>
-<li><p>If you are using Eclipse, please refresh your eclipse project and do a clean.</p></li>
+<li><p>If you use Eclipse, please refresh your Eclipse project and do a clean.</p></li>
 <li><p>Copy the new <code>phonegap-1.3.0.js</code> into your project.</p></li>
 <li><p>Update your HTML to use the new <code>phonegap-1.2.0.js</code> file.</p></li>
 <li><p>Update <code>res/xml/plugins.xml</code> to match <code>framework/res/xml/plugins.xml</code>.</p></li>
@@ -468,7 +474,7 @@ maintainer and add this task to their bu
 <ol>
 <li><p>Remove <code>phonegap-1.1.0.jar</code> from the project's <code>libs</code> directory.</p></li>
 <li><p>Add <code>phonegap-1.2.0.jar</code> to the project's <code>libs</code> directory.</p></li>
-<li><p>If you are using Eclipse, please refresh your eclipse project and do a clean.</p></li>
+<li><p>If you use Eclipse, please refresh your Eclipse project and do a clean.</p></li>
 <li><p>Copy the new <code>phonegap-1.2.0.js</code> into your project.</p></li>
 <li><p>Update your HTML to use the new <code>phonegap-1.2.0.js</code> file.</p></li>
 <li><p>Update <code>res/xml/plugins.xml</code> to match <code>framework/res/xml/plugins.xml</code>.</p></li>
@@ -480,7 +486,7 @@ maintainer and add this task to their bu
 <ol>
 <li><p>Remove <code>phonegap-1.0.0.jar</code> from the project's <code>libs</code> directory.</p></li>
 <li><p>Add <code>phonegap-1.1.0.jar</code> to the project's <code>libs</code> directory.</p></li>
-<li><p>If you are using Eclipse, please refresh your eclipse project and do a clean.</p></li>
+<li><p>If you use Eclipse, please refresh your Eclipse project and do a clean.</p></li>
 <li><p>Copy the new <code>phonegap-1.1.0.js</code> into your project.</p></li>
 <li><p>Update your HTML to use the new <code>phonegap-1.1.0.js</code> file.</p></li>
 <li><p>Update <code>res/xml/plugins.xml</code> to match <code>framework/res/xml/plugins.xml</code>.</p></li>
@@ -491,7 +497,7 @@ maintainer and add this task to their bu
 <ol>
 <li><p>Remove <code>phonegap-0.9.6.jar</code> from the project's <code>libs</code> directory.</p></li>
 <li><p>Add <code>phonegap-1.0.0.jar</code> to the project's <code>libs</code> directory.</p></li>
-<li><p>If you are using Eclipse, please refresh your eclipse project and do a clean.</p></li>
+<li><p>If you use Eclipse, please refresh your Eclipse project and do a clean.</p></li>
 <li><p>Copy the new <code>phonegap-1.0.0.js</code> into your project.</p></li>
 <li><p>Update your HTML to use the new <code>phonegap-1.0.0.js</code> file.</p></li>
 <li><p>Add the <code>res/xml/plugins.xml</code> to match <code>framework/res/xml/plugins.xml</code>.</p></li>

Modified: cordova/site/public/docs/en/edge/guide_platforms_blackberry10_index.md.html
URL: http://svn.apache.org/viewvc/cordova/site/public/docs/en/edge/guide_platforms_blackberry10_index.md.html?rev=1539110&r1=1539109&r2=1539110&view=diff
==============================================================================
--- cordova/site/public/docs/en/edge/guide_platforms_blackberry10_index.md.html (original)
+++ cordova/site/public/docs/en/edge/guide_platforms_blackberry10_index.md.html Tue Nov  5 19:34:36 2013
@@ -281,8 +281,8 @@ associates a target named <em>emu</em> w
 
 <p>To deploy to a device, make sure it is plugged into your computer.
 Enable development mode and obtain the IP address as desribed in the
-emulator section above. You will also need to obtain the PIN from the
-the <strong>Settings</strong> application under <strong>About → Hardware</strong>:</p>
+emulator section above. You also need to obtain the PIN from the
+<strong>Settings</strong> application under <strong>About → Hardware</strong>:</p>
 
 <p><img src="img/guide/platforms/blackberry10/bb_pin.png" alt="" title=""></p>
 

Modified: cordova/site/public/docs/en/edge/guide_platforms_blackberry10_tools.md.html
URL: http://svn.apache.org/viewvc/cordova/site/public/docs/en/edge/guide_platforms_blackberry10_tools.md.html?rev=1539110&r1=1539109&r2=1539110&view=diff
==============================================================================
--- cordova/site/public/docs/en/edge/guide_platforms_blackberry10_tools.md.html (original)
+++ cordova/site/public/docs/en/edge/guide_platforms_blackberry10_tools.md.html Tue Nov  5 19:34:36 2013
@@ -181,7 +181,7 @@ arguments.</p>
 <li><p><code>&lt;project-name&gt;</code> specifies the apps display name</p></li>
 </ul>
 
-<p><strong>NOTE:</strong> the <code>create</code> command bootstraps dependency installation
+<p><strong>NOTE</strong>: the <code>create</code> command bootstraps dependency installation
 through the <code>npm install</code> command. Depending on the installation
 directory and system permissions, this may require administrator
 privileges.  If there's problem on OSX/Linux, run <code>sudo npm install</code>
@@ -210,7 +210,7 @@ emulator. This is required only if the d
 password protected.</p></li>
 <li><p><code>--pin &lt;device-pin&gt;</code> specifies the PIN of the BlackBerry device,
 which identifies that device as a valid host for the debug
-token. This argument is required only if you are creating a debug
+token. This argument is required only when creating a debug
 token.</p></li>
 </ul>
 
@@ -272,31 +272,24 @@ be one of <code>error</code>, <code>warn
 
 <p>If you have previously defined a default target (and previously
 installed a debug token, if that target is a BlackBerry device), you
-can run the script with no arguments, and the script will package your
-app and deploy it to the default target. For example:</p>
+can run the script with no arguments, and the script packages your
+app and deploys it to the default target. For example:</p>
 
 <pre class="prettyprint"><code>&lt;path-to-project&gt;/cordova/build debug
 </code></pre>
 
 <h2><a name="BlackBerry%2010%20Command-line%20Tools_run">run</a></h2>
 
-<p>The <code>run</code> command deploys the app on the specified BlackBerry device
-or an emulator. Before deploying your app, you must first create a
-target for the device or emulator you want to deploy your app to using
-the target script. The deploy script will deploy the most recent build of your app.</p>
+<p>The <code>run</code> command deploys the app's most recent build on the specified
+BlackBerry device or an emulator. To deploy your app, you need to
+specify a target for the device or emulator:</p>
 
 <pre class="prettyprint"><code>&lt;path-to-project&gt;/cordova/run &lt;target&gt;
 </code></pre>
 
-<p>where</p>
-
-<ul>
-<li>
-<code>&lt;target&gt;</code>specifies the name of a previously added target. If
-<code>&lt;target&gt;</code>is a device, then that device must be connected to your
-computer by USB connection or be connected to the same Wi-Fi network
-as your computer.</li>
-</ul>
+<p>...where <code>&lt;target&gt;</code>specifies the name of a previously added target.
+If <code>&lt;target&gt;</code> is a device, then it must be connected to your computer
+via USB cable, or else over the same Wi-Fi network as your computer.</p>
 
 <h2><a name="BlackBerry%2010%20Command-line%20Tools_plugin">plugin</a></h2>
 

Modified: cordova/site/public/docs/en/edge/guide_platforms_blackberry10_upgrading.md.html
URL: http://svn.apache.org/viewvc/cordova/site/public/docs/en/edge/guide_platforms_blackberry10_upgrading.md.html?rev=1539110&r1=1539109&r2=1539110&view=diff
==============================================================================
--- cordova/site/public/docs/en/edge/guide_platforms_blackberry10_upgrading.md.html (original)
+++ cordova/site/public/docs/en/edge/guide_platforms_blackberry10_upgrading.md.html Tue Nov  5 19:34:36 2013
@@ -170,7 +170,9 @@ platform add blackberry10</code>.</p></l
 at the root of the cordova project you just created.</p></li>
 <li><p>Copy or overwrite any native assets from your original project
 (<code>Resources</code>, etc.)</p></li>
-<li><p>Copy your <code>config.xml</code> into the <code>www</code> directory, and remove any plugin definitions. You will modify settings here instead of the platform directory.</p></li>
+<li><p>Copy the <code>config.xml</code> file into the <code>www</code> directory, and remove any
+plugin definitions. You need to modify settings here rather than
+within the platform directory.</p></li>
 <li><p>Use the cordova CLI tool to install any plugins you need. Note that
 the CLI handles all core APIs as plugins, so they may need to be
 added. Only plugins marked 3.0.0 and above are compatible with the CLI.</p></li>
@@ -190,7 +192,9 @@ platform add blackberry10</code>.</p></l
 at the root of the cordova project you just created.</p></li>
 <li><p>Copy or overwrite any native assets from your original project
 (<code>Resources</code>, etc.)</p></li>
-<li><p>Copy your <code>config.xml</code> into the <code>www</code> directory, and remove any plugin definitions. You will modify settings here instead of the platform directory.</p></li>
+<li><p>Copy the <code>config.xml</code> file into the <code>www</code> directory, and remove any
+plugin definitions. You need to modify settings here rather than
+within the platform directory.</p></li>
 <li><p>Use the cordova CLI tool to install any plugins you need. Note that
 the CLI handles all core APIs as plugins, so they may need to be
 added. Only 3.0.0 plugins are compatible with the CLI.</p></li>

Modified: cordova/site/public/docs/en/edge/guide_platforms_blackberry_index.md.html
URL: http://svn.apache.org/viewvc/cordova/site/public/docs/en/edge/guide_platforms_blackberry_index.md.html?rev=1539110&r1=1539109&r2=1539110&view=diff
==============================================================================
--- cordova/site/public/docs/en/edge/guide_platforms_blackberry_index.md.html (original)
+++ cordova/site/public/docs/en/edge/guide_platforms_blackberry_index.md.html Tue Nov  5 19:34:36 2013
@@ -311,7 +311,7 @@ following to install an application to t
 <p>If you are prompted whether a device is connected to your computer,
 answer no.</p>
 
-<p><strong>NOTE:</strong> On BlackBerry OS 5, the application is installed in the
+<p><strong>NOTE</strong>: On BlackBerry OS 5, the application is installed in the
 <code>Downloads</code> directory.</p>
 
 <h2><a name="BlackBerry%20Platform%20Guide_deploy_to_device">Deploy to Device
@@ -342,7 +342,7 @@ would to view the app in an emulator:</p
 <p>If you are prompted whether a device is connected to your computer,
 answer yes.</p>
 
-<p><strong>NOTE:</strong> On BlackBerry OS 5, the application is installed in the
+<p><strong>NOTE</strong>: On BlackBerry OS 5, the application is installed in the
 <code>Downloads</code> directory.</p>
 
 <h2><a name="BlackBerry%20Platform%20Guide_additional_information">Additional Information</a></h2>

Modified: cordova/site/public/docs/en/edge/guide_platforms_blackberry_tools.md.html
URL: http://svn.apache.org/viewvc/cordova/site/public/docs/en/edge/guide_platforms_blackberry_tools.md.html?rev=1539110&r1=1539109&r2=1539110&view=diff
==============================================================================
--- cordova/site/public/docs/en/edge/guide_platforms_blackberry_tools.md.html (original)
+++ cordova/site/public/docs/en/edge/guide_platforms_blackberry_tools.md.html Tue Nov  5 19:34:36 2013
@@ -170,7 +170,7 @@ name.  Here is the syntax for both Mac a
 $ /path/to/cordova-blackberry-webworks/bin/create.bat /path/to/my_new_project com.example.project_name ProjectName
 </code></pre>
 
-<p><strong>NOTE:</strong> The BlackBerry platform ignores the package name placeholder
+<p><strong>NOTE</strong>: The BlackBerry platform ignores the package name placeholder
 (<code>com.example.project_name</code>), but it's still required for use by
 cross-platform tools.</p>
 

Modified: cordova/site/public/docs/en/edge/guide_platforms_ios_index.md.html
URL: http://svn.apache.org/viewvc/cordova/site/public/docs/en/edge/guide_platforms_ios_index.md.html?rev=1539110&r1=1539109&r2=1539110&view=diff
==============================================================================
--- cordova/site/public/docs/en/edge/guide_platforms_ios_index.md.html (original)
+++ cordova/site/public/docs/en/edge/guide_platforms_ios_index.md.html Tue Nov  5 19:34:36 2013
@@ -284,7 +284,7 @@ on your device.</p></li>
 
 <h2><a name="iOS%20Platform%20Guide_common_problems">Common Problems</a></h2>
 
-<p><strong>Deprecation Warnings:</strong> When an application programming interface
+<p><strong>Deprecation Warnings</strong>: When an application programming interface
 (API) is changed or replaced by another API, it is marked as
 <em>deprecated</em>.  The API still works in the near term, but is eventually
 removed.  Some of these deprecated interfaces are reflected in Apache

Modified: cordova/site/public/docs/en/edge/guide_platforms_ios_upgrading.md.html
URL: http://svn.apache.org/viewvc/cordova/site/public/docs/en/edge/guide_platforms_ios_upgrading.md.html?rev=1539110&r1=1539109&r2=1539110&view=diff
==============================================================================
--- cordova/site/public/docs/en/edge/guide_platforms_ios_upgrading.md.html (original)
+++ cordova/site/public/docs/en/edge/guide_platforms_ios_upgrading.md.html Tue Nov  5 19:34:36 2013
@@ -171,7 +171,7 @@ created with an older set of command-lin
 <code>cordova</code> CLI utility. See <a href="guide_cli_index.md.html#The%20Command-line%20Interface">The Command-line Interface</a> for information
 how to update the version of the CLI.</p>
 
-<p><strong>NOTE:</strong> Xcode 4.6 is required, Xcode 5 is recommended. Currently, to submit to the
+<p><strong>NOTE</strong>: Xcode 4.6 is required, Xcode 5 is recommended. Currently, to submit to the
 Apple App Store, you should use the latest shipped version of the iOS SDK, which is iOS 7.
 iOS 7 SDK is not required yet, but this may change quickly.</p>
 
@@ -182,25 +182,31 @@ iOS 7 SDK is not required yet, but this 
 <pre class="prettyprint"><code>    bin/update path/to/project
 </code></pre>
 
-<p>For CLI projects, run: </p>
+<p>For CLI projects:</p>
 
-<pre class="prettyprint"><code>    1. Update the `cordova` CLI version - see <a href="guide_cli_index.md.html#The%20Command-line%20Interface">The Command-line Interface</a> 
-    2. Run `cordova platform update ios`
-</code></pre>
+<ol>
+<li><p>Update the <code>cordova</code> CLI version. See <a href="guide_cli_index.md.html#The%20Command-line%20Interface">The Command-line Interface</a>.</p></li>
+<li><p>Run <code>cordova platform update ios</code></p></li>
+</ol>
 
 <h3>iOS 7 Issues</h3>
 
-<pre class="prettyprint"><code>1. Remove the values "width=device-width, height=device-height" from your meta tag 
-"viewport" attribute in your index.html file, see https://issues.apache.org/jira/browse/CB-4323
-2. Update your media, media-capture and splashscreen core plugins for iOS 7 support
-</code></pre>
+<ol>
+<li><p>Remove <code>width=device-width, height=device-height</code> from the
+<code>index.html</code> file's <code>viewport</code> <code>meta</code> tag. (See <a class="external" href="https://issues.apache.org/jira/browse/CB-4323">the relevent
+bug</a>.)</p></li>
+<li><p>Update your media, media-capture and splashscreen core plugins for
+iOS 7 support.</p></li>
+</ol>
 
 <h3>Xcode 5 Issues</h3>
 
-<pre class="prettyprint"><code>1. Update your Project Settings if Xcode 5 prompts you to do so (in the Issues Navigator)
-2. Update your "Compiler for C/C++/Objective-C" setting, under the "Build Settings" 
-tab, "Build Options" section. Choose "Default compiler (Apple LLVM 5.0)"
-</code></pre>
+<ol>
+<li><p>Update your Project Settings if Xcode 5 prompts you to do so (in the Issues Navigator).</p></li>
+<li><p>Update your <strong>Compiler for C/C++/Objective-C</strong> setting, under the
+<strong>Build Settings</strong> tab, <strong>Build Options</strong> section. Choose <strong>Default
+compiler (Apple LLVM 5.0)</strong>.</p></li>
+</ol>
 
 <h2><a name="Upgrading%20iOS_upgrade_to_the_cli_3_0_0_from_2_9_0">Upgrade to the CLI (3.0.0) from 2.9.0</a></h2>
 
@@ -235,10 +241,9 @@ added. Only 3.0.0 plugins are compatible
 <li><p>Delete your <code>CordovaLib</code> directory, and copy the <code>CordovaLib</code> directory from the new project into your project's root directory.</p></li>
 </ol>
 
-<p><strong>NOTE:</strong> Starting with Cordova 3.0.0, projects do not come with any
-plugins, you will have to install the ones you require for your
-project using the <code>plugman</code> command-line utility. See <a href="#Using%20Plugman%20to%0AManage%20Plugins">Using Plugman to
-Manage Plugins</a>.</p>
+<p><strong>NOTE</strong>: Starting with Cordova 3.0.0, plugins are not pre-installed,
+and you need to use the <code>plugman</code> command-line utility to install them
+yourself. See <a href="plugin_ref_plugman.md.html#Using%20Plugman%20to%20Manage%20Plugins">Using Plugman to Manage Plugins</a>.</p>
 
 <h2><a name="Upgrading%20iOS_upgrading_2_8_0_projects_to_2_9_0">Upgrading 2.8.0 projects to 2.9.0</a></h2>
 
@@ -262,7 +267,7 @@ Manage Plugins</a>.</p>
 <li><p>Copy the <code>www/cordova.js</code> (note that it does not have a version suffix anymore, the version is in the file itself in the header) file from the new project into your <code>www</code> directory, and delete your <code>www/cordova-2.7.0.js</code> file.</p></li>
 <li><p>Update the Cordova script reference in your <code>www/index.html</code> file (and any other files that contain the script reference) to point to the new <code>cordova.js</code> file.</p></li>
 <li>
-<p>Update any <code>&lt;plugin&gt;</code> tags that are in your <code>config.xml</code> to <code>&lt;feature&gt;</code> tags. Note that existing <code>&lt;plugin&gt;</code> tags will still work, but are deprecated. You can copy this information in the <code>config.xml</code> for a new project. For example:</p>
+<p>Update any <code>&lt;plugin&gt;</code> tags in the <code>config.xml</code> file to <code>&lt;feature&gt;</code> tags. Note that existing <code>&lt;plugin&gt;</code> tags still work, but are deprecated. You can copy this information in the <code>config.xml</code> file for a new project. For example:</p>
 
 <pre class="prettyprint"><code>&lt;plugins&gt;
     &lt;plugin name="LocalStorage" value="CDVLocalStorage" /&gt;
@@ -277,7 +282,7 @@ Manage Plugins</a>.</p>
 &lt;!-- other &lt;feature&gt; tags --&gt;
 </code></pre>
 </li>
-<li><p>Delete your <code>CordovaLib</code> directory, and copy the <code>CordovaLib</code> directory from the new project into your project's root directory.</p></li>
+<li><p>Delete the <code>CordovaLib</code> directory, and copy the <code>CordovaLib</code> directory from the new project into your project's root directory.</p></li>
 <li>
 <p>Add these two frameworks to your project:</p>
 
@@ -351,7 +356,7 @@ ImageIO
 <li><p>In your <code>config.xml</code> file, <a class="external" href="https://git-wip-us.apache.org/repos/asf?p=cordova-ios.git;a=blobdiff;f=bin/templates/project/__TESTING__/config.xml;h=7d67508b70914aa921a16e79f79c00512502a8b6;hp=337d38da6f40c7432b0bce05aa3281d797eec40a;hb=6749c17640c5fed8a7d3a0b9cca204b89a855baa;hpb=deabeeb6fcb35bac9360b053c8bf902b45e6de4d">add this new line</a>.</p></li>
 <li><p>Delete your <code>cordova</code> directory, and copy the <code>cordova</code> directory from the new project into your project's root directory. In 2.4.0, this has fixed scripts.</p></li>
 <li><p>Delete your <code>CordovaLib</code> directory, and copy the <code>CordovaLib</code> directory from the new project into your project's root directory.</p></li>
-<li><p>Add AssetsLibrary.framework as a resource to your project.  (Go <a class="external" href="https://developer.apple.com/library/ios/#recipes/xcode_help-project_editor/Articles/AddingaLibrarytoaTarget.html">here</a> for instructions on how to do so.).</p></li>
+<li><p>Add AssetsLibrary.framework as a resource to your project.  (See <a class="external" href="https://developer.apple.com/library/ios/#recipes/xcode_help-project_editor/Articles/AddingaLibrarytoaTarget.html">Apple's documentation</a> for instructions on how to do so.).</p></li>
 </ol>
 
 <h2><a name="Upgrading%20iOS_upgrading_2_2_0_projects_to_2_3_0">Upgrading 2.2.0 projects to 2.3.0</a></h2>
@@ -373,8 +378,8 @@ ImageIO
 <pre class="prettyprint"><code>&lt;plugin name="<a href="cordova_inappbrowser_inappbrowser.md.html#InAppBrowser">InAppBrowser</a>" value="CDVInAppBrowser" /&gt;
 </code></pre>
 </li>
-<li><p>Note that Objective-C plugins are <em>not</em> whitelisted anymore. To whitelist your connections with the app whitelist, you will need to set the <code>User-Agent</code> header of the connection to the same user-agent as the main Cordova WebView.
-You can get this by accessing the <code>userAgent</code> property off the main view-controller. The main view-controller (CDVViewController) also has a <code>URLisAllowed</code> method for you to check whether a URL will pass the whitelist.</p></li>
+<li><p>Note that Objective-C plugins are <em>not</em> whitelisted anymore. To whitelist your connections with the app whitelist, you need to set the <code>User-Agent</code> header of the connection to the same user-agent as the main Cordova WebView.
+You can get this by accessing the <code>userAgent</code> property off the main view-controller. The main view-controller (<code>CDVViewController</code>) also has a <code>URLisAllowed</code> method for you to check whether a URL passes the whitelist.</p></li>
 <li>
 <p><a href="cordova_device_device.md.html#Device">Device</a> API changes:</p>
 
@@ -418,7 +423,7 @@ You can get this by accessing the <code>
 </li>
 </ol>
 
-<p><strong>NOTE:</strong> In 2.2.0, the <code>bin/create</code> script copy in the <code>CordovaLib</code> sub-project into your project. To have the same kind of setup, just copy in the right <code>CordovaLib</code> into your project directory, and update the <code>CordovaLib</code> sub-project location (relative to the project) in the Xcode <a href="cordova_file_file.md.html#File">File</a> Inspector.</p>
+<p><strong>NOTE</strong>: In 2.2.0, the <code>bin/create</code> script copy in the <code>CordovaLib</code> sub-project into your project. To have the same kind of setup, just copy in the right <code>CordovaLib</code> into your project directory, and update the <code>CordovaLib</code> sub-project location (relative to the project) in the Xcode <a href="cordova_file_file.md.html#File">File</a> Inspector.</p>
 
 <h2><a name="Upgrading%20iOS_upgrading_2_0_0_projects_to_2_1_0">Upgrading 2.0.0 projects to 2.1.0</a></h2>
 
@@ -534,7 +539,7 @@ is <code>CDVDevice</code>.</p></li>
 <li><p>Select the <strong>Run</strong> button.</p></li>
 </ol>
 
-<p><strong>NOTE:</strong> If your project is not working as expected in the Simulator, please take a note of any errors in the console log in Xcode for clues.</p>
+<p><strong>NOTE</strong>: If your project is not working as expected in the Simulator, please take a note of any errors in the console log in Xcode for clues.</p>
 
 <h2><a name="Upgrading%20iOS_upgrading_1_8_x_projects_to_1_9_0">Upgrading 1.8.x projects to 1.9.0</a></h2>
 
@@ -545,7 +550,7 @@ is <code>CDVDevice</code>.</p></li>
 <li><p>Update the Cordova script reference in your <code>www/index.html</code> file (and any other files that contain the script reference) to point to the new <code>cordova-1.9.0.js</code> file.</p></li>
 </ol>
 
-<p><strong>NOTE:</strong> 1.9.0 supports the new <code>BackupWebStorage</code> boolean <code>Cordova.plist</code> setting. It's enabled by default, so set it to
+<p><strong>NOTE</strong>: 1.9.0 supports the new <code>BackupWebStorage</code> boolean <code>Cordova.plist</code> setting. It's enabled by default, so set it to
 <code>false</code> to disable it, especially on iOS 6. See <a class="external" href="https://developer.apple.com/library/prerelease/ios/#releasenotes/General/RN-iOSSDK-6_0/_index.html">Release Notes: Safari and UIKit Section</a></p>
 
 <h2><a name="Upgrading%20iOS_upgrading_1_7_0_projects_to_1_8_x">Upgrading 1.7.0 projects to 1.8.x</a></h2>
@@ -598,7 +603,7 @@ necessary because the core plugin servic
 match the ones from Android and BlackBerry, for a unified Cordova
 JavaScript file (<code>cordova-js</code>).</p></li>
 <li><p>Integrate any settings, <strong>Plugins</strong> and <strong>ExternalHosts</strong> entries that you had in your <strong>backed-up Cordova.plist</strong> into the new <code>Cordova.plist</code>.</p></li>
-<li><p>Integrate any project-specific code that you have in your backed-up <code>AppDelegate.h</code> and <code>AppDelegate.m</code> into the new AppDelegate files. Any <code>UIWebViewDelegate</code> or <code>CDVCommandDelegate</code> code in <code>AppDelegate.m</code> will need to go into <code>MainViewController.m</code> now (see commented out sections in that file).</p></li>
+<li><p>Integrate any project-specific code that you have in your backed-up <code>AppDelegate.h</code> and <code>AppDelegate.m</code> into the new <code>AppDelegate</code> files. Any <code>UIWebViewDelegate</code> or <code>CDVCommandDelegate</code> code in <code>AppDelegate.m</code> needs to go into <code>MainViewController.m</code> now (see commented-out sections in that file).</p></li>
 <li><p>Integrate any project-specific code that you have in your backed-up <code>MainViewController.h</code> and <code>MainViewController.m</code> into the new MainViewController files.</p></li>
 <li><p>Click on the project icon in the Project Navigator, select your <strong>Project</strong>, then select the <strong>Build Settings</strong> tab.</p></li>
 <li><p>Enter <strong>Compiler for C/C++/Objective-C</strong> in the search field.</p></li>
@@ -647,7 +652,7 @@ JavaScript file (<code>cordova-js</code>
 for the Replace string, then press the <strong>Replace All</strong> button.</p></li>
 <li><p>Enter <strong>PG</strong> for the Find string, and <strong>CDV</strong> for the Replace
 string, then press the <strong>Replace All</strong> button.</p></li>
-<li><p>Press <strong>Command-B</strong> to build, you will still have deprecations
+<li><p>Press <strong>Command-B</strong> to build. You still have deprecations
 that you can get rid of in the future (see <code>CDVDeprecated.h</code>. For
 example, replace classes in your code that use PG* to CDV*).</p></li>
 </ol>

Modified: cordova/site/public/docs/en/edge/guide_platforms_wp7_index.md.html
URL: http://svn.apache.org/viewvc/cordova/site/public/docs/en/edge/guide_platforms_wp7_index.md.html?rev=1539110&r1=1539109&r2=1539110&view=diff
==============================================================================
--- cordova/site/public/docs/en/edge/guide_platforms_wp7_index.md.html (original)
+++ cordova/site/public/docs/en/edge/guide_platforms_wp7_index.md.html Tue Nov  5 19:34:36 2013
@@ -177,7 +177,7 @@ version is recommended for running a dev
 Center</a> account if you want
 to install an app on a real device or submit it to Market Place.</p>
 
-<p><strong>NOTE:</strong> Running the SDK in Virtual Machine may present challenges.
+<p><strong>NOTE</strong>: Running the SDK in Virtual Machine may present challenges.
 Read <a class="external" href="http://aka.ms/BuildaWP8apponaMac">Windows Phone on a Mac</a> for
 insights on developing solutions.</p>
 
@@ -187,7 +187,7 @@ insights on developing solutions.</p>
 SDK</a>.</p>
 
 <p>Download and extract the latest copy of
-<a class="external" href="http://phonegap.com/download">Cordova</a>. You will be working in the
+<a class="external" href="http://phonegap.com/download">Cordova</a>. You need to work in the
 <code>lib\windows-phone-8\wp7</code> subdirectory, <code>lib\windows-phone-8\wp8</code>
 contains the Windwos Phone 8 version of Cordova.</p>
 
@@ -196,7 +196,7 @@ Studio 2012\Templates\ProjectTemplates\<
 
 <h2><a name="Windows%20Phone%207%20Platform%20Guide_building_the_template">Building the Template</a></h2>
 
-<p><strong>NOTE:</strong> Skip this step if the <code>lib\windows-phone</code> directory already
+<p><strong>NOTE</strong>: Skip this step if the <code>lib\windows-phone</code> directory already
 contains a <code>CordovaWP7_x_x_x.zip</code> file.</p>
 
 <p>To simplify development, Cordova bundles a script to build Visual
@@ -248,7 +248,7 @@ vary depending on installed version:</p>
 
 <p>Before testing your application on a device, the device must be
 registered. Consult
-[Microsoft's documentation][http://msdn.microsoft.com/en-us/library/windowsphone/develop/ff402565(v=vs.105).aspx]
+<a class="external" href="http://msdn.microsoft.com/en-us/library/windowsphone/develop/ff402565(v=vs.105">Microsoft's documentation</a>.aspx)
 for details on how to deploy and test on Windows Phone 7. These are
 the basic steps:</p>
 

Modified: cordova/site/public/docs/en/edge/guide_platforms_wp8_index.md.html
URL: http://svn.apache.org/viewvc/cordova/site/public/docs/en/edge/guide_platforms_wp8_index.md.html?rev=1539110&r1=1539109&r2=1539110&view=diff
==============================================================================
--- cordova/site/public/docs/en/edge/guide_platforms_wp8_index.md.html (original)
+++ cordova/site/public/docs/en/edge/guide_platforms_wp8_index.md.html Tue Nov  5 19:34:36 2013
@@ -220,7 +220,7 @@ current interface.</p>
 <li><p>Register and pay for a <a class="external" href="http://dev.windowsphone.com/en-us/publish">Windows Phone Dev Center</a> account if you want to install your app on a real device or submit it to Market Place.</p></li>
 </ul>
 
-<p><strong>NOTE:</strong> Running the SDK in Virtual Machine might present some challenges. You can read this blog post that gives insight on the solutions to develop for <a class="external" href="http://aka.ms/BuildaWP8apponaMac">Windows Phone on a Mac</a>.</p>
+<p><strong>NOTE</strong>: Running the SDK in Virtual Machine might present some challenges. You can read this blog post that gives insight on the solutions to develop for <a class="external" href="http://aka.ms/BuildaWP8apponaMac">Windows Phone on a Mac</a>.</p>
 
 <h2><a name="Windows%20Phone%208%20Platform%20Guide_install_sdk_and_cordova">Install SDK and Cordova</a></h2>
 
@@ -229,14 +229,14 @@ SDK</a>.</p>
 
 <p>Download and extract the latest copy of
 <a class="external" href="http://phonegap.com/download">Cordova</a>. The <code>lib\windows-phone-8\wp8</code>
-subdirectory is where you will do your work.</p>
+subdirectory is where you need to do your work.</p>
 
 <p>Copy the <code>CordovaWP8_x_x_x.zip</code> file to the <code>\My Documents\Visual
 Studio 2012\Templates\ProjectTemplates\</code> directory.</p>
 
 <h2><a name="Windows%20Phone%208%20Platform%20Guide_building_the_template">Building the Template</a></h2>
 
-<p><strong>NOTE:</strong> Skip this step if the <code>lib\windows-phone</code> directory already
+<p><strong>NOTE</strong>: Skip this step if the <code>lib\windows-phone</code> directory already
 contains a <code>CordovaWP8_x_x_x.zip</code> file.</p>
 
 <p>To simplify development, Cordova bundles a script to build Visual
@@ -298,7 +298,7 @@ start debugging, or type <strong>F5</str
 
 <p>Before testing your application on a device, the device must be
 registered. Consult
-[Microsoft's documentation][http://msdn.microsoft.com/en-us/library/windowsphone/develop/ff402565(v=vs.105).aspx]
+<a class="external" href="http://msdn.microsoft.com/en-us/library/windowsphone/develop/ff402565(v=vs.105">Microsoft's documentation</a>.aspx)
 for details on how to deploy and test on Windows Phone 8. These are
 the basic steps:</p>
 

Modified: cordova/site/public/docs/en/edge/guide_platforms_wp8_tools.md.html
URL: http://svn.apache.org/viewvc/cordova/site/public/docs/en/edge/guide_platforms_wp8_tools.md.html?rev=1539110&r1=1539109&r2=1539110&view=diff
==============================================================================
--- cordova/site/public/docs/en/edge/guide_platforms_wp8_tools.md.html (original)
+++ cordova/site/public/docs/en/edge/guide_platforms_wp8_tools.md.html Tue Nov  5 19:34:36 2013
@@ -177,8 +177,14 @@ repo has subdirectories for each: <code>
 <h3>Run the batch file to create and install the templates.</h3>
 
 <ul>
-<li><p>The root of the repo contains a file createTemplates.bat.  Double clicking this file will generate 2 .zip files. (CordovaWP7<em>x</em>x<em>x.zip + CordovaWP8</em>x<em>x</em>x.zip where x.x.x is the current version number)  To easily use these files in Visual Studio, copy them to 
-"My Documents\Visual Studio 2012\Templates\ProjectTemplates\" You will then be able to create new Apache Cordova Windows Phone apps from the Visual Studio <a href="cordova_file_file.md.html#File">File</a>-&gt;New Project menu.</p></li>
+<li><p>The root of the repo contains a <code>createTemplates.bat</code> file.
+Double-clicking it generates two <code>.zip</code> files:
+<code>CordovaWP7_x_x_x.zip</code> and <code>CordovaWP8_x_x_x.zip</code>, where <em>x.x.x</em>
+represents the current version number. To easily use these files in
+Visual Studio, copy them to <code>My Documents\Visual Studio
+2012\Templates\ProjectTemplates\</code>. You are then able to create
+new Apache Cordova Windows Phone apps from Visual Studio's
+<strong><a href="cordova_file_file.md.html#File">File</a> → New Project</strong> menu.</p></li>
 <li><p>If you run the batch file from the command line, you can also call with a parameter to install automatically</p></li>
 </ul>
 
@@ -237,7 +243,7 @@ name.  Here is the syntax for both Windo
 </li>
 </ul>
 
-<p>By default the <code>run</code> command will be called with <code>--emulator --debug</code> if flags are not provided.</p>
+<p>By default the <code>run</code> command is called with <code>--emulator --debug</code> if flags are not provided.</p>
 
 <h2><a name="Windows%20Phone%20Command-line%20Tools_cleaning">Cleaning</a></h2>
 

Modified: cordova/site/public/docs/en/edge/guide_platforms_wp8_upgrading.md.html
URL: http://svn.apache.org/viewvc/cordova/site/public/docs/en/edge/guide_platforms_wp8_upgrading.md.html?rev=1539110&r1=1539109&r2=1539110&view=diff
==============================================================================
--- cordova/site/public/docs/en/edge/guide_platforms_wp8_upgrading.md.html (original)
+++ cordova/site/public/docs/en/edge/guide_platforms_wp8_upgrading.md.html Tue Nov  5 19:34:36 2013
@@ -177,15 +177,14 @@ projects.</p>
 <p>For projects that were created with the cordova CLI: </p>
 
 <ol>
-<li>Update the <code>cordova</code> CLI version - see <a href="guide_cli_index.md.html#The%20Command-line%20Interface">The Command-line Interface</a> </li>
-<li>Run <code>cordova platform update wp8</code> (or <code>wp7</code>, per the platforms you added to your project).</li>
+<li><p>Update the <code>cordova</code> CLI version. See <a href="guide_cli_index.md.html#The%20Command-line%20Interface">The Command-line Interface</a>. </p></li>
+<li><p>Run <code>cordova platform update wp8</code> (or <code>wp7</code>, per the platforms you added to your project).</p></li>
 </ol>
 
 <p>For projects not created with the cordova CLI, run:</p>
 
-<ol>
-<li><code>bin\update &lt;project_path&gt;</code></li>
-</ol>
+<pre class="prettyprint"><code>    bin\update &lt;project_path&gt;
+</code></pre>
 
 <h2><a name="Upgrading%20Windows%20Phone_upgrade_to_the_cli_3_0_0_from_2_9_0">Upgrade to the CLI (3.0.0) from 2.9.0</a></h2>
 
@@ -218,7 +217,7 @@ added. Only 3.0.0 plugins are compatible
 <li><p>Build and test.</p></li>
 </ol>
 
-<p><strong>NOTE:</strong> all core APIs are removed from Cordova version 3.0, and must
+<p><strong>NOTE</strong>: all core APIs are removed from Cordova version 3.0, and must
 be installed separately as plugins.  For more information on how to
 re-enable these features in a non-CLI workflow, see <a href="#Using%20Plugman%20to%0AManage%20Plugins">Using Plugman to
 Manage Plugins</a>.</p>
@@ -366,10 +365,7 @@ Manage Plugins</a>.</p>
 <li>
 <p>Navigate to the new distribution and add the <code>WP7CordovaClassLib.dll</code> file.</p>
 
-<ul>
-<li>
-<strong>NOTE:</strong> You can view the DLL's version by right-clicking on the reference, and selecting <strong>Properties</strong>.</li>
-</ul>
+<p><strong>NOTE</strong>: You can view the DLL's version by right-clicking on the reference, and selecting <strong>Properties</strong>.</p>
 </li>
 <li><p>Copy the new <code>cordova-1.9.0.js</code> into your project. (Be sure it is marked as Content.)</p></li>
 <li><p>Update your HTML to use the new <code>cordova-1.9.0.js</code> file.</p></li>
@@ -386,10 +382,7 @@ Manage Plugins</a>.</p>
 <li>
 <p>Navigate to the new distribution and add the <code>WP7CordovaClassLib.dll</code> file.</p>
 
-<ul>
-<li>
-<strong>NOTE:</strong> You can view the DLL's version by right-clicking on the reference, and selecting <strong>Properties</strong>.</li>
-</ul>
+<p><strong>NOTE</strong>: You can view the DLL's version by right-clicking on the reference, and selecting <strong>Properties</strong>.</p>
 </li>
 <li><p>Copy the new <code>cordova-1.8.0.js</code> into your project. (Be sure it is marked as Content.)</p></li>
 <li><p>Update your HTML to use the new <code>cordova-1.8.0.js</code> file.</p></li>
@@ -406,10 +399,7 @@ Manage Plugins</a>.</p>
 <li>
 <p>Navigate to the new distribution and add the <code>WP7CordovaClassLib.dll</code> file.</p>
 
-<ul>
-<li>
-<strong>NOTE:</strong> You can view the DLL's version by right-clicking on the reference, and selecting <strong>Properties</strong>.</li>
-</ul>
+<p><strong>NOTE</strong>: You can view the DLL's version by right-clicking on the reference, and selecting <strong>Properties</strong>.</p>
 </li>
 <li><p>Copy the new <code>cordova-1.7.0.js</code> into your project. (Be sure it is marked as Content.)</p></li>
 <li><p>Update your HTML to use the new <code>cordova-1.7.0.js</code> file.</p></li>
@@ -426,10 +416,7 @@ Manage Plugins</a>.</p>
 <li>
 <p>Navigate to the new distribution and add the <code>WP7CordovaClassLib.dll</code> file.</p>
 
-<ul>
-<li>
-<strong>NOTE:</strong> You can view the DLL's version by right-clicking on the reference, and selecting <strong>Properties</strong>.</li>
-</ul>
+<p><strong>NOTE</strong>: You can view the DLL's version by right-clicking on the reference, and selecting <strong>Properties</strong>.</p>
 </li>
 <li><p>Copy the new <code>cordova-1.6.1.js</code> into your project. (Be sure it is marked as Content.)</p></li>
 <li><p>Update your HTML to use the new <code>cordova-1.6.1.js</code> file.</p></li>
@@ -446,10 +433,7 @@ Manage Plugins</a>.</p>
 <li>
 <p>Navigate to the new distribution and add the <code>WP7CordovaClassLib.dll</code> file.</p>
 
-<ul>
-<li>
-<strong>NOTE:</strong> You can view the DLL's version by right-clicking on the reference, and selecting <strong>Properties</strong>.</li>
-</ul>
+<p><strong>NOTE</strong>: You can view the DLL's version by right-clicking on the reference, and selecting <strong>Properties</strong>.</p>
 </li>
 <li><p>Copy the new <code>cordova-1.6.0.js</code> into your project. (Be sure it is marked as Content.)</p></li>
 <li><p>Update your HTML to use the new <code>cordova-1.6.0.js</code> file.</p></li>
@@ -466,10 +450,7 @@ Manage Plugins</a>.</p>
 <li>
 <p>Navigate to the new distribution and add the <code>WP7CordovaClassLib.dll</code> file.</p>
 
-<ul>
-<li>
-<strong>NOTE:</strong> You can view the DLL's version by right-clicking on the reference, and selecting <strong>Properties</strong>.</li>
-</ul>
+<p><strong>NOTE</strong>: You can view the DLL's version by right-clicking on the reference, and selecting <strong>Properties</strong>.</p>
 </li>
 <li><p>Copy the new <code>cordova-1.5.0.js</code> into your project. (Be sure it is marked as Content.)</p></li>
 <li><p>Update your HTML to use the new <code>cordova-1.5.0.js</code> file.</p></li>
@@ -486,10 +467,7 @@ Manage Plugins</a>.</p>
 <li>
 <p>Navigate to the new distribution and add the <code>WP7CordovaClassLib.dll</code> file.</p>
 
-<ul>
-<li>
-<strong>NOTE:</strong> You can view the DLL's version by right-clicking on the reference, and selecting <strong>Properties</strong>.</li>
-</ul>
+<p><strong>NOTE</strong>: You can view the DLL's version by right-clicking on the reference, and selecting <strong>Properties</strong>.</p>
 </li>
 <li><p>Copy the new <code>cordova-1.4.0.js</code> into your project. (Be sure it is marked as Content.)</p></li>
 <li><p>Update your HTML to use the new <code>cordova-1.4.0.js</code> file.</p></li>
@@ -506,10 +484,7 @@ Manage Plugins</a>.</p>
 <li>
 <p>Navigate to the new distribution and add the <code>WP7CordovaClassLib.dll</code> file.</p>
 
-<ul>
-<li>
-<strong>NOTE:</strong> You can view the DLL's version by right-clicking on the reference, and selecting <strong>Properties</strong>.</li>
-</ul>
+<p><strong>NOTE</strong>: You can view the DLL's version by right-clicking on the reference, and selecting <strong>Properties</strong>.</p>
 </li>
 <li><p>Copy the new <code>cordova-1.3.0.js</code> into your project. (Be sure it is marked as Content.)</p></li>
 <li><p>Update your HTML to use the new <code>cordova-1.3.0.js</code> file.</p></li>
@@ -526,10 +501,7 @@ Manage Plugins</a>.</p>
 <li>
 <p>Navigate to the new distribution and add the <code>WP7CordovaClassLib.dll</code> file.</p>
 
-<ul>
-<li>
-<strong>NOTE:</strong> You can view the DLL's version by right-clicking on the reference, and selecting <strong>Properties</strong>.</li>
-</ul>
+<p><strong>NOTE</strong>: You can view the DLL's version by right-clicking on the reference, and selecting <strong>Properties</strong>.</p>
 </li>
 <li><p>Copy the new <code>cordova-1.2.0.js</code> into your project. (Be sure it is marked as Content.)</p></li>
 <li><p>Update your HTML to use the new <code>cordova-1.2.0.js</code> file.</p></li>
@@ -546,10 +518,7 @@ Manage Plugins</a>.</p>
 <li>
 <p>Navigate to the new distribution and add the <code>WP7CordovaClassLib.dll</code> file.</p>
 
-<ul>
-<li>
-<strong>NOTE:</strong> you can view the DLL's version by right-clicking on the reference, and selecting <strong>Properties</strong>.</li>
-</ul>
+<p><strong>NOTE</strong>: you can view the DLL's version by right-clicking on the reference, and selecting <strong>Properties</strong>.</p>
 </li>
 <li><p>Copy the new <code>cordova-1.1.0.js</code> into your project. (Be sure it is marked as Content.)</p></li>
 <li><p>Update your HTML to use the new <code>cordova-1.1.0.js</code> file.</p></li>

Modified: cordova/site/public/docs/en/edge/guide_support_index.md.html
URL: http://svn.apache.org/viewvc/cordova/site/public/docs/en/edge/guide_support_index.md.html?rev=1539110&r1=1539109&r2=1539110&view=diff
==============================================================================
--- cordova/site/public/docs/en/edge/guide_support_index.md.html (original)
+++ cordova/site/public/docs/en/edge/guide_support_index.md.html Tue Nov  5 19:34:36 2013
@@ -179,7 +179,7 @@ CLI's shorthand stubs.)</p>
         <td data-col="ios" class="y">Mac</td>
         <td data-col="winphone7" class="y">Windows</td>
         <td data-col="winphone8" class="y">Windows</td>
-        <td data-col="win8" class="n"></td>
+        <td data-col="win8" class="y"></td>
 <!--        <td data-col="firefoxos"  class="n"></td> -->
         <td data-col="tizen" class="n"></td>
     </tr>
@@ -204,8 +204,8 @@ CLI's shorthand stubs.)</p>
         <td data-col="blackberry10" class="y"><a href="guide_guide_platforms_blackberry10_plugin.md.html">(see details)</a></td>
         <td data-col="ios" class="y"><a href="guide_guide_platforms_ios_plugin.md.html">(see details)</a></td>
         <td data-col="winphone7" class="y"><a href="guide_guide_platforms_wp8_plugin.md.html">(see details)</a></td>
-        <td data-col="winphone8" class="y"></td>
-        <td data-col="win8" class="n"></td>
+        <td data-col="winphone8" class="y"><a href="guide_guide_platforms_wp8_plugin.md.html">(see details)</a></td>
+        <td data-col="win8" class="y"></td>
 <!--        <td data-col="firefoxos"  class="n"></td> -->
         <td data-col="tizen" class="n"></td>
     </tr>
@@ -288,7 +288,7 @@ CLI's shorthand stubs.)</p>
         <td data-col="ios" class="y"></td>
         <td data-col="winphone7" class="y"></td>
         <td data-col="winphone8" class="y"></td>
-        <td data-col="win8" class="y"></td>
+        <td data-col="win8" class="n"></td>
 <!--        <td data-col="firefoxos"  class="n"></td> -->
         <td data-col="tizen" class="n"></td>
     </tr>
@@ -325,10 +325,8 @@ CLI's shorthand stubs.)</p>
         <td data-col="blackberry" class="y"></td>
         <td data-col="blackberry10" class="y"></td>
         <td data-col="ios" class="y"></td>
-        <td data-col="winphone7" class="p">no <a href="cordova_file_file.md.html#FileTransfer">FileTransfer</a>
-</td>
-        <td data-col="winphone8" class="p">no <a href="cordova_file_file.md.html#FileTransfer">FileTransfer</a>
-</td>
+        <td data-col="winphone7" class="y"></td>
+        <td data-col="winphone8" class="y"></td>
         <td data-col="win8" class="y"></td>
 <!--        <td data-col="firefoxos"  class="n"></td> -->
         <td data-col="tizen" class="n"></td>
@@ -353,7 +351,7 @@ CLI's shorthand stubs.)</p>
         <td data-col="blackberry" class="y"></td>
         <td data-col="blackberry10" class="n"></td>
         <td data-col="ios" class="y"></td>
-        <td data-col="winphone7" class="n"></td>
+        <td data-col="winphone7" class="y"></td>
         <td data-col="winphone8" class="y"></td>
         <td data-col="win8" class="n"></td>
 <!--        <td data-col="firefoxos"  class="n"></td> -->
@@ -368,7 +366,7 @@ CLI's shorthand stubs.)</p>
         <td data-col="ios" class="y"></td>
         <td data-col="winphone7" class="y"></td>
         <td data-col="winphone8" class="y"></td>
-        <td data-col="win8" class="n"></td>
+        <td data-col="win8" class="p">uses iframe</td>
 <!--        <td data-col="firefoxos"  class="n"></td> -->
         <td data-col="tizen" class="n"></td>
     </tr>
@@ -418,9 +416,9 @@ CLI's shorthand stubs.)</p>
         <td data-col="blackberry" class="y"></td>
         <td data-col="blackberry10" class="y"></td>
         <td data-col="ios" class="y"></td>
-        <td data-col="winphone7" class="p">localStorage only</td>
-        <td data-col="winphone8" class="p">localStorage only</td>
-        <td data-col="win8" class="y"></td>
+        <td data-col="winphone7" class="y">localStorage &amp; indexedDB</td>
+        <td data-col="winphone8" class="y">localStorage &amp; indexedDB</td>
+        <td data-col="win8" class="y">localStorage &amp; indexedDB</td>
 <!--        <td data-col="firefoxos"  class="n"></td> -->
         <td data-col="tizen" class="y"></td>
     </tr>

Modified: cordova/site/public/docs/en/edge/plugin_ref_spec.md.html
URL: http://svn.apache.org/viewvc/cordova/site/public/docs/en/edge/plugin_ref_spec.md.html?rev=1539110&r1=1539109&r2=1539110&view=diff
==============================================================================
--- cordova/site/public/docs/en/edge/plugin_ref_spec.md.html (original)
+++ cordova/site/public/docs/en/edge/plugin_ref_spec.md.html Tue Nov  5 19:34:36 2013
@@ -467,7 +467,7 @@ platform-specific JavaScript module bind
 <h2><a name="Plugin%20Specification_dependency_element">
 dependency element</a></h2>
 
-<p>The <code>&lt;dependency&gt;</code> tag allows you specify other plugins on which the
+<p>The <code>&lt;dependency&gt;</code> tag allows you to specify other plugins on which the
 current plugin depends. While future versions will access them from
 plugin repositories, in the short term plugins are directly referenced
 as URLs by <code>&lt;dependency&gt;</code> tags. They are formatted as follows:</p>
@@ -562,7 +562,7 @@ should be installed into a project. Exam
 <ul>
 <li><p><code>src</code> (required):
 Location of the file relative to <code>plugin.xml</code>.  If the <code>src</code> file
-cannot be found, plugman stops and reverses the installation, issues
+can't be found, plugman stops and reverses the installation, issues
 a notification about the problem, and exits with a non-zero code.</p></li>
 <li>
 <p><code>target-dir</code>:
@@ -705,7 +705,7 @@ Examples:</p>
 <ul>
 <li><p><code>src</code> (required):
 The location of the file relative to <code>plugin.xml</code>.
-If <code>src</code> cannot be found, plugman stops and reverses the
+If <code>src</code> can't be found, plugman stops and reverses the
 installation, issues a warning about the problem, and exits with a
 non-zero code.</p></li>
 <li><p><code>arch</code>: The architecture for which the <code>.so</code> file has been built,



Mime
View raw message