cordova-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From fil...@apache.org
Subject android commit: [CB-4463] Updated bin/check_reqs to looks for android-18 target.Also fixed an issue in unix version of script that would invoke the `android` command if an error occurred.
Date Wed, 31 Jul 2013 00:14:52 GMT
Updated Branches:
  refs/heads/master 2bdc849c2 -> c2c5f7101


[CB-4463] Updated bin/check_reqs to looks for android-18 target.Also fixed an issue in unix
version of script that would invoke the `android` command if an error occurred.


Project: http://git-wip-us.apache.org/repos/asf/cordova-android/repo
Commit: http://git-wip-us.apache.org/repos/asf/cordova-android/commit/c2c5f710
Tree: http://git-wip-us.apache.org/repos/asf/cordova-android/tree/c2c5f710
Diff: http://git-wip-us.apache.org/repos/asf/cordova-android/diff/c2c5f710

Branch: refs/heads/master
Commit: c2c5f71018a6821388e2516a6084818453b82de0
Parents: 2bdc849
Author: Fil Maj <maj.fil@gmail.com>
Authored: Tue Jul 30 17:14:46 2013 -0700
Committer: Fil Maj <maj.fil@gmail.com>
Committed: Tue Jul 30 17:14:46 2013 -0700

----------------------------------------------------------------------
 bin/check_reqs    | 10 +++++-----
 bin/check_reqs.js |  8 ++++----
 2 files changed, 9 insertions(+), 9 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/cordova-android/blob/c2c5f710/bin/check_reqs
----------------------------------------------------------------------
diff --git a/bin/check_reqs b/bin/check_reqs
index 0032778..cdc3fda 100755
--- a/bin/check_reqs
+++ b/bin/check_reqs
@@ -19,16 +19,16 @@
 ROOT="$( cd "$( dirname "$0" )/.." && pwd )"
 cmd=`android list target`
 if [[ $? != 0 ]]; then
-    echo "The command `android` failed. Make sure you have the latest Android SDK installed,
and the `android` command (inside the tools/ folder) added to your path."
+    echo "The command \"android\" failed. Make sure you have the latest Android SDK installed,
and the \"android\" command (inside the tools/ folder) added to your path."
     exit 2
-elif [[ ! $cmd =~ "android-17" ]]; then
-    echo "Please install Android target 17 (the Android 4.2 SDK). Make sure you have the
latest Android tools installed as well. Run `android` from your command-line to install/update
any missing SDKs or tools."
+elif [[ ! $cmd =~ "android-18" ]]; then
+    echo "Please install Android target 18 (the Android 4.3 SDK). Make sure you have the
latest Android tools installed as well. Run \"android\" from your command-line to install/update
any missing SDKs or tools."
     exit 2
 else
-    cmd="android update project -p $ROOT -t android-17 1> /dev/null 2>&1"
+    cmd="android update project -p $ROOT -t android-18 1> /dev/null 2>&1"
     eval $cmd
     if [[ $? != 0 ]]; then
         echo "Error updating the Cordova library to work with your Android environment."
         exit 2
     fi
-fi
\ No newline at end of file
+fi

http://git-wip-us.apache.org/repos/asf/cordova-android/blob/c2c5f710/bin/check_reqs.js
----------------------------------------------------------------------
diff --git a/bin/check_reqs.js b/bin/check_reqs.js
index ef30991..7fc32b8 100644
--- a/bin/check_reqs.js
+++ b/bin/check_reqs.js
@@ -63,13 +63,13 @@ function check_requirements() {
         Log('The command `android` failed. Make sure you have the latest Android SDK installed,
and the `android` command (inside the tools/ folder) added to your path. Output: ' + result.output,
true);
         WScript.Quit(2);
     }
-    else if(!result.output.match(/android[-]17/)) {
-        Log('Please install Android target 17 (the Android 4.2 SDK). Make sure you have the
latest Android tools installed as well. Run `android` from your command-line to install/update
any missing SDKs or tools.', true);
+    else if(!result.output.match(/android[-]18/)) {
+        Log('Please install Android target 18 (the Android 4.3 SDK). Make sure you have the
latest Android tools installed as well. Run `android` from your command-line to install/update
any missing SDKs or tools.', true);
         Log('Output : ' + result.output);
         WScript.Quit(2);
     }
     else {
-        var cmd = '%comspec% /c android update project -p ' + ROOT + '\\framework -t android-17';
+        var cmd = '%comspec% /c android update project -p ' + ROOT + '\\framework -t android-18';
         result = exec_out(cmd);
         if(result.error) {
             Log('Error updating the Cordova library to work with your Android environment.
Command run: "' + cmd + '", output: ' + result.output, true);
@@ -78,4 +78,4 @@ function check_requirements() {
     }
 }
 
-check_requirements();
\ No newline at end of file
+check_requirements();


Mime
View raw message