continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Fetzer <>
Subject Re: Ant Build Failing in Continuum
Date Fri, 05 Oct 2012 21:47:38 GMT
I wish I could Alf.  It doesn't throw any errors.  It brings the server to its knees as soon
as it hits the parallel task and continuum stops responding.  I end up having to restart
the continuum service.  When I run it in Unix from the command line with the exact same command,
exact same user, it works fine.  I did a -d and it's using the same version of Ant and Java. 
All it is trying to do is multi-thread the <antcall> task.  I'm going to try to create
a simple repro multi threading antcall with simple tasks rather than resource intensive tasks
and see if it does the same.

----- Original Message -----
From: Alf Potgieter <>
To: "" <>
Sent: Friday, October 5, 2012 12:12 AM
Subject: RE: Ant Build Failing in Continuum

Eric, continuum shouldn't be interfering with whatever happens inside ant...
Can you run the build with debug information (ant -d) and post the error traces at the end?
I suspect you are building with a different ant or java version when you are inside continuum.


-----Original Message-----
From: Eric Fetzer [] 
Sent: Friday 05 October 2012 03:17 AM
Subject: Re: Ant Build Failing in Continuum

Thanks for your reply Louis!  At least I don't feel like I'm talking to myself anymore ;0). 
Are there any project developers on here that may want a simple repro?

On Oct 4, 2012, at 6:24 PM, Louis Smith <> wrote:

> There are folks here, I'm guessing that none of us have a setup as you
> describe.  We only use Maven builds - not ANT - and we don't even use
> buildagents - just a dedicated build machine.  So I'm not familiar at all
> with the multi-threading ANT setup you have.  Sorry.
> Louis
> On Thu, Oct 4, 2012 at 2:41 PM, Eric Fetzer <> wrote:
>> No takers?  Is this forum monitored at all since Wendy left?
>> On Oct 2, 2012, at 5:16 PM, Eric Fetzer <> wrote:
>>> All,
>>> We have an ant build that we're running in continuum that seems to fail
>> only when multi-threading.  When we turn off multi-threading (set
>> threadcount to 1), it succeeds.  Is there an issue in continuum with
>> multi-threading?  Using the following for parallel threads:
>>>  <target name="Build All Applications">
>>>      <parallel threadcount="4">
>>>          <antcall target="myTarget1" />
>>>          <antcall target="myTarget2" />
>>>          <antcall target="myTarget3" />
>>>      </parallel>
>>>  </target>
>>> Thanks,
>>> Eric
> -- 
> Dr. Louis Smith, ThD
> Chief Technology Officer, Kyra InfoTech
> Engineer-in-Training, Veterans Memorial Railroad
Discovery is an authorised financial services provider.

The information in this email is confidential and may have legal privileges. We intend it
only for the use of the individual or entity we've addressed the communication to. If you
have received this email by mistake please delete it and tell the sender. We forbid any unauthorised
use, change, disclosure or sending of the contents of this email (including its attachments),
whether in part or as a whole, unless consented to in writing by the sender, as it may be

We cannot guarantee this email has no malicious coding. 

We reserve the right to check, intercept and block emails or take any other action according
to our email etiquette. 

Discovery will not be liable for any delivery delay, loss, harm, disruption or data corruption
that may arise from this email.

A full list of company directors is available on our website at:
- or to get this list by email, please email

View raw message