continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Louis Smith <dr.louis.sm...@gmail.com>
Subject Re: Setting appserver.base for RHEL 6
Date Thu, 08 Mar 2012 21:09:36 GMT
We placed this in the geronimo.sh file itself:

GERONIMO_OPTS="-Dappserver.base=/opt/geronimo/current/var/catalina
-Dappserver.home=/opt/geronimo/current/var/catalina"

Louis

On Thu, Mar 8, 2012 at 4:01 PM, John DeStefano <john.destefano@gmail.com>wrote:

> Hi,
>
> Even after hard-coding the Tomcat path in every Continuum file I could
> find that referenced an application/appserver/catalina variable, I
> still see related errors in catalina.out:
>
> Mar 8, 2012 11:53:04 AM org.apache.catalina.startup.HostConfig
> deployDescriptor
> INFO: Deploying configuration descriptor continuum.xml
> Could not resolve placeholder 'appserver.base' in
> [file:${appserver.base}/conf/continuum.xml] as system property:
> neither system property nor environment variable found
>
> The webapp seems to load, but now two stray directories based on
> variable names (`$` and `${appserver.base}`) are being created in
> Tomcat's home on start.
>
> I should note that I've changed the file referenced above
> (conf/continuum.xml) to point to the absolute Tomcat path, so either
> this placeholder is coming from elsewhere, or the variable information
> has been cached and not updated.
>
> ~John
>
> On Wed, Mar 7, 2012 at 4:58 PM, John DeStefano <john.destefano@gmail.com>
> wrote:
> > Hi,
> >
> > I'm trying to migrate a few Tomcat webapps from RHEL 5 to RHEL 6.2,
> > and as with other Apache webapps, I'm having trouble with getting the
> > latest Continuum .WAR running, likely because Tomcat 6.0.24 in RHEL
> > 6.2 no longer permits loading of environment variables via setenv.sh,
> > as was done previously: Tomcat 6 for RHEL does not ship with this file
> > and does not honor it on start.  As a result, on Tomcat start,
> > Continuum creates a directory in what was previously known as
> > $CATALINA_HOME called `${appserver.base}`, attempts to populate this
> > directory, and fails to load, with little feedback that I can find
> > (catalina.out simply says "INFO: Deploying configuration descriptor
> > continuum.xml").
> >
> > Is there a workaround to this?  I was able to get another webapp
> > (Archiva) working by hard-coding some paths in a few XML files, but
> > this doesn't seem to help in this case.
> >
> > Thank you,
> > ~John
>



-- 
Dr. Louis Smith, ThD
Chief Technology Officer, Kyra InfoTech
Colonel, Commemorative Air Force

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message