continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From B o d h a y a n C h a k r a b o r t y <bodhay...@gmail.com>
Subject Email notifications not being sent
Date Wed, 11 May 2011 22:36:48 GMT
Hi,

I am using Continuum 1.3.7, Continuum build agent 1.3.7, Maven 3.0 and jdk
1.6.0_17. When I am enabling distributed build from the Continuum
configuration page, I see that email notifications are not being sent. Email
notifications are being sent when I disable distributed build. I am
configuring notifiers in the pom.xml file. When I am adding that project to
Continuum, I see the configured email id in the Notifiers section of Project
Information page. But if distributed build is emabled and when I start a
build, the email id is being removed from the Notifiers section. I still see
the <ciManagement><Notifiers> section in the pom.xml file under the working
copy.

The email id still remains at the Notifiers section of Project Information
page, if I disable distributed build.

If I add any email id from the Project Group Summary > Notifiers > Project
group notifiers section, emails are being sent to that email id even if
distributed build is enabled.

I tried this with Continuum 1.3.4 and 1.4.0 also with no luck. Is this a
bug? Please help.

This is the ciManagement section of my pom.xml.

     <ciManagement>
        <system>continuum</system>
        <url>http://server.url/continuum</url>
        <notifiers>
            <notifier>
                <type>mail</type>
                <sendOnError>true</sendOnError>
                <sendOnFailure>true</sendOnFailure>
                <sendOnSuccess>true</sendOnSuccess>
                <sendOnWarning>true</sendOnWarning>
                <configuration>
                    <address><email.id></address>
                </configuration>
            </notifier>
        </notifiers>
    </ciManagement>

Thanks,
Bodhayan.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message