continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From murali mohan <muralih...@gmail.com>
Subject Re: Build starts, but not queued or executed. No history.
Date Mon, 21 Mar 2011 11:15:54 GMT
Hello,

So I found that the builds were indeed running. But they were hanging and
being closed/killed as thye complete their timeout period.

The problem was that there was no build history in the Conintuum UI. But, I
could find corresponding logs in the build-output-directory which helped me
find out that it was my application DB problem which i have fixed now.

The problem here was that the builds were not showing up in the UI. Not
sure, if the development team would consider it a bug?

PS: can somebody please confirm that these emails are being delivered to the
right audience. I have not seen any response, so wondering if something is
wrong.

thanks,
Murali.

On Mon, Mar 14, 2011 at 10:54 AM, murali mohan <muralihere@gmail.com> wrote:

> Hello,
>
> Anybody? Any suggestions?
>
> This is now being very unpredictable. Some builds run and some don't. I do
> not find any error messages or stack traces in the logs. Is there anything I
> need to check?
>
> The problem is only with shell builds. All the maven2 builds execute
> without any issues. There are many builds happening, 2 parallel queues.
>
> I am looking for directions which I can take to analyze or understand the
> root cause.
>
> thanks,
> Murali.
>
>
>
> On Wed, Mar 9, 2011 at 5:23 PM, murali mohan <muralihere@gmail.com> wrote:
>
>> Hello,
>>
>> Continuum Version - 1.3.6
>> O/S -Ubuntu
>> Deployed in Tomcat 5.
>>
>> This particular build has been running every night without any issues. For
>> the last 2 days, a couple of builds have started disappearing. I have pasted
>> the log messages from Continuum.log files below. Comparing these logs with a
>> Successful Build, I can see that some log messages are missing which
>> indicates the exit code etc (I have pasted those missing messages too). What
>> is happening? Shouldn't there be these missing messages?
>>
>> I do not see any build history for this build in the last 2 days. It is
>> present for days before that. When I run the build now, say by clicking
>> Build Now Button, it runs fine. Please suggest how to debug this. I have
>> checked the Catalina.out log too, but it does not seem to have anything
>> worth reporting.
>>
>> thanks in advance,
>> Murali.
>>
>> Logs for the failed build
>> ==================
>> 2011-03-08 23:35:00,016 [continuumScheduler_Worker-4] INFO
>> org.apache.maven.continuum.build.settings.DefaultSchedulesActivator  -
>> >>>>>>>>>>>>>>>>>>>>>
Executing build job (CLEAN_DB_CORE_MAINT)...
>> 2011-03-08 23:35:00,052 [continuumScheduler_Worker-4] INFO
>> org.apache.continuum.buildmanager.ParallelBuildsManager  - Queueing
>> prepare-build-project task
>> 'org.apache.continuum.taskqueue.PrepareBuildProjectsTask@72' to
>> prepare-build queue.
>> 2011-03-08 23:35:00,052 [pool-9-thread-1] INFO
>> org.apache.maven.continuum.scm.queue.PrepareBuildProjectsTaskExecutor  -
>> Initializing prepare build
>> 2011-03-08 23:35:00,097 [pool-9-thread-1] INFO
>> org.apache.maven.continuum.scm.queue.PrepareBuildProjectsTaskExecutor  -
>> Starting prepare build of project: Maint_Core_Tests_Install
>> 2011-03-08 23:35:00,099 [pool-9-thread-1] INFO
>> org.apache.maven.continuum.scm.queue.PrepareBuildProjectsTaskExecutor  -
>> Updating working dir
>> 2011-03-08 23:35:00,099 [pool-9-thread-1] INFO
>> org.apache.maven.continuum.scm.queue.PrepareBuildProjectsTaskExecutor  -
>> Performing action check-working-directory
>> 2011-03-08 23:35:00,100 [pool-9-thread-1] INFO
>> org.apache.maven.continuum.scm.queue.PrepareBuildProjectsTaskExecutor  -
>> Performing action update-working-directory-from-scm
>> 2011-03-08 23:35:00,123 [pool-9-thread-1] INFO
>> action#update-working-directory-from-scm  - Updating project:
>> Maint_Core_Tests_Install', id: '56' to
>> '/home/continuum/continuumDirectories/trunk/working-directory/56'.
>> 2011-03-08 23:35:00,144 [pool-9-thread-1] INFO
>> org.apache.continuum.scm.manager.Slf4jScmLogger  - Executing: /bin/sh -c cd
>> /home/continuum/continuumDirectories/trunk/working-directory/56 && svn
>> --username murali --password '*****' --non-interactive update
>> /home/continuum/continuumDirectories/trunk/working-directory/56
>> 2011-03-08 23:35:00,144 [pool-9-thread-1] INFO
>> org.apache.continuum.scm.manager.Slf4jScmLogger  - Working directory:
>> /home/continuum/continuumDirectories/trunk/working-directory/56
>> 2011-03-08 23:35:01,067 [pool-9-thread-1] INFO
>> org.apache.maven.continuum.scm.queue.PrepareBuildProjectsTaskExecutor  -
>> Merging SCM results
>> 2011-03-08 23:35:01,067 [pool-9-thread-1] INFO
>> org.apache.maven.continuum.scm.queue.PrepareBuildProjectsTaskExecutor  -
>> Ending prepare build of project: Maint_Core_Tests_Install
>> 2011-03-08 23:35:01,067 [pool-9-thread-1] INFO
>> org.apache.maven.continuum.scm.queue.PrepareBuildProjectsTaskExecutor  -
>> Ending prepare build
>> 2011-03-08 23:35:01,084 [pool-9-thread-1] INFO
>> org.apache.maven.continuum.notification.mail.MailContinuumNotifier  -
>> Message Subject: '[continuum] PREPARE BUILD SUCCESSFUL:
>> Bidcenter-Core-Maint'.
>> 2011-03-08 23:35:01,084 [pool-9-thread-1] INFO
>> org.apache.maven.continuum.notification.mail.MailContinuumNotifier  -
>> Sending message: From '"Continuum@lambo" <continuum@lambo>'.
>> 2011-03-08 23:35:01,093 [pool-9-thread-1] INFO
>> org.apache.maven.continuum.scm.queue.PrepareBuildProjectsTaskExecutor  -
>> Performing action create-build-project-task
>> 2011-03-08 23:35:01,101 [pool-9-thread-1] INFO
>> org.apache.continuum.buildmanager.ParallelBuildsManager  - Project '56' -
>> 'Maint_Core_Tests_Install' added to overall build queue 'MAINT_BUILD_QUEUE'.
>> 2011-03-08 23:35:01,102 [pool-3-thread-4] INFO
>> org.apache.maven.continuum.buildcontroller.DefaultBuildController  -
>> Initializing build
>> 2011-03-08 23:35:01,118 [pool-3-thread-4] INFO
>> org.apache.maven.continuum.buildcontroller.DefaultBuildController  -
>> Starting build of Maint_Core_Tests_Install
>> 2011-03-08 23:35:01,142 [pool-3-thread-4] INFO
>> org.apache.maven.continuum.buildcontroller.DefaultBuildController  -
>> AlwaysBuild configured, building
>> 2011-03-08 23:35:01,142 [pool-3-thread-4] INFO
>> org.apache.maven.continuum.buildcontroller.DefaultBuildController  -
>> Performing action update-project-from-working-directory
>> 2011-03-08 23:35:01,148 [pool-3-thread-4] INFO
>> action#update-project-from-working-directory  - Updating project
>> 'Maint_Core_Tests_Install' from checkout.
>> 2011-03-08 23:35:01,159 [pool-3-thread-4] INFO
>> org.apache.maven.continuum.buildcontroller.DefaultBuildController  -
>> Performing action execute-builder
>>
>>
>>
>> Logs Missing compared to Successful builds
>> ===================================
>> 011-03-09 02:05:01,234 [pool-3-thread-8] INFO
>> org.apache.continuum.utils.shell.DefaultShellCommandHelper  - Executing:
>> /bin/sh -c cd
>> /home/continuum/continuumDirectories/trunk/working-directory/56 &&
>> cleandb2Continuum_maint2.sh
>> 2011-03-09 02:05:01,234 [pool-3-thread-8] INFO
>> org.apache.continuum.utils.shell.DefaultShellCommandHelper  - Working
>> directory: /home/continuum/continuumDirectories/trunk/working-directory/56
>> 2011-03-09 02:07:18,766 [pool-3-thread-8] INFO
>> org.apache.maven.continuum.execution.shell.ShellBuildExecutor  - Exit code:
>> 0
>>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message