continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gwen Harold Autencio <gwenharol...@yahoo.com>
Subject Re: Rob - 503 error
Date Fri, 11 Mar 2011 09:49:35 GMT
Hi Rob,

Here's what I've done in my local. Installating continuum-1.3.7 war in tomcat 6 with email
config.
1. Extracted the war in the <TOMCAT_6_DIR>/webapps folder and renamed it to "continuum"
2. Created "continuum.xml" file in <TOMCAT_6_DIR>/conf/Catalina/localhost
*********
<Context path="/continuum" docBase="<YOUR_TOMCAT_6_DIR>/webapps/continuum-webapp-1.3.7.war">
<Resource name="jdbc/users"
auth="Container"
type="javax.sql.DataSource"
username="sa"
password=""
driverClassName="org.apache.derby.jdbc.EmbeddedDriver"
url="jdbc:derby:<YOUR_TOMCAT_6_DIR>/database/users;create=true" />
<Resource name="jdbc/continuum"
auth="Container"
type="javax.sql.DataSource"
username="sa"
password=""
driverClassName="org.apache.derby.jdbc.EmbeddedDriver"
url="jdbc:derby:<YOUR_TOMCAT_6_DIR>/database/continuum;create=true" />
<Resource name="mail/Session"
auth="Container"
type="javax.mail.Session"
mail.transport.protocol="smtp"
mail.smtp.host="smtp.gmail.com"
mail.smtp.port="465"
mail.smtp.auth="true"
mail.smtp.user="YOUREMAIL@gmail.com"
password="YOURPASSWORD"
mail.smtp.starttls.enable="true"
mail.smtp.socketFactory.class="javax.net.ssl.SSLSocketFactory"/>

</Context>
**********

Add the mail and derby jars in <TOMCAT_6_DIR>/lib

You can try to read more on the documentation here:
http://continuum.apache.org/docs/1.3.7/installation/tomcat.html

Thanks,
Gwen

--- On Fri, 3/11/11, Robert Edge <roberte45@gmail.com> wrote:

From: Robert Edge <roberte45@gmail.com>
Subject: Re: Rob - 503 error
To: users@continuum.apache.org
Date: Friday, March 11, 2011, 12:28 PM

Its a new installation.  This is actually the second standalone
installation.  1.3.6 was the first one, and it ended up doing the same thing
to me.
Then I installed a new copy onto my existing tomcat 6 server and I had no
problems with it.  But, I could not get the mail notification to work on the
war version which I guess was a problem that wouldn't be fixed until 1.4.0
so I went back to standalone.
That's when I installed the standalone 1.3.7 and it worked fine for 4
weeks.  Then now this 503 error with the following stack trace.  I really
wish i could get this working for my school project.  Is there any fix for
mail notification on the war version?
I hadn't changed any values in the configurations in the db before starting.

-Rob




      

Mime
View raw message