continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Fetzer <elstonk...@yahoo.com>
Subject Re: Ant Build Failing
Date Mon, 31 Jan 2011 20:56:14 GMT
Note that my workaround achieves the same results as Louis's, it turns the build 
status from "Building" to "Failed".




________________________________
From: Eric Fetzer <elstonkers@yahoo.com>
To: users@continuum.apache.org
Sent: Mon, January 31, 2011 1:52:07 PM
Subject: Re: Ant Build Failing

OK, so I found another workaround.  I went to the build history and deleted the 
last recorded build and then kicked off another build.  That succeeded.  Not 
sure if this will help, but it worked.

Thanks,
Eric




________________________________
From: Eric Fetzer <elstonkers@yahoo.com>
To: users@continuum.apache.org
Sent: Mon, January 31, 2011 1:37:34 PM
Subject: Re: Ant Build Failing

Yes Wendy, I cancel the build but it doesn't do a thing.  A build log never 
shows up in the build history.  Louis describes it very well except I don't know 


how to do what he's doing in the database.  Louis, can you give me instructions 
on this workaround?




________________________________
From: Louis Smith <dr.louis.smith@gmail.com>
To: users@continuum.apache.org
Sent: Mon, January 31, 2011 1:16:18 PM
Subject: Re: Ant Build Failing

Oh good.  It isn't just me.  I have the same situation, but with a maven 2
build.

No, they don't cancel.  They just disappear - Continuum shows the "in
process" icon, no log entries are written.

I too see the checkout/update in the log, but the build just never actually
starts.

We have to hit the MySQL database and update the status back to "2" so we
can re-submit.  And it will frequently work again.

Louis


On Mon, Jan 31, 2011 at 3:08 PM, Wendy Smoak <wsmoak@gmail.com> wrote:

> On Mon, Jan 31, 2011 at 3:04 PM, Eric Fetzer <elstonkers@yahoo.com> wrote:
> > I have 2 Ant builds setup to be built by continuum.  They are the same
> projects
> > but from 2 different views in StarTeam.  They were both working fine and
> then
> > all-of-a-sudden, one stopped working and I can't get it to succeed
> again.  It
> > checks out the code successfully, but never kicks off the build (I've
> checked
> > for the process in unix).  I see the process for checking out the code,
> then
> > nothing for the build itself.  The continuum display shows the build in
> progress
> > indefinitely.  I've tried failing the build, but it will never go out of
> > "building" status.  Any help out there?
>
> What shows up in the Continuum log file when this happens?
>
> By 'failing the build' I assume you mean canceling?  Again there
> should be something in the log if things are going wrong.
>
> --
> Wendy
>



-- 
Dr. Louis Smith, ThD
Chief Technology Officer, Kyra InfoTech
Colonel, Commemorative Air Force


      
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message