continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wendy Smoak <wsm...@gmail.com>
Subject Re: Maven throwing error being built by continuum but not from command line
Date Wed, 25 Aug 2010 17:05:17 GMT
On Wed, Aug 25, 2010 at 12:54 PM, Eric Fetzer <elstonkers@yahoo.com> wrote:
> I reveive the following error when attempting to build a project from continuum
> using Maven.  The error does not happen when built from the command line.
>
>
> [INFO] ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO] ------------------------------------------------------------------------
> [INFO] An Ant BuildException has occured:
> /home/continuum/apache-continuum-1.3.6/data/working-directory/myProject-client-ria/src/main/flex/assets
>  does not exist.
...
> The thing that confuses me is, why is it looking in
> data/working-directory/myProject-client-ria..., when just before this error, it
> was working in /data/working-directory/25/target/myProject-client-ria?  Seems it
> is in the completely wrong place.  Any help?

I'm guessing that your build tries to get something out of another
module using a relative path.

In Continuum, by default, each module is checked out into a separate
numbered directory.  Maven modules are intended to stand alone,
sharing is done through the repository.

If that's the problem and you can't fix the build so it works, then
you might want to try the options for checking out in a single
directory that you see when adding a project.

-- 
Wendy

Mime
View raw message