continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wendy Smoak <wsm...@gmail.com>
Subject Re: Problem when acessing Continuum
Date Tue, 18 May 2010 12:40:04 GMT
On Thu, May 13, 2010 at 11:03 AM, Bruno Antunes <bema@dei.uc.pt> wrote:
> I'm using Continuum 1.3.6 on a Tomcat 6.0.20 server and a MySQL database.
>
> Whenever I don't access Continuum for some time, when I open the main page I
> get a strange error. If I reload the page this error disappears and
> Continuum works just fine. This happens over and over. I'm also using
> Archiva and the same happens. I suppose it is something related with
> database access.
>
> Do you have any idea on what could be causing this error?
>
> The error I get is:
>
> Error Occured
> org.codehaus.plexus.redback.users.UserManagerException: Unable to get object
> 'org.codehaus.plexus.redback.users.jdo.JdoUser', id 'guest', fetch-group
> 'null' from jdo store.

>From the stack trace, it's a problem in Redback, which both Continuum
and Archiva use to handle user auth.

If it's repeatable, go ahead and open a JIRA issue (if there isn't one already).

But we need more details.  When you say you don't access it for a long
time and then open the main page... are you logged in and then letting
it sit for a while?  By open the page, do you mean in a fresh browser
window, or are you refreshing an old one?

How did you set it up for the alternate MySQL database?

Can you try the latest 1.4.0 and see if it still happens there?

-- 
Wendy

Mime
View raw message