continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wendy Smoak <wsm...@gmail.com>
Subject Re: Distributed Builds Always Use Same Agent
Date Thu, 01 Oct 2009 22:18:10 GMT
On Thu, Oct 1, 2009 at 1:30 PM, George Snyder <George.Snyder@arrisi.com> wrote:

> I am trying to set up Continuum 1.3.4 to run certain builds on SunOS
> machines and other builds on Linux machines.  However, when I enable
> Distributed Builds, all builds seem to run on the first enabled build agent.

I wasn't able to reproduce this.  I set up two build defs with
different environments (which have different agent groups) and forced
builds on each definition went to the correct agent.

One thing I will suggest is re-starting.  We recently found that the
continuum.xml file isn't getting updated when you change things
through the UI, so depending on what you were doing, it's possible
that the config file is out of sync.  Stopping Continuum will cause it
to update that file, and it will be read in on startup.

> Also, http://continuum.apache.org/docs/1.3.4/installation/build-agent.html
> says:
>  "Note that all of your agents need to be identical, as there is no way to
>  control which agent Continuum chooses.."

I think that's old info, from before the 'Build Agent Group' feature
was introduced.  Prior to groups, you had no control over what agent
your project would build on.  Can you open an issue to get that
corrected?

-- 
Wendy

Mime
View raw message